summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-08-06 15:06:42 +0000
committerTorsten Veller <tove@gentoo.org>2012-08-06 15:06:42 +0000
commitde413a4026affc1cc85c16b6ad511cc8f3054e95 (patch)
tree2c98b3932df8c6608b9bf1b032336cfe2dce2bc3 /dev-perl/Alien-SDL/Alien-SDL-1.436.0.ebuild
parentwhitespace (diff)
downloadgentoo-2-de413a4026affc1cc85c16b6ad511cc8f3054e95.tar.gz
gentoo-2-de413a4026affc1cc85c16b6ad511cc8f3054e95.tar.bz2
gentoo-2-de413a4026affc1cc85c16b6ad511cc8f3054e95.zip
[bump] dev-perl/Alien-SDL-1.436.0
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/Alien-SDL/Alien-SDL-1.436.0.ebuild')
-rw-r--r--dev-perl/Alien-SDL/Alien-SDL-1.436.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Alien-SDL/Alien-SDL-1.436.0.ebuild b/dev-perl/Alien-SDL/Alien-SDL-1.436.0.ebuild
new file mode 100644
index 000000000000..d118b55f54c3
--- /dev/null
+++ b/dev-perl/Alien-SDL/Alien-SDL-1.436.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Alien-SDL/Alien-SDL-1.436.0.ebuild,v 1.1 2012/08/06 15:06:42 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=FROGGS
+MODULE_VERSION=1.436
+inherit perl-module
+
+DESCRIPTION="building, finding and using SDL binaries"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE=""
+
+# Archive::Extract, File::Fetch, File::Find, Test::More -> dev-lang/perl
+RDEPEND="dev-perl/Archive-Zip
+ dev-perl/Capture-Tiny
+ dev-perl/File-ShareDir
+ dev-perl/File-Which
+ dev-perl/Text-Patch
+ media-libs/libsdl
+ virtual/perl-Archive-Tar
+ virtual/perl-Digest-SHA
+ virtual/perl-ExtUtils-CBuilder
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-Module-Build
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp"
+DEPEND=${RDEPEND}
+
+SRC_TEST=do
+myconf='--with-sdl-config'