summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-11-18 14:07:47 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-11-18 14:07:47 +0000
commitcefeb4ad68c1d3a3b630913397248b8f3c886d86 (patch)
treeaee2c70c54ea01c59f1940d63c483ce84ccd2af4 /dev-ml
parentInitial commit, based on ebuild in enlightenment overlay (diff)
downloadgentoo-2-cefeb4ad68c1d3a3b630913397248b8f3c886d86.tar.gz
gentoo-2-cefeb4ad68c1d3a3b630913397248b8f3c886d86.tar.bz2
gentoo-2-cefeb4ad68c1d3a3b630913397248b8f3c886d86.zip
version bump
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlp5/ChangeLog7
-rw-r--r--dev-ml/camlp5/camlp5-6.02.0.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ml/camlp5/ChangeLog b/dev-ml/camlp5/ChangeLog
index 2ca455dfbc8f..05d7afc095c7 100644
--- a/dev-ml/camlp5/ChangeLog
+++ b/dev-ml/camlp5/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camlp5
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.49 2010/09/29 13:14:26 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.50 2010/11/18 14:07:47 aballier Exp $
+
+*camlp5-6.02.0 (18 Nov 2010)
+
+ 18 Nov 2010; Alexis Ballier <aballier@gentoo.org> +camlp5-6.02.0.ebuild:
+ version bump
29 Sep 2010; Alexis Ballier <aballier@gentoo.org> -camlp5-5.12.ebuild,
-camlp5-5.13.ebuild:
diff --git a/dev-ml/camlp5/camlp5-6.02.0.ebuild b/dev-ml/camlp5/camlp5-6.02.0.ebuild
new file mode 100644
index 000000000000..eee15a7d3ae7
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-6.02.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-6.02.0.ebuild,v 1.1 2010/11/18 14:07:47 aballier Exp $
+
+EAPI="2"
+
+inherit multilib findlib
+
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/camlp5/"
+SRC_URI="http://pauillac.inria.fr/~ddr/camlp5/distrib/src/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ ./configure \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile(){
+ emake || die "emake failed"
+ if use ocamlopt; then
+ emake opt || die "Compiling native code programs failed"
+ emake opt.opt || die "Compiling native code programs failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META || die "failed to install META file for findlib support"
+
+ use doc && dohtml -r doc/*
+
+ dodoc CHANGES DEVEL ICHANGES README UPGRADING MODE
+}