summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-01-01 22:09:32 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-01-01 22:09:32 +0000
commit84d46bbcb9eb7c00a935c0fae96ce320b09d999d (patch)
tree50343e476f2ae4731a113cdb195b5f328e8a68f6 /dev-ml
parentStable on amd64 wrt bug #349801 (diff)
downloadgentoo-2-84d46bbcb9eb7c00a935c0fae96ce320b09d999d.tar.gz
gentoo-2-84d46bbcb9eb7c00a935c0fae96ce320b09d999d.tar.bz2
gentoo-2-84d46bbcb9eb7c00a935c0fae96ce320b09d999d.zip
version bump
(Portage version: 2.2.0_alpha11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/postgresql-ocaml/ChangeLog10
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-1.14.0.ebuild42
2 files changed, 50 insertions, 2 deletions
diff --git a/dev-ml/postgresql-ocaml/ChangeLog b/dev-ml/postgresql-ocaml/ChangeLog
index bbe8422aa5a8..5dd9f9cab569 100644
--- a/dev-ml/postgresql-ocaml/ChangeLog
+++ b/dev-ml/postgresql-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/postgresql-ocaml
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.19 2010/12/16 21:46:33 aballier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.20 2011/01/01 22:09:32 aballier Exp $
+
+*postgresql-ocaml-1.14.0 (01 Jan 2011)
+
+ 01 Jan 2011; Alexis Ballier <aballier@gentoo.org>
+ +postgresql-ocaml-1.14.0.ebuild:
+ version bump
*postgresql-ocaml-1.13.1 (16 Dec 2010)
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-1.14.0.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.14.0.ebuild
new file mode 100644
index 000000000000..de144f00a293
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.14.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-1.14.0.ebuild,v 1.1 2011/01/01 22:09:32 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+IUSE="examples +ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases."
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.gz"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#toc9"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ dev-db/postgresql-base
+ dev-db/postgresql-server"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile() {
+ cd "${S}/lib"
+ emake -j1 byte-code-library || die "failed to build byte code library"
+ if use ocamlopt; then
+ emake -j1 native-code-library || die "failed to built nativde code library"
+ fi
+}
+
+src_install () {
+ use ocamlopt || export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_preinst
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS Changelog README.txt
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}