summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-03-27 18:15:39 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-03-27 18:15:39 +0000
commit836ebbd4bfeba03d77bab744e91110bc3340e726 (patch)
tree247bc7ae05a85274744cda845e694e0bab78b0bc /dev-ml
parentocamlnet httpd useflag (diff)
downloadgentoo-2-836ebbd4bfeba03d77bab744e91110bc3340e726.tar.gz
gentoo-2-836ebbd4bfeba03d77bab744e91110bc3340e726.tar.bz2
gentoo-2-836ebbd4bfeba03d77bab744e91110bc3340e726.zip
Version bump, thanks to Pierre Clairambault, bug #114277
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlnet/ChangeLog8
-rw-r--r--dev-ml/ocamlnet/files/digest-ocamlnet-2.2.43
-rw-r--r--dev-ml/ocamlnet/files/ocamlnet-2.2.4-configure-fix.patch222
-rw-r--r--dev-ml/ocamlnet/ocamlnet-2.2.4.ebuild54
4 files changed, 286 insertions, 1 deletions
diff --git a/dev-ml/ocamlnet/ChangeLog b/dev-ml/ocamlnet/ChangeLog
index 5cd14ea086f6..5c579903e5ae 100644
--- a/dev-ml/ocamlnet/ChangeLog
+++ b/dev-ml/ocamlnet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocamlnet
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.15 2007/02/09 02:48:46 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.16 2007/03/27 18:15:39 aballier Exp $
+
+*ocamlnet-2.2.4 (27 Mar 2007)
+
+ 27 Mar 2007; Alexis Ballier <aballier@gentoo.org>
+ +files/ocamlnet-2.2.4-configure-fix.patch, +ocamlnet-2.2.4.ebuild:
+ Version bump, thanks to Pierre Clairambault, bug #114277
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/dev-ml/ocamlnet/files/digest-ocamlnet-2.2.4 b/dev-ml/ocamlnet/files/digest-ocamlnet-2.2.4
new file mode 100644
index 000000000000..374d0b57a445
--- /dev/null
+++ b/dev-ml/ocamlnet/files/digest-ocamlnet-2.2.4
@@ -0,0 +1,3 @@
+MD5 5805641c5d4f4e6da1b4fc1008c41f0e ocamlnet-2.2.4.tar.gz 1770863
+RMD160 a8cf56de5e9806570689022dbe58b2d7ca003b87 ocamlnet-2.2.4.tar.gz 1770863
+SHA256 5d43d3c6529c99069b88708f90896cfa6682ceea25b23b948a02f38cdb31a207 ocamlnet-2.2.4.tar.gz 1770863
diff --git a/dev-ml/ocamlnet/files/ocamlnet-2.2.4-configure-fix.patch b/dev-ml/ocamlnet/files/ocamlnet-2.2.4-configure-fix.patch
new file mode 100644
index 000000000000..112db811c0e6
--- /dev/null
+++ b/dev-ml/ocamlnet/files/ocamlnet-2.2.4-configure-fix.patch
@@ -0,0 +1,222 @@
+--- ocamlnet-2.2.4.orig/configure 2007-01-12 14:58:03.000000000 +0100
++++ ocamlnet-2.2.4/configure 2007-01-12 15:03:56.000000000 +0100
+@@ -114,9 +114,9 @@
+ eval "$e"
+ uopt=`echo $opt | sed -e 's/_/-/g'`
+ if [ $o -gt 0 ]; then
+- echo " -enable-$uopt"
++ echo " --enable-$uopt"
+ else
+- echo " -disable-$uopt"
++ echo " --disable-$uopt"
+ fi
+ done
+ for opt in $woptions; do
+@@ -124,30 +124,30 @@
+ eval "$e"
+ uopt=`echo $opt | sed -e 's/_/-/g'`
+ if [ $o -gt 0 ]; then
+- echo " -with-$uopt"
++ echo " --with-$uopt"
+ else
+- echo " -without-$uopt"
++ echo " --without-$uopt"
+ fi
+ done
+- echo " -bindir $bindir"
+- echo " -datadir $net_db_dir"
++ echo " --bindir $bindir"
++ echo " --datadir $net_db_dir"
+ if [ $enable_tcl -gt 0 ]; then
+- echo " -equeue-tcl-defs \"$tcl_defs\""
+- echo " -equeue-tcl-libs \"$tcl_libs\""
++ echo " --equeue-tcl-defs \"$tcl_defs\""
++ echo " --equeue-tcl-libs \"$tcl_libs\""
+ fi
+ if [ $with_rpc_auth_dh -gt 0 ]; then
+ if [ -n "$adh_style" ]; then
+- echo " -auth-dh-style $adh_style"
++ echo " --auth-dh-style $adh_style"
+ fi
+ fi
+ if [ -n "$apxs" ]; then
+- echo " -apxs $apxs"
++ echo " --apxs $apxs"
+ fi
+ if [ -n "$apache" ]; then
+- echo " -apache $apache"
++ echo " --apache $apache"
+ fi
+ if [ $prefer_netcgi2 -gt 0 ]; then
+- echo " -prefer-netcgi2"
++ echo " --prefer-netcgi2"
+ fi
+ }
+
+@@ -162,41 +162,41 @@
+ e="help=\$ehelp_$opt"
+ eval "$e"
+ uopt=`echo $opt | sed -e 's/_/-/g'`
+- echo "-enable-$uopt:" >&2
+- echo "-disable-$uopt:" >&2
++ echo "--enable-$uopt:" >&2
++ echo "--disable-$uopt:" >&2
+ echo " $help" >&2
+ done
+ for opt in $woptions; do
+ e="help=\$whelp_$opt"
+ eval "$e"
+ uopt=`echo $opt | sed -e 's/_/-/g'`
+- echo "-with-$uopt:" >&2
+- echo "-without-$uopt:" >&2
++ echo "--with-$uopt:" >&2
++ echo "--without-$uopt:" >&2
+ echo " $help" >&2
+ done
+ cat <<_EOF_ >&2
+--bindir dir
++--bindir dir
+ Install binaries into this directory
+
+--datadir dir
++--datadir dir
+ Install the run-time data file into this directory
+
+--equeue-tcl-defs <opts>
+- Set C compiler options to find tcl.h (for -enable-tcl)
++--equeue-tcl-defs <opts>
++ Set C compiler options to find tcl.h (for --enable-tcl)
+
+--equeue-tcl-libs <opts>
+- Set C compiler options to link against libtcl (for -enable-tcl)
++--equeue-tcl-libs <opts>
++ Set C compiler options to link against libtcl (for --enable-tcl)
+
+--auth-dh-style (keyenvoy|unixdomain|tirpc)
++--auth-dh-style (keyenvoy|unixdomain|tirpc)
+ Set style of keyserv connector (see README.authdh)
+
+--apxs /path/to/apxs
+- Set which apxs to use for -enable-modcaml
++--apxs /path/to/apxs
++ Set which apxs to use for --enable-modcaml
+
+--apache /path/to/apache
+- Set which apache executable to use for -enable-modcaml
++--apache /path/to/apache
++ Set which apache executable to use for --enable-modcaml
+
+--prefer-netcgi2
++--prefer-netcgi2
+ Use netcgi2 as default CGI implementation instead of netcgi1.
+ This affects nethttpd.
+
+@@ -234,74 +234,74 @@
+
+ while [ "$#" -gt 0 ]; do
+ case "$1" in
+- -enable-*)
+- opt=`echo "$1" | sed -e 's/-enable-//' -e 's/-/_/g'`
++ --enable-*)
++ opt=`echo "$1" | sed -e 's/--enable-//' -e 's/-/_/g'`
+ check_eopt "$opt"
+ eval "enable_$opt=2"
+ shift
+ ;;
+- -disable-core)
++ --disable-core)
+ # Intentionally undocumented.
+ disable_core=1
+ shift
+ ;;
+- -disable-*)
+- opt=`echo "$1" | sed -e 's/-disable-//' -e 's/-/_/g'`
++ --disable-*)
++ opt=`echo "$1" | sed -e 's/--disable-//' -e 's/-/_/g'`
+ check_eopt "$opt"
+ eval "enable_$opt=-1"
+ shift
+ ;;
+- -with-*)
+- opt=`echo "$1" | sed -e 's/-with-//' -e 's/-/_/g'`
++ --with-*)
++ opt=`echo "$1" | sed -e 's/--with-//' -e 's/-/_/g'`
+ check_wopt "$opt"
+ eval "with_$opt=2"
+ shift
+ ;;
+- -without-*)
+- opt=`echo "$1" | sed -e 's/-without-//' -e 's/-/_/g'`
++ --without-*)
++ opt=`echo "$1" | sed -e 's/--without-//' -e 's/-/_/g'`
+ check_wopt "$opt"
+ eval "with_$opt=-1"
+ shift
+ ;;
+- -bindir)
++ --bindir)
+ bindir="$2"
+ shift
+ shift
+ ;;
+- -datadir)
++ --datadir)
+ net_db_dir="$2"
+ net_db_dir_set=1
+ shift; shift
+ ;;
+- -equeue-tcl-defs)
++ --equeue-tcl-defs)
+ tcl_defs="$tcl_defs $2"
+ shift
+ shift
+ ;;
+- -equeue-tcl-libs)
++ --equeue-tcl-libs)
+ tcl_libs="$tcl_libs $2"
+ shift
+ shift
+ ;;
+- -auth-dh-style)
++ --auth-dh-style)
+ adh_style="$2"
+ shift
+ shift
+ ;;
+- -apxs)
++ --apxs)
+ apxs="$2"
+ shift
+ shift
+ ;;
+- -apache)
++ --apache)
+ apache="$2"
+ shift
+ shift
+ ;;
+- -prefer-netcgi2)
++ --prefer-netcgi2)
+ prefer_netcgi2=1
+ shift ;;
+- -version)
++ --version)
+ echo "$version"
+ exit 0
+ ;;
+@@ -482,13 +482,13 @@
+ else
+ echo "not ok (check ldd output of tmp/t)"
+ echo
+- echo "Please check -equeue-tcl-libs!"
++ echo "Please check --equeue-tcl-libs!"
+ exit 1
+ fi
+ else
+ echo "not ok"
+ echo
+- echo "Please check -equeue-tcl-libs!"
++ echo "Please check --equeue-tcl-libs!"
+ exit 1
+ fi
+
diff --git a/dev-ml/ocamlnet/ocamlnet-2.2.4.ebuild b/dev-ml/ocamlnet/ocamlnet-2.2.4.ebuild
new file mode 100644
index 000000000000..8b7d719c97bd
--- /dev/null
+++ b/dev-ml/ocamlnet/ocamlnet-2.2.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-2.2.4.ebuild,v 1.1 2007/03/27 18:15:39 aballier Exp $
+
+inherit eutils findlib
+
+DESCRIPTION="Modules for OCaml application-level Internet protocols"
+HOMEPAGE="http://ocamlnet.sourceforge.net"
+SRC_URI="mirror://sourceforge/ocamlnet/${P}.tar.gz"
+
+LICENSE="as-is GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk ssl tk httpd"
+
+# the auth-dh compile flag has been disabled as well, since it depends on
+# ocaml-cryptgps, which is not available.
+
+DEPEND="!dev-ml/equeue
+ !dev-ml/rpc
+ !dev-ml/netclient
+ >=dev-ml/findlib-1.0
+ >=dev-ml/pcre-ocaml-5
+ gtk? ( >=dev-ml/lablgtk-2 )
+ ssl? ( dev-ml/ocaml-ssl )"
+
+src_unpack() {
+ cd "${S}"
+ unpack ${A}
+ epatch "${FILESDIR}/ocamlnet-2.2.4-configure-fix.patch"
+}
+
+pkg_setup() {
+ if use tk && ! built_with_use 'dev-lang/ocaml' tk ;
+ then die "If you want to enable tcl/tk, you need to rebuild dev-lang/ocaml with the 'tk' USE flag";
+ fi
+}
+
+src_compile() {
+ ./configure \
+ --bindir /usr/bin \
+ --datadir /usr/share/${PN} \
+ $(use_enable gtk gtk2) \
+ $(use_enable ssl) \
+ $(use_enable tk tcl) \
+ $(use_with httpd nethttpd) \
+ || die "Error : econf failed!"
+
+ emake -j1 all opt || die "make failed"
+}
+
+src_install() {
+ findlib_src_install
+}