summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-03-18 17:26:46 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-03-18 17:26:46 +0000
commit72081c90524171c53d99950407a3149a3ca345da (patch)
tree76c230117a066e7061a59744d960848098ee3b28 /dev-ml
parentversion bump (diff)
downloadgentoo-2-72081c90524171c53d99950407a3149a3ca345da.tar.gz
gentoo-2-72081c90524171c53d99950407a3149a3ca345da.tar.bz2
gentoo-2-72081c90524171c53d99950407a3149a3ca345da.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/async_extra/ChangeLog9
-rw-r--r--dev-ml/async_extra/async_extra-112.24.00.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/dev-ml/async_extra/ChangeLog b/dev-ml/async_extra/ChangeLog
index 6f9512841563..0e3cba74ab0a 100644
--- a/dev-ml/async_extra/ChangeLog
+++ b/dev-ml/async_extra/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/async_extra
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/async_extra/ChangeLog,v 1.17 2015/02/20 17:45:46 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async_extra/ChangeLog,v 1.18 2015/03/18 17:26:46 aballier Exp $
+
+*async_extra-112.24.00 (18 Mar 2015)
+
+ 18 Mar 2015; Alexis Ballier <aballier@gentoo.org>
+ +async_extra-112.24.00.ebuild:
+ version bump
20 Feb 2015; Alexis Ballier <aballier@gentoo.org>
-async_extra-110.01.00.ebuild, -async_extra-111.28.00.ebuild,
@@ -95,4 +101,3 @@
06 Mar 2013; Alexis Ballier <aballier@gentoo.org>
+async_extra-109.11.00.ebuild, +metadata.xml:
initial import, ebuild by me
-
diff --git a/dev-ml/async_extra/async_extra-112.24.00.ebuild b/dev-ml/async_extra/async_extra-112.24.00.ebuild
new file mode 100644
index 000000000000..ba89a8845eb6
--- /dev/null
+++ b/dev-ml/async_extra/async_extra-112.24.00.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async_extra/async_extra-112.24.00.ebuild,v 1.1 2015/03/18 17:26:46 aballier Exp $
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library (extra)"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P%.*}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/sexplib-109.20.00:=
+ >=dev-ml/fieldslib-109.20.00:=
+ >=dev-ml/bin-prot-109.15.00:=
+ >=dev-ml/pa_ounit-109.18.00:=
+ >=dev-ml/pipebang-109.15.00:=
+ >=dev-ml/core-${PV}:=
+ >=dev-ml/async_kernel-${PV}:=
+ >=dev-ml/async_unix-${PV}:=
+ dev-ml/custom_printf:=
+ dev-ml/herelib:=
+ dev-ml/pa_test:=
+ dev-ml/camlp4:=
+ "
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"