summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-02-20 17:47:57 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-02-20 17:47:57 +0000
commit6b3ec37720c22d5ee7746360f08a7205a86fac4f (patch)
treee98d275facd0d386512ebf6f6c603f9844088d38 /dev-ml
parentUpdate description (diff)
downloadgentoo-2-6b3ec37720c22d5ee7746360f08a7205a86fac4f.tar.gz
gentoo-2-6b3ec37720c22d5ee7746360f08a7205a86fac4f.tar.bz2
gentoo-2-6b3ec37720c22d5ee7746360f08a7205a86fac4f.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/async/ChangeLog9
-rw-r--r--dev-ml/async/async-112.17.00.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-ml/async/ChangeLog b/dev-ml/async/ChangeLog
index 3b3b2de10e25..6145ca3bd0df 100644
--- a/dev-ml/async/ChangeLog
+++ b/dev-ml/async/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/async
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/ChangeLog,v 1.15 2014/12/22 10:11:59 aballier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/ChangeLog,v 1.16 2015/02/20 17:47:57 aballier Exp $
+
+*async-112.17.00 (20 Feb 2015)
+
+ 20 Feb 2015; Alexis Ballier <aballier@gentoo.org> +async-112.17.00.ebuild:
+ version bump
*async-112.06.00 (22 Dec 2014)
diff --git a/dev-ml/async/async-112.17.00.ebuild b/dev-ml/async/async-112.17.00.ebuild
new file mode 100644
index 000000000000..fa9a366a44c3
--- /dev/null
+++ b/dev-ml/async/async-112.17.00.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/async-112.17.00.ebuild,v 1.1 2015/02/20 17:47:57 aballier Exp $
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/async_kernel-${PV}:=
+ >=dev-ml/async_unix-${PV}:=
+ >=dev-ml/async_extra-${PV}:=
+ dev-ml/camlp4:=
+ "
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.0.2 dev-ml/core_bench dev-ml/pa_ounit )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}