summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-07-31 08:38:25 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-07-31 08:38:25 +0000
commit6a2007b36a78eb780ae6284355a6b986ab6453bb (patch)
tree2b0c81a8d95121d892f6533f41044d07c71b939b /dev-ml
parentAllow lib only installation (diff)
downloadgentoo-2-6a2007b36a78eb780ae6284355a6b986ab6453bb.tar.gz
gentoo-2-6a2007b36a78eb780ae6284355a6b986ab6453bb.tar.bz2
gentoo-2-6a2007b36a78eb780ae6284355a6b986ab6453bb.zip
version bump, fixing bug #556340
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-mysql/ChangeLog7
-rw-r--r--dev-ml/ocaml-mysql/ocaml-mysql-1.2.0.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ml/ocaml-mysql/ChangeLog b/dev-ml/ocaml-mysql/ChangeLog
index 422f372e7d5e..6913b6762438 100644
--- a/dev-ml/ocaml-mysql/ChangeLog
+++ b/dev-ml/ocaml-mysql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocaml-mysql
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-mysql/ChangeLog,v 1.16 2015/05/31 00:13:05 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-mysql/ChangeLog,v 1.17 2015/07/31 08:38:25 aballier Exp $
+
+*ocaml-mysql-1.2.0 (31 Jul 2015)
+
+ 31 Jul 2015; Alexis Ballier <aballier@gentoo.org> +ocaml-mysql-1.2.0.ebuild:
+ version bump, fixing bug #556340
31 May 2015; Manuel Rüger <mrueg@gentoo.org>
-files/ocaml-mysql-1.0.3-head.patch, -files/ocaml-mysql-1.0.3-shtool-r1.patch,
diff --git a/dev-ml/ocaml-mysql/ocaml-mysql-1.2.0.ebuild b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.0.ebuild
new file mode 100644
index 000000000000..0e8bc51058ec
--- /dev/null
+++ b/dev-ml/ocaml-mysql/ocaml-mysql-1.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-mysql/ocaml-mysql-1.2.0.ebuild,v 1.1 2015/07/31 08:38:25 aballier Exp $
+
+EAPI=5
+
+inherit findlib eutils
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to mysql databases"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/1500/${P}.tar.gz"
+HOMEPAGE="http://ocaml-mysql.forge.ocamlcore.org/"
+
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ sys-libs/zlib
+ >=virtual/mysql-4.0"
+
+RDEPEND="$DEPEND"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile()
+{
+ emake all
+ if use ocamlopt; then
+ emake opt
+ fi
+}
+
+src_install()
+{
+ findlib_src_preinst
+ emake install
+
+ dodoc CHANGES README VERSION || die
+}