summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-03-30 11:52:39 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-03-30 11:52:39 +0000
commit6971e0b624ea24700bd8b3af0ce503f6dcd3cd4d (patch)
tree4826fa25396e5b8454634d2a7176b809a74e8d6d /dev-ml
parentinitial import, ebuild by Guillaume Horel in bug #406523 (diff)
downloadgentoo-2-6971e0b624ea24700bd8b3af0ce503f6dcd3cd4d.tar.gz
gentoo-2-6971e0b624ea24700bd8b3af0ce503f6dcd3cd4d.tar.bz2
gentoo-2-6971e0b624ea24700bd8b3af0ce503f6dcd3cd4d.zip
initial import, ebuild by Guillaume Horel in bug #406519
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/utop/ChangeLog10
-rw-r--r--dev-ml/utop/metadata.xml5
-rw-r--r--dev-ml/utop/utop-1.1.ebuild53
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-ml/utop/ChangeLog b/dev-ml/utop/ChangeLog
new file mode 100644
index 000000000000..0852bede82fa
--- /dev/null
+++ b/dev-ml/utop/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ml/utop
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/utop/ChangeLog,v 1.1 2012/03/30 11:52:39 aballier Exp $
+
+*utop-1.1 (30 Mar 2012)
+
+ 30 Mar 2012; Alexis Ballier <aballier@gentoo.org> +utop-1.1.ebuild,
+ +metadata.xml:
+ initial import, ebuild by Guillaume Horel in bug #406519
+
diff --git a/dev-ml/utop/metadata.xml b/dev-ml/utop/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/utop/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/utop/utop-1.1.ebuild b/dev-ml/utop/utop-1.1.ebuild
new file mode 100644
index 000000000000..8f0d6d3e7499
--- /dev/null
+++ b/dev-ml/utop/utop-1.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/utop/utop-1.1.ebuild,v 1.1 2012/03/30 11:52:39 aballier Exp $
+
+EAPI=4
+
+OASIS_BUILD_DOCS=1
+inherit oasis elisp-common
+
+DESCRIPTION="A new toplevel for OCaml with completion and colorization"
+HOMEPAGE="http://forge.ocamlcore.org/projects/utop/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/674/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="emacs"
+
+DEPEND="dev-ml/lwt[react]
+ dev-ml/lambda-term
+ dev-ml/zed
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "CHANGES" "README" )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ sed -i "s/(\"utop.el.*)//" setup.ml
+}
+
+src_compile() {
+ oasis_src_compile
+ if use emacs; then
+ elisp-compile src/*.el
+ fi
+}
+
+src_install() {
+ oasis_src_install
+ if use emacs; then
+ elisp-install "${PN}" src/*.el src/*.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}