summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-07-07 20:34:43 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-07-07 20:34:43 +0000
commit3d8ead0f6f1055279e462eb6ef1ef24ec7b6d581 (patch)
tree574d482e7cb2ef7d4c37246bee1cf0c9f3f39379 /dev-ml
parentbump to latest debian patchset, fix bug #367891 (diff)
downloadgentoo-2-3d8ead0f6f1055279e462eb6ef1ef24ec7b6d581.tar.gz
gentoo-2-3d8ead0f6f1055279e462eb6ef1ef24ec7b6d581.tar.bz2
gentoo-2-3d8ead0f6f1055279e462eb6ef1ef24ec7b6d581.zip
version bump
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlduce/ChangeLog7
-rw-r--r--dev-ml/ocamlduce/ocamlduce-3.12.1.0.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-ml/ocamlduce/ChangeLog b/dev-ml/ocamlduce/ChangeLog
index e0f9eb63cf61..b2e3c5762aaf 100644
--- a/dev-ml/ocamlduce/ChangeLog
+++ b/dev-ml/ocamlduce/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocamlduce
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlduce/ChangeLog,v 1.20 2011/07/06 16:38:12 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlduce/ChangeLog,v 1.21 2011/07/07 20:34:43 aballier Exp $
+
+*ocamlduce-3.12.1.0 (07 Jul 2011)
+
+ 07 Jul 2011; Alexis Ballier <aballier@gentoo.org> +ocamlduce-3.12.1.0.ebuild:
+ version bump
06 Jul 2011; Alexis Ballier <aballier@gentoo.org> -ocamlduce-3.11.2.0.ebuild,
-ocamlduce-3.12.0.0.ebuild, -ocamlduce-3.12.0.0-r10.ebuild:
diff --git a/dev-ml/ocamlduce/ocamlduce-3.12.1.0.ebuild b/dev-ml/ocamlduce/ocamlduce-3.12.1.0.ebuild
new file mode 100644
index 000000000000..58163de92886
--- /dev/null
+++ b/dev-ml/ocamlduce/ocamlduce-3.12.1.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlduce/ocamlduce-3.12.1.0.ebuild,v 1.1 2011/07/07 20:34:43 aballier Exp $
+
+EAPI="2"
+
+inherit versionator eutils toolchain-funcs flag-o-matic multilib
+
+OCAML_VERSION=3.12.1
+OCAML_TARBALL=ocaml-${OCAML_VERSION}.tar.bz2
+OCAML_PATCHLEVEL=3
+OCAML_GENTOO_PATCHES=ocaml-patches-${OCAML_PATCHLEVEL}.tar.bz2
+
+DESCRIPTION="OCamlDuce is a merger between OCaml and CDuce"
+HOMEPAGE="http://ocamlduce.forge.ocamlcore.org/"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/644/${P}.tar.gz
+ ftp://ftp.inria.fr/INRIA/cristal/ocaml/ocaml-$(get_version_component_range 1-2 ${OCAML_VERSION})/${OCAML_TARBALL}
+ mirror://gentoo/${OCAML_GENTOO_PATCHES}"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="+ocamlopt"
+
+DEPEND="~dev-lang/ocaml-${OCAML_VERSION/+/_}[ocamlopt?]
+ >=dev-ml/findlib-1.2.4-r1
+ !!<dev-ml/${P}"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}/ocaml-${OCAML_VERSION}
+
+src_unpack() {
+ unpack ${P}.tar.gz ${OCAML_GENTOO_PATCHES}
+}
+
+src_prepare() {
+ cd "${WORKDIR}/${P}"
+ emake OCAML_SOURCE="${DISTDIR}/${OCAML_TARBALL}" prepare || die "failed to prepare"
+ cd "${S}"
+ EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
+}
+
+src_configure() {
+ RAW_LDFLAGS="$(raw-ldflags)" ./configure -prefix /usr \
+ --bindir /usr/bin \
+ --libdir /usr/$(get_libdir)/ocaml \
+ --mandir /usr/share/man \
+ -host "${CHOST}" \
+ -cc "$(tc-getCC)" \
+ -as "$(tc-getAS)" \
+ -aspp "$(tc-getCC) -c" \
+ --with-pthread || die "configure failed!"
+}
+
+src_compile() {
+ if use ocamlopt; then
+ emake -f Makefile.ocamlduce -j1 world.opt || die
+ else
+ emake -f Makefile.ocamlduce -j1 world || die
+ fi
+}
+
+src_install() {
+ emake -f Makefile.ocamlduce BINDIR="${D}/usr/bin" LIBDIR="${D}/usr/$(get_libdir)/ocaml" installbyte || die
+ if use ocamlopt; then
+ emake -f Makefile.ocamlduce BINDIR="${D}/usr/bin" LIBDIR="${D}/usr/$(get_libdir)/ocaml" installopt || die
+ fi
+ dodoc Changes README
+}