summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-11-21 00:15:13 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-11-21 00:15:13 +0000
commit3c1c8b708ac0a0bed4a66fb98dc6244e231245bc (patch)
tree3b7809511ff5648d2f72efc9bb4a6af7a7710448 /dev-ml
parentversion bump (diff)
downloadgentoo-2-3c1c8b708ac0a0bed4a66fb98dc6244e231245bc.tar.gz
gentoo-2-3c1c8b708ac0a0bed4a66fb98dc6244e231245bc.tar.bz2
gentoo-2-3c1c8b708ac0a0bed4a66fb98dc6244e231245bc.zip
version bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlzip/ChangeLog9
-rw-r--r--dev-ml/camlzip/camlzip-1.05.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-ml/camlzip/ChangeLog b/dev-ml/camlzip/ChangeLog
index 4a48a472d6a1..518805df3472 100644
--- a/dev-ml/camlzip/ChangeLog
+++ b/dev-ml/camlzip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camlzip
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/ChangeLog,v 1.20 2011/04/27 17:58:49 angelos Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/ChangeLog,v 1.21 2012/11/21 00:15:13 aballier Exp $
+
+*camlzip-1.05 (21 Nov 2012)
+
+ 21 Nov 2012; Alexis Ballier <aballier@gentoo.org> +camlzip-1.05.ebuild:
+ version bump
27 Apr 2011; Christoph Mende <angelos@gentoo.org> camlzip-1.04.ebuild:
Stable on amd64 wrt bug #363617
diff --git a/dev-ml/camlzip/camlzip-1.05.ebuild b/dev-ml/camlzip/camlzip-1.05.ebuild
new file mode 100644
index 000000000000..d26ac155df55
--- /dev/null
+++ b/dev-ml/camlzip/camlzip-1.05.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/camlzip-1.05.ebuild,v 1.1 2012/11/21 00:15:13 aballier Exp $
+
+EAPI="4"
+
+inherit findlib eutils
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
+HOMEPAGE="http://forge.ocamlcore.org/projects/camlzip/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1037/${P}.tar.gz"
+
+SLOT="1"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ >=sys-libs/zlib-1.1.3"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake all
+ if use ocamlopt; then
+ emake allopt
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ emake DESTDIR="${D}" install-findlib
+
+ dodoc README Changes
+}