summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-08-10 06:34:21 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-08-10 06:34:21 +0000
commit2052fe5603180b8e153a1b1ae60f5150a72ec1b0 (patch)
tree020e33091499eda5d174658ab22cdaa2a55d827f /dev-ml
parentx86 stable wrt bug #302103 (diff)
downloadgentoo-2-2052fe5603180b8e153a1b1ae60f5150a72ec1b0.tar.gz
gentoo-2-2052fe5603180b8e153a1b1ae60f5150a72ec1b0.tar.bz2
gentoo-2-2052fe5603180b8e153a1b1ae60f5150a72ec1b0.zip
version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlp5/ChangeLog7
-rw-r--r--dev-ml/camlp5/camlp5-5.15.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ml/camlp5/ChangeLog b/dev-ml/camlp5/ChangeLog
index 6f060eb2853e..d6349e6faa68 100644
--- a/dev-ml/camlp5/ChangeLog
+++ b/dev-ml/camlp5/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camlp5
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.46 2010/08/03 11:47:18 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.47 2010/08/10 06:34:21 aballier Exp $
+
+*camlp5-5.15 (10 Aug 2010)
+
+ 10 Aug 2010; Alexis Ballier <aballier@gentoo.org> +camlp5-5.15.ebuild:
+ version bump
03 Aug 2010; Alexis Ballier <aballier@gentoo.org> camlp5-5.14.ebuild,
+files/camlp5-5.14-ocaml312.patch:
diff --git a/dev-ml/camlp5/camlp5-5.15.ebuild b/dev-ml/camlp5/camlp5-5.15.ebuild
new file mode 100644
index 000000000000..b6ba664723c6
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-5.15.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-5.15.ebuild,v 1.1 2010/08/10 06:34:21 aballier Exp $
+
+EAPI="2"
+
+inherit multilib findlib
+
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/camlp5/"
+SRC_URI="http://pauillac.inria.fr/~ddr/camlp5/distrib/src/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ ./configure \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile(){
+ emake -j1 || die "emake failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "Compiling native code programs failed"
+ emake -j1 opt.opt || die "Compiling native code programs failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META || die "failed to install META file for findlib support"
+
+ use doc && dohtml -r doc/*
+
+ dodoc CHANGES DEVEL ICHANGES README UPGRADING MODE
+}