summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-06-29 09:23:24 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-06-29 09:23:24 +0000
commit1520a9602b57eecdacc5df59912a496bced82a06 (patch)
tree00ba62bce98632bb9be9924beb476f00b0b3f00e /dev-ml
parentversion bump (diff)
downloadgentoo-2-1520a9602b57eecdacc5df59912a496bced82a06.tar.gz
gentoo-2-1520a9602b57eecdacc5df59912a496bced82a06.tar.bz2
gentoo-2-1520a9602b57eecdacc5df59912a496bced82a06.zip
version bump
Signed-off-by: Alexis Ballier <aballier@gentoo.org> (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/utop/ChangeLog7
-rw-r--r--dev-ml/utop/utop-1.18.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-ml/utop/ChangeLog b/dev-ml/utop/ChangeLog
index 6ab8eb992087..bbfa93d033d1 100644
--- a/dev-ml/utop/ChangeLog
+++ b/dev-ml/utop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/utop
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/utop/ChangeLog,v 1.12 2015/06/06 19:48:58 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/utop/ChangeLog,v 1.13 2015/06/29 09:23:24 aballier Exp $
+
+*utop-1.18 (29 Jun 2015)
+
+ 29 Jun 2015; Alexis Ballier <aballier@gentoo.org> +utop-1.18.ebuild:
+ version bump
06 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-ml/utop/utop-1.18.ebuild b/dev-ml/utop/utop-1.18.ebuild
new file mode 100644
index 000000000000..1990c8a67b3a
--- /dev/null
+++ b/dev-ml/utop/utop-1.18.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/utop/utop-1.18.ebuild,v 1.1 2015/06/29 09:23:24 aballier Exp $
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+inherit oasis elisp-common
+
+DESCRIPTION="A new toplevel for OCaml with completion and colorization"
+HOMEPAGE="http://github.com/diml/utop"
+SRC_URI="http://github.com/diml/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="camlp4 emacs"
+
+DEPEND=">=dev-ml/lwt-2.4.0:=[react]
+ >=dev-ml/lambda-term-1.2:=
+ >=dev-ml/zed-1.2:=
+ >=dev-ml/cppo-1.0.1:=
+ emacs? ( virtual/emacs )
+ camlp4? ( || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 ) )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "CHANGES.md" "README.md" )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ sed -i "s/(\"utop.el.*)//" setup.ml
+}
+
+src_configure() {
+ oasis_configure_opts="$(use_enable camlp4)" \
+ oasis_src_configure
+}
+src_compile() {
+ oasis_src_compile
+ if use emacs; then
+ elisp-compile src/top/*.el
+ fi
+}
+
+src_install() {
+ oasis_src_install
+ if use emacs; then
+ elisp-install "${PN}" src/top/*.el src/top/*.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}