summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-07-27 07:53:35 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-07-27 07:53:35 +0000
commit0d2696343ba6c5a3a638df07046bfbbee48cb242 (patch)
tree097649b7fcbff1f8008479124d15f82691b6f10b /dev-ml
parentUpdating remote-id in metadata.xml (diff)
downloadgentoo-2-0d2696343ba6c5a3a638df07046bfbbee48cb242.tar.gz
gentoo-2-0d2696343ba6c5a3a638df07046bfbbee48cb242.tar.bz2
gentoo-2-0d2696343ba6c5a3a638df07046bfbbee48cb242.zip
version bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/js_of_ocaml/ChangeLog7
-rw-r--r--dev-ml/js_of_ocaml/js_of_ocaml-2.6.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ml/js_of_ocaml/ChangeLog b/dev-ml/js_of_ocaml/ChangeLog
index c4f5d0572e3a..8467f08b1dcb 100644
--- a/dev-ml/js_of_ocaml/ChangeLog
+++ b/dev-ml/js_of_ocaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/js_of_ocaml
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/js_of_ocaml/ChangeLog,v 1.9 2015/06/07 09:13:33 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/js_of_ocaml/ChangeLog,v 1.10 2015/07/27 07:53:35 aballier Exp $
+
+*js_of_ocaml-2.6 (27 Jul 2015)
+
+ 27 Jul 2015; Alexis Ballier <aballier@gentoo.org> +js_of_ocaml-2.6.ebuild:
+ version bump
07 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-ml/js_of_ocaml/js_of_ocaml-2.6.ebuild b/dev-ml/js_of_ocaml/js_of_ocaml-2.6.ebuild
new file mode 100644
index 000000000000..da66a530d90e
--- /dev/null
+++ b/dev-ml/js_of_ocaml/js_of_ocaml-2.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/js_of_ocaml/js_of_ocaml-2.6.ebuild,v 1.1 2015/07/27 07:53:35 aballier Exp $
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="A compiler from OCaml bytecode to javascript"
+HOMEPAGE="http://ocsigen.org/js_of_ocaml/"
+SRC_URI="https://github.com/ocsigen/js_of_ocaml/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt doc +deriving"
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
+ >=dev-ml/lwt-2.4.4:=
+ dev-ml/react:=
+ dev-ml/reactiveData:=
+ >=dev-ml/tyxml-3.3:=
+ dev-ml/cmdliner:=
+ dev-ml/menhir:=
+ dev-ml/ocaml-base64:=
+ dev-ml/camlp4:=
+ dev-ml/cppo:=
+ deriving? ( >=dev-ml/deriving-0.6:= )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ use ocamlopt || echo "BEST := byte" >> Makefile.conf
+ use deriving || echo "WITH_DERIVING := NO" >> Makefile.conf
+}
+
+src_compile() {
+ emake
+ use doc && emake doc
+}
+
+src_install() {
+ findlib_src_preinst
+ emake BINDIR="${ED}/usr/bin/" install
+ dodoc CHANGES README.md
+ use doc && dohtml -r doc/api/html/
+}