summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2005-06-02 15:11:54 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2005-06-02 15:11:54 +0000
commit88ac4b969ff3a029631403cae6c6335cd6d87b09 (patch)
tree41a8cc8c83e6a7540eff50ba70e0d85bd590bb2c /dev-ml/ocaml-mysql/ocaml-mysql-1.0.3-r1.ebuild
parentMarked ppc stable. (diff)
downloadgentoo-2-88ac4b969ff3a029631403cae6c6335cd6d87b09.tar.gz
gentoo-2-88ac4b969ff3a029631403cae6c6335cd6d87b09.tar.bz2
gentoo-2-88ac4b969ff3a029631403cae6c6335cd6d87b09.zip
Fixes bug #93784
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-ml/ocaml-mysql/ocaml-mysql-1.0.3-r1.ebuild')
-rw-r--r--dev-ml/ocaml-mysql/ocaml-mysql-1.0.3-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/ocaml-mysql/ocaml-mysql-1.0.3-r1.ebuild b/dev-ml/ocaml-mysql/ocaml-mysql-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..d665deaff73a
--- /dev/null
+++ b/dev-ml/ocaml-mysql/ocaml-mysql-1.0.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-mysql/ocaml-mysql-1.0.3-r1.ebuild,v 1.1 2005/06/02 15:11:54 mattam Exp $
+
+inherit findlib eutils
+
+IUSE="doc"
+
+DESCRIPTION="A package for ocaml that provides access to mysql databases."
+SRC_URI="http://raevnos.pennmush.org/code/${PN}/${P}.tar.gz"
+HOMEPAGE="http://raevnos.pennmush.org/code/ocaml-mysql/index.html"
+
+DEPEND=">=dev-lang/ocaml-3.06
+ >=dev-db/mysql-4.0.12"
+
+RDEPEND="$DEPEND"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="x86 ppc"
+
+src_compile()
+{
+ epatch ${FILESDIR}/${P}-head.patch
+ epatch ${FILESDIR}/${P}-shtool.patch
+ econf || die "configure failed"
+ make all || die "make failed"
+ make opt
+}
+
+src_install()
+{
+ findlib_src_preinst
+ make install || die
+
+ ( use doc ) && dohtml -r doc/html/*
+ dodoc META COPYING CHANGES README VERSION
+}