summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-10-10 12:00:43 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-10-10 12:00:43 +0000
commit7b5fe6ab63a8e84e2b76f4ff7703cf59ea65dc80 (patch)
treec4d250867fdd5ad47431668599ebb306b03a8354 /dev-ml/ocaml-make
parentversion bump (diff)
downloadgentoo-2-7b5fe6ab63a8e84e2b76f4ff7703cf59ea65dc80.tar.gz
gentoo-2-7b5fe6ab63a8e84e2b76f4ff7703cf59ea65dc80.tar.bz2
gentoo-2-7b5fe6ab63a8e84e2b76f4ff7703cf59ea65dc80.zip
version bump
(Portage version: 2.2.0_alpha136/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/ocaml-make')
-rw-r--r--dev-ml/ocaml-make/ChangeLog7
-rw-r--r--dev-ml/ocaml-make/ocaml-make-6.37.0.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-ml/ocaml-make/ChangeLog b/dev-ml/ocaml-make/ChangeLog
index c96fa2d986af..07b005ed3512 100644
--- a/dev-ml/ocaml-make/ChangeLog
+++ b/dev-ml/ocaml-make/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocaml-make
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-make/ChangeLog,v 1.18 2012/02/19 13:27:22 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-make/ChangeLog,v 1.19 2012/10/10 12:00:43 aballier Exp $
+
+*ocaml-make-6.37.0 (10 Oct 2012)
+
+ 10 Oct 2012; Alexis Ballier <aballier@gentoo.org> +ocaml-make-6.37.0.ebuild:
+ version bump
19 Feb 2012; Alexis Ballier <aballier@gentoo.org> -ocaml-make-6.29.3.ebuild,
-ocaml-make-6.30.0.ebuild, -ocaml-make-6.33.0.ebuild,
diff --git a/dev-ml/ocaml-make/ocaml-make-6.37.0.ebuild b/dev-ml/ocaml-make/ocaml-make-6.37.0.ebuild
new file mode 100644
index 000000000000..4d5d2356cd46
--- /dev/null
+++ b/dev-ml/ocaml-make/ocaml-make-6.37.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-make/ocaml-make-6.37.0.ebuild,v 1.1 2012/10/10 12:00:43 aballier Exp $
+
+EAPI=4
+
+DESCRIPTION="Generic O'Caml Makefile for GNU Make"
+HOMEPAGE="http://bitbucket.org/mmottl/ocaml-makefile"
+LICENSE="LGPL-2.1"
+
+DEPEND=""
+RDEPEND=">=dev-lang/ocaml-3.06-r1
+ >=dev-ml/findlib-0.8"
+SRC_URI="http://bitbucket.org/mmottl/ocaml-makefile/downloads/${PN}file-${PV}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="examples"
+S="${WORKDIR}/${PN}file-${PV}"
+
+src_install () {
+ # Just put the OCamlMakefile into /usr/include
+ # where GNU Make will automatically pick it up.
+ insinto /usr/include
+ doins OCamlMakefile
+ # install documentation
+ dodoc README.md CHANGES.txt
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r calc camlp4 gtk idl threads
+ fi
+}