summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-08-09 18:48:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-08-09 18:48:39 +0000
commit6a1df5523fb867f76b04d8caf436586071e8669b (patch)
tree504bdf6e7f4c95fb6d6ec6819e02f808596eaeab /dev-ml/camomile
parentadd fix & mark rev bump x86, cleanup (Manifest recommit) (diff)
downloadgentoo-2-6a1df5523fb867f76b04d8caf436586071e8669b.tar.gz
gentoo-2-6a1df5523fb867f76b04d8caf436586071e8669b.tar.bz2
gentoo-2-6a1df5523fb867f76b04d8caf436586071e8669b.zip
header fix; tidy
Diffstat (limited to 'dev-ml/camomile')
-rw-r--r--dev-ml/camomile/ChangeLog5
-rw-r--r--dev-ml/camomile/camomile-0.5.3.ebuild22
2 files changed, 16 insertions, 11 deletions
diff --git a/dev-ml/camomile/ChangeLog b/dev-ml/camomile/ChangeLog
index 6927f5ecaa13..6d8bb3923db0 100644
--- a/dev-ml/camomile/ChangeLog
+++ b/dev-ml/camomile/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/ulex
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/ChangeLog,v 1.1 2004/08/08 08:51:41 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/ChangeLog,v 1.2 2004/08/09 18:48:39 mr_bones_ Exp $
+
+ 09 Aug 2004; Michael Sterrett <mr_bones_@gentoo.org> camomile-0.5.3.ebuild:
+ header fix; tidy
*camomile-0.5.3 (08 Aug 2004)
diff --git a/dev-ml/camomile/camomile-0.5.3.ebuild b/dev-ml/camomile/camomile-0.5.3.ebuild
index 8311349b8881..268ba6a234a6 100644
--- a/dev-ml/camomile/camomile-0.5.3.ebuild
+++ b/dev-ml/camomile/camomile-0.5.3.ebuild
@@ -1,30 +1,32 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/camomile-0.5.3.ebuild,v 1.2 2004/08/09 02:00:37 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/camomile-0.5.3.ebuild,v 1.3 2004/08/09 18:48:39 mr_bones_ Exp $
DESCRIPTION="Camomile is a comprehensive Unicode library for ocaml."
HOMEPAGE="http://camomile.sourceforge.net/"
SRC_URI="http://heanet.dl.sourceforge.net/sourceforge/camomile/${P}.tar.bz2"
-LICENSE="LGPL-2"
+LICENSE="LGPL-2"
+SLOT="0"
KEYWORDS="~x86 ~ppc"
IUSE=""
+
DEPEND=">=dev-lang/ocaml-3.07"
-SLOT="0"
src_compile() {
econf || die
# Does not support parallel builds.
- make
+ emake -j1
}
src_install() {
- local destdir=`ocamlfind printconf destdir`
- dodir ${destdir}
- export OCAMLFIND_DESTDIR=${D}${destdir}
+ local destdir="$(ocamlfind printconf destdir)"
+
+ export OCAMLFIND_DESTDIR="${D}${destdir}"
# stublibs style
- dodir ${destdir}/stublibs
+ dodir "${destdir}/stublibs"
- make DESTDIR=${D} DATADIR=${D}/usr/share install
+ make DESTDIR="${D}" DATADIR="${D}/usr/share" install \
+ || die "make install failed"
}