summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-12-17 01:25:11 +0000
committerTim Harder <radhermit@gentoo.org>2014-12-17 01:25:11 +0000
commitbf3d853bcc874b6ac83a348fc15fc37bbce61240 (patch)
tree600673a150495d354f3a789f4852dedc1aecb864 /dev-lua
parentVersion bump. (diff)
downloadgentoo-2-bf3d853bcc874b6ac83a348fc15fc37bbce61240.tar.gz
gentoo-2-bf3d853bcc874b6ac83a348fc15fc37bbce61240.tar.bz2
gentoo-2-bf3d853bcc874b6ac83a348fc15fc37bbce61240.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lpeg/ChangeLog8
-rw-r--r--dev-lua/lpeg/files/lpeg-0.12.1-makefile.patch37
-rw-r--r--dev-lua/lpeg/lpeg-0.12.1.ebuild42
3 files changed, 86 insertions, 1 deletions
diff --git a/dev-lua/lpeg/ChangeLog b/dev-lua/lpeg/ChangeLog
index 85d22f537208..ba39666d2209 100644
--- a/dev-lua/lpeg/ChangeLog
+++ b/dev-lua/lpeg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lua/lpeg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/lpeg/ChangeLog,v 1.8 2014/12/09 09:54:05 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/lpeg/ChangeLog,v 1.9 2014/12/17 01:25:11 radhermit Exp $
+
+*lpeg-0.12.1 (17 Dec 2014)
+
+ 17 Dec 2014; Tim Harder <radhermit@gentoo.org> +lpeg-0.12.1.ebuild,
+ +files/lpeg-0.12.1-makefile.patch:
+ Version bump.
09 Dec 2014; Jeroen Roovers <jer@gentoo.org> lpeg-0.12.ebuild:
Stable for HPPA (bug #526016).
diff --git a/dev-lua/lpeg/files/lpeg-0.12.1-makefile.patch b/dev-lua/lpeg/files/lpeg-0.12.1-makefile.patch
new file mode 100644
index 000000000000..a0be0558aa97
--- /dev/null
+++ b/dev-lua/lpeg/files/lpeg-0.12.1-makefile.patch
@@ -0,0 +1,37 @@
+--- lpeg-0.12.1/makefile
++++ lpeg-0.12.1/makefile
+@@ -1,7 +1,7 @@
+ LIBNAME = lpeg
+ LUADIR = ../lua/
+
+-COPT = -O2
++#COPT = -O2
+ # COPT = -DLPEG_DEBUG -g
+
+ CWARNS = -Wall -Wextra -pedantic \
+@@ -22,21 +22,21 @@
+ # -Wunreachable-code \
+
+
+-CFLAGS = $(CWARNS) $(COPT) -std=c99 -I$(LUADIR) -fPIC
++CFLAGS += $(CWARNS) $(COPT) -std=c99 -I$(LUADIR) -fPIC
+ CC = gcc
+
+ FILES = lpvm.o lpcap.o lptree.o lpcode.o lpprint.o
+
+ # For Linux
+ linux:
+- make lpeg.so "DLLFLAGS = -shared -fPIC"
++ $(MAKE) lpeg.so "DLLFLAGS = -shared -fPIC"
+
+ # For Mac OS
+ macosx:
+- make lpeg.so "DLLFLAGS = -bundle -undefined dynamic_lookup"
++ $(MAKE) lpeg.so "DLLFLAGS = -bundle -undefined dynamic_lookup"
+
+ lpeg.so: $(FILES)
+- env $(CC) $(DLLFLAGS) $(FILES) -o lpeg.so
++ env $(CC) $(DLLFLAGS) $(LDFLAGS) $(FILES) -o lpeg.so
+
+ $(FILES): makefile
+
diff --git a/dev-lua/lpeg/lpeg-0.12.1.ebuild b/dev-lua/lpeg/lpeg-0.12.1.ebuild
new file mode 100644
index 000000000000..01ace250a448
--- /dev/null
+++ b/dev-lua/lpeg/lpeg-0.12.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/lpeg/lpeg-0.12.1.ebuild,v 1.1 2014/12/17 01:25:11 radhermit Exp $
+
+EAPI=5
+
+inherit flag-o-matic toolchain-funcs eutils multilib
+
+DESCRIPTION="Parsing Expression Grammars for Lua"
+HOMEPAGE="http://www.inf.puc-rio.br/~roberto/lpeg/"
+SRC_URI="http://www.inf.puc-rio.br/~roberto/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~x86"
+IUSE="debug doc"
+
+RDEPEND=">=dev-lang/lua-5.1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ use debug && append-cflags -DLPEG_DEBUG
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_test() {
+ lua test.lua || die
+}
+
+src_install() {
+ exeinto "$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)"
+ doexe lpeg.so
+
+ dodoc HISTORY
+
+ use doc && dohtml *
+}