summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-04-06 13:02:35 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-04-06 13:02:35 +0000
commit50494522c752eaff245790048d110cd9f17f3c2e (patch)
tree38885ccc2674b77224c217e65b9d4390091500f1 /dev-lua/luaevent
parentGentoo Bug Day bump and fixes bug 299429 and bug 336397. (diff)
downloadgentoo-2-50494522c752eaff245790048d110cd9f17f3c2e.tar.gz
gentoo-2-50494522c752eaff245790048d110cd9f17f3c2e.tar.bz2
gentoo-2-50494522c752eaff245790048d110cd9f17f3c2e.zip
Version bump, bug #464756
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-lua/luaevent')
-rw-r--r--dev-lua/luaevent/ChangeLog10
-rw-r--r--dev-lua/luaevent/luaevent-0.4.3.ebuild40
2 files changed, 47 insertions, 3 deletions
diff --git a/dev-lua/luaevent/ChangeLog b/dev-lua/luaevent/ChangeLog
index 0eddff03cb11..b3ae14143a05 100644
--- a/dev-lua/luaevent/ChangeLog
+++ b/dev-lua/luaevent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lua/luaevent
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/luaevent/ChangeLog,v 1.9 2012/12/31 09:56:38 djc Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luaevent/ChangeLog,v 1.10 2013/04/06 13:02:35 blueness Exp $
+
+*luaevent-0.4.3 (06 Apr 2013)
+
+ 06 Apr 2013; Anthony G. Basile <blueness@gentoo.org> +luaevent-0.4.3.ebuild:
+ Version bump, bug #464756
31 Dec 2012; Dirkjan Ochtman <djc@gentoo.org> metadata.xml:
Remove myself as a maintainer.
@@ -36,4 +41,3 @@
20 Jan 2011; Anthony G. Basile <blueness@gentoo.org>
+luaevent-0.3.1.ebuild, +metadata.xml:
Initial commit, bug #333097
-
diff --git a/dev-lua/luaevent/luaevent-0.4.3.ebuild b/dev-lua/luaevent/luaevent-0.4.3.ebuild
new file mode 100644
index 000000000000..e91f454599a2
--- /dev/null
+++ b/dev-lua/luaevent/luaevent-0.4.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luaevent/luaevent-0.4.3.ebuild,v 1.1 2013/04/06 13:02:35 blueness Exp $
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+DESCRIPTION="libevent bindings for Lua"
+HOMEPAGE="http://luaforge.net/projects/luaevent"
+SRC_URI="https://github.com/harningt/luaevent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/lua-5.1
+ >=dev-libs/libevent-1.4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i "s:^CFLAGS =:CFLAGS +=:" "${S}/Makefile" \
+ || die "sed failed"
+ sed -i "s:^LDFLAGS =:LDFLAGS +=:" "${S}/Makefile" \
+ || die "sed failed"
+ sed -i "/^LDFLAGS/a CC = $(tc-getCC)" "${S}/Makefile" \
+ || die "sed failed"
+ sed -i "s:^LUA_INC_DIR ?=.*:LUA_INC_DIR ?= $(pkg-config --variable INSTALL_INC lua):" "${S}/Makefile" \
+ || die "sed failed"
+ sed -i "s:^INSTALL_DIR_LUA ?=.*:INSTALL_DIR_LUA ?= $(pkg-config --variable INSTALL_LMOD lua):" "${S}/Makefile" \
+ || die "sed failed"
+ sed -i "s:^INSTALL_DIR_BIN ?=.*:INSTALL_DIR_BIN ?= $(pkg-config --variable INSTALL_CMOD lua):" "${S}/Makefile" \
+ || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+}