summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2009-07-29 14:22:17 +0000
committerMarijn Schouten <hkbst@gentoo.org>2009-07-29 14:22:17 +0000
commite29965d7d5d26426075a509347dc4009273e32c9 (patch)
tree904a937e0c690c0df011bc1fe14044664196f50c /dev-lisp
parentVersion bump. (diff)
downloadgentoo-2-e29965d7d5d26426075a509347dc4009273e32c9.tar.gz
gentoo-2-e29965d7d5d26426075a509347dc4009273e32c9.tar.bz2
gentoo-2-e29965d7d5d26426075a509347dc4009273e32c9.zip
some small improvement
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/clisp/ChangeLog5
-rw-r--r--dev-lisp/clisp/clisp-2.48.ebuild12
2 files changed, 11 insertions, 6 deletions
diff --git a/dev-lisp/clisp/ChangeLog b/dev-lisp/clisp/ChangeLog
index 7316e073f733..3b188554c36b 100644
--- a/dev-lisp/clisp/ChangeLog
+++ b/dev-lisp/clisp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lisp/clisp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.94 2009/07/29 11:32:46 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.95 2009/07/29 14:22:17 hkbst Exp $
+
+ 29 Jul 2009; Marijn Schouten <hkBst@gentoo.org> clisp-2.48.ebuild:
+ some small improvement
29 Jul 2009; Marijn Schouten <hkBst@gentoo.org> -clisp-2.43-r1.ebuild,
-clisp-2.44.1.ebuild, -clisp-2.44.1-r1.ebuild, -clisp-2.46.ebuild,
diff --git a/dev-lisp/clisp/clisp-2.48.ebuild b/dev-lisp/clisp/clisp-2.48.ebuild
index 8ca93570c710..656c172c65c9 100644
--- a/dev-lisp/clisp/clisp-2.48.ebuild
+++ b/dev-lisp/clisp/clisp-2.48.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.48.ebuild,v 1.1 2009/07/29 11:29:44 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.48.ebuild,v 1.2 2009/07/29 14:22:17 hkbst Exp $
EAPI=2
@@ -13,7 +13,7 @@ LICENSE="GPL-2"
SLOT="2"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc -sparc ~x86"
-IUSE="hyperspec X new-clx dbus fastcgi gdbm gtk pari pcre postgres readline svm zlib"
+IUSE="hyperspec X new-clx dbus fastcgi gdbm gtk pari +pcre postgres +readline svm +unicode +zlib" #threads
RDEPEND="virtual/libiconv
>=dev-libs/libsigsegv-2.4
@@ -42,7 +42,7 @@ enable_modules() {
[[ $# = 0 ]] && die "${FUNCNAME[0]} must receive at least one argument"
for m in "$@" ; do
einfo "enabling module $m"
- myconf="${myconf} --with-module=${m}"
+ myconf+=" --with-module=${m}"
done
}
@@ -63,7 +63,7 @@ src_prepare() {
src_configure() {
# built-in features
local myconf="--with-ffcall --with-dynamic-modules"
- use readline || myconf="${myconf} --with-noreadline"
+# use threads && myconf+=" --with-threads=POSIX_THREADS"
# We need this to build on alpha/ia64
if use alpha || use ia64; then
@@ -106,6 +106,7 @@ src_configure() {
# configure chokes on --sysconfdir option
local configure="./configure --prefix=/usr --libdir=/usr/$(get_libdir) \
+ $(use_with readline) $(use_with unicode) \
${myconf} --hyperspec=${CLHSROOT} ${BUILDDIR}"
einfo "${configure}"
${configure} || die "./configure failed"
@@ -117,6 +118,7 @@ src_configure() {
}
src_compile() {
+ export VARTEXFONTS="${T}"/fonts
cd "${BUILDDIR}"
# parallel build fails
emake -j1 || die "emake failed"
@@ -126,7 +128,7 @@ src_install() {
pushd "${BUILDDIR}"
make DESTDIR="${D}" prefix=/usr install-bin || die
doman clisp.1
- dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE clisp.dvi clisp.html
+ dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE
chmod a+x "${D}"/usr/$(get_libdir)/clisp-${PV/_*/}/clisp-link
# stripping them removes common symbols (defined but uninitialised variables)
# which are then needed to build modules...