summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2008-05-13 11:36:55 +0000
committerMarijn Schouten <hkbst@gentoo.org>2008-05-13 11:36:55 +0000
commit3fd33bf5ae89de68ba5e815b0f71187a57396a77 (patch)
tree6a4add554c30248b9a08662939d039d40b1e0bfd /dev-lisp/clisp/clisp-2.41.ebuild
parentbump, bug 218739 and fix bug 155402, thanks to Stelian Ionescu <stelian.iones... (diff)
downloadgentoo-2-3fd33bf5ae89de68ba5e815b0f71187a57396a77.tar.gz
gentoo-2-3fd33bf5ae89de68ba5e815b0f71187a57396a77.tar.bz2
gentoo-2-3fd33bf5ae89de68ba5e815b0f71187a57396a77.zip
drop old versions
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'dev-lisp/clisp/clisp-2.41.ebuild')
-rw-r--r--dev-lisp/clisp/clisp-2.41.ebuild93
1 files changed, 0 insertions, 93 deletions
diff --git a/dev-lisp/clisp/clisp-2.41.ebuild b/dev-lisp/clisp/clisp-2.41.ebuild
deleted file mode 100644
index eb32406e2d70..000000000000
--- a/dev-lisp/clisp/clisp-2.41.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.41.ebuild,v 1.9 2007/09/09 18:01:53 josejx Exp $
-
-inherit flag-o-matic eutils toolchain-funcs
-
-DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
-HOMEPAGE="http://clisp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="~amd64 ppc -sparc x86"
-IUSE="X new-clx fastcgi pcre postgres readline zlib"
-
-RDEPEND=">=dev-libs/libsigsegv-2.4
- sys-devel/gettext
- virtual/tetex
- fastcgi? ( dev-libs/fcgi )
- postgres? ( >=dev-db/postgresql-8.0 )
- readline? ( sys-libs/readline )
- pcre? ( dev-libs/libpcre )
- zlib? ( sys-libs/zlib )
- X? ( new-clx? ( x11-libs/libXpm ) )"
-
-DEPEND="${RDEPEND}
- X? ( new-clx? ( x11-misc/imake x11-proto/xextproto ) )"
-
-PROVIDE="virtual/commonlisp"
-
-pkg_setup() {
- if use X; then
- if use new-clx; then
- elog "CLISP will be built with NEW-CLX support which is a C binding to Xorg libraries."
- else
- elog "CLISP will be built with MIT-CLX support."
- fi
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch ${FILESDIR}/2.41-fastcgi-Makefile-gentoo.patch
- epatch ${FILESDIR}/2.41-fastcgi-build.patch
- epatch ${FILESDIR}/2.41-linux-headers.patch
-}
-
-src_compile() {
- CC="$(tc-getCC)"
- local myconf="--with-dynamic-ffi
- --with-module=wildcard
- --with-module=rawsock"
- use elibc_glibc && myconf="${myconf} --with-module=bindings/glibc"
- use readline || myconf="${myconf} --with-noreadline"
- if use X; then
- if use new-clx; then
- myconf="${myconf} --with-module=clx/new-clx"
- else
- myconf="${myconf} --with-module=clx/mit-clx"
- fi
- fi
- if use postgres; then
- myconf="${myconf} --with-module=postgresql"
- CC="${CC} -I $(pg_config --includedir)"
- fi
- use fastcgi && myconf="${myconf} --with-module=fastcgi"
- use pcre && myconf="${myconf} --with-module=pcre"
- use zlib && myconf="${myconf} --with-module=zlib"
- einfo "Configuring with ${myconf}"
- ./configure --prefix=/usr ${myconf} build || die "./configure failed"
- cd build
- ./makemake ${myconf} >Makefile
- emake -j1 config.lisp
- sed -i 's,"vi","nano",g' config.lisp
- sed -i 's,http://www.lisp.org/HyperSpec/,http://www.lispworks.com/reference/HyperSpec/,g' config.lisp
- emake -j1 || die
-}
-
-src_install() {
- pushd build
- make DESTDIR=${D} prefix=/usr install-bin || die
- doman clisp.1
- dodoc SUMMARY README* NEWS MAGIC.add GNU-GPL COPYRIGHT \
- ANNOUNCE clisp.dvi clisp.html
- chmod a+x ${D}/usr/lib/clisp/clisp-link
- popd
- dohtml doc/impnotes.{css,html}
- dohtml build/clisp.html
- dohtml doc/clisp.png
- dodoc build/clisp.ps
- dodoc doc/{editors,CLOS-guide,LISP-tutorial}.txt
-}