summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-02-05 22:36:40 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-02-05 22:36:40 +0000
commit3531c719c071083e766a873010db2ed10596c21b (patch)
tree8be47a38fb5dd75635c7985e1873c238977b77ab /dev-lisp/cl-paip
parentRemove bmp from alpha use.mask. (diff)
downloadgentoo-2-3531c719c071083e766a873010db2ed10596c21b.tar.gz
gentoo-2-3531c719c071083e766a873010db2ed10596c21b.tar.bz2
gentoo-2-3531c719c071083e766a873010db2ed10596c21b.zip
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-lisp/cl-paip')
-rw-r--r--dev-lisp/cl-paip/ChangeLog8
-rw-r--r--dev-lisp/cl-paip/cl-paip-1.0.2.ebuild10
-rw-r--r--dev-lisp/cl-paip/files/1.0.2-package-lock-gentoo.patch20
3 files changed, 31 insertions, 7 deletions
diff --git a/dev-lisp/cl-paip/ChangeLog b/dev-lisp/cl-paip/ChangeLog
index f12454bcaf00..71b50a02fef7 100644
--- a/dev-lisp/cl-paip/ChangeLog
+++ b/dev-lisp/cl-paip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/cl-paip
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-paip/ChangeLog,v 1.3 2004/10/15 03:52:11 mkennedy Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-paip/ChangeLog,v 1.4 2005/02/05 22:36:40 mkennedy Exp $
+
+ 05 Feb 2005; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/1.0.2-package-lock-gentoo.patch, cl-paip-1.0.2.ebuild:
+ Include fix for package locks (CMUCL, SBCL); Tagging stable keywords for x86
09 Sep 2004; <mkennedy@gentoo.org> cl-paip-1.0.2.ebuild:
Corrected spelling mistake in description.
diff --git a/dev-lisp/cl-paip/cl-paip-1.0.2.ebuild b/dev-lisp/cl-paip/cl-paip-1.0.2.ebuild
index 7bda91690cb3..9060127915d0 100644
--- a/dev-lisp/cl-paip/cl-paip-1.0.2.ebuild
+++ b/dev-lisp/cl-paip/cl-paip-1.0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-paip/cl-paip-1.0.2.ebuild,v 1.4 2004/10/15 03:52:11 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-paip/cl-paip-1.0.2.ebuild,v 1.5 2005/02/05 22:36:40 mkennedy Exp $
inherit common-lisp eutils
@@ -10,9 +10,8 @@ DESCRIPTION="Common Lisp source code from Peter Norvig's book: Paradigms of Arti
HOMEPAGE="http://www.norvig.com/paip.html http://packages.debian.org/unstable/devel/cl-paip.html"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-paip/${PN}_${PV}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/c/cl-paip/${PN}_${PV}-${DEB_PV}.diff.gz"
-
LICENSE="Norvig"
-KEYWORDS="~x86"
+KEYWORDS="x86"
SLOT="0"
IUSE=""
@@ -23,7 +22,8 @@ CLPACKAGE=paip
src_unpack() {
unpack ${A}
- epatch ${PN}_${PV}-${DEB_PV}.diff
+ epatch ${PN}_${PV}-${DEB_PV}.diff || die
+ epatch ${FILESDIR}/${PV}-package-lock-gentoo.patch || die
}
src_install() {
diff --git a/dev-lisp/cl-paip/files/1.0.2-package-lock-gentoo.patch b/dev-lisp/cl-paip/files/1.0.2-package-lock-gentoo.patch
new file mode 100644
index 000000000000..2b81dafe85f0
--- /dev/null
+++ b/dev-lisp/cl-paip/files/1.0.2-package-lock-gentoo.patch
@@ -0,0 +1,20 @@
+diff -ur cl-paip-1.0.2.orig/auxfns.lisp cl-paip-1.0.2/auxfns.lisp
+--- cl-paip-1.0.2.orig/auxfns.lisp 2002-11-11 23:53:18.000000000 -0600
++++ cl-paip-1.0.2/auxfns.lisp 2005-02-05 16:29:36.297025165 -0600
+@@ -15,6 +15,16 @@
+ #+clisp
+ (dolist (pkg '(excl common-lisp common-lisp-user))
+ (setf (ext:package-lock (find-package pkg)) nil))
++ #+sbcl
++ (dolist (pkg '(common-lisp common-lisp-user))
++ (sb-ext:unlock-package (find-package pkg)))
++ #+cmu
++ (dolist (pkg '(extensions common-lisp common-lisp-user))
++ (let ((pkg (find-package pkg)))
++ (when pkg
++ (setf (ext:package-lock pkg) nil)
++ (setf (ext:package-definition-lock pkg) nil))))
++
+ ;; Don't warn if a function is defined in multiple files --
+ ;; this happens often since we refine several programs.
+ #+Lispworks