summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-21 16:58:14 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-21 16:58:14 +0000
commitcf6a382b7d38016121d5279facc95a4af1570551 (patch)
tree37429143bae6a2ed9f276841cc99bbf4a768d830 /dev-lisp/cl-awk
parentMarked stable on hppa. (Manifest recommit) (diff)
downloadgentoo-2-cf6a382b7d38016121d5279facc95a4af1570551.tar.gz
gentoo-2-cf6a382b7d38016121d5279facc95a4af1570551.tar.bz2
gentoo-2-cf6a382b7d38016121d5279facc95a4af1570551.zip
add inherit eutils
Diffstat (limited to 'dev-lisp/cl-awk')
-rw-r--r--dev-lisp/cl-awk/cl-awk-1-r1.ebuild15
-rw-r--r--dev-lisp/cl-awk/cl-awk-1.ebuild21
2 files changed, 17 insertions, 19 deletions
diff --git a/dev-lisp/cl-awk/cl-awk-1-r1.ebuild b/dev-lisp/cl-awk/cl-awk-1-r1.ebuild
index 789db50ab732..147b844cdd2b 100644
--- a/dev-lisp/cl-awk/cl-awk-1-r1.ebuild
+++ b/dev-lisp/cl-awk/cl-awk-1-r1.ebuild
@@ -1,27 +1,27 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-awk/cl-awk-1-r1.ebuild,v 1.1 2004/02/12 09:13:13 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-awk/cl-awk-1-r1.ebuild,v 1.2 2004/04/21 16:54:44 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=1
DESCRIPTION="Common Lisp implementation of AWK"
-HOMEPAGE="http://www.geocities.com/mparker762/clawk.html#clawk
- http://www.cliki.net/RegEx-CLAWK-Lexer
- http://packages.debian.org/unstable/devel/cl-awk.html"
+HOMEPAGE="http://www.geocities.com/mparker762/clawk.html#clawk http://www.cliki.net/RegEx-CLAWK-Lexer http://packages.debian.org/unstable/devel/cl-awk.html"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-awk/cl-awk_${PV}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/c/cl-awk/cl-awk_1-${DEB_PV}.diff.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
-DEPEND="dev-lisp/cl-regex"
-CLPACKAGE=clawk
+DEPEND="dev-lisp/cl-regex"
S=${WORKDIR}/cl-awk-${PV}
+CLPACKAGE=clawk
+
src_unpack() {
unpack ${A}
epatch cl-awk_${PV}-${DEB_PV}.diff
@@ -31,7 +31,6 @@ src_install() {
common-lisp-install clawk.lisp utils.lisp packages.lisp clawk.asd
common-lisp-system-symlink
do-debian-credits
- dodoc license.txt
docinto examples
dodoc clawktest.lisp emp.data
}
diff --git a/dev-lisp/cl-awk/cl-awk-1.ebuild b/dev-lisp/cl-awk/cl-awk-1.ebuild
index 384041e7109e..a31ddb56f646 100644
--- a/dev-lisp/cl-awk/cl-awk-1.ebuild
+++ b/dev-lisp/cl-awk/cl-awk-1.ebuild
@@ -1,27 +1,27 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-awk/cl-awk-1.ebuild,v 1.2 2003/10/15 18:10:05 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-awk/cl-awk-1.ebuild,v 1.3 2004/04/21 16:55:19 vapier Exp $
-inherit common-lisp
+inherit common-lisp eutils
DEB_PV=1
DESCRIPTION="Common Lisp implementation of AWK"
-HOMEPAGE="http://www.geocities.com/mparker762/clawk.html#clawk
- http://www.cliki.net/RegEx-CLAWK-Lexer
- http://packages.debian.org/unstable/devel/cl-awk.html"
+HOMEPAGE="http://www.geocities.com/mparker762/clawk.html#clawk http://www.cliki.net/RegEx-CLAWK-Lexer http://packages.debian.org/unstable/devel/cl-awk.html"
SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-awk/cl-awk_${PV}.orig.tar.gz
http://ftp.debian.org/debian/pool/main/c/cl-awk/cl-awk_1-${DEB_PV}.diff.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
-DEPEND="dev-lisp/cl-regex"
-CLPACKAGE=clawk
+DEPEND="dev-lisp/cl-regex"
S=${WORKDIR}/cl-awk-${PV}
+CLPACKAGE=clawk
+
src_unpack() {
unpack ${A}
epatch cl-awk_${PV}-${DEB_PV}.diff
@@ -30,15 +30,14 @@ src_unpack() {
src_install() {
common-lisp-install clawk.lisp utils.lisp packages.lisp clawk.asd
common-lisp-system-symlink
- dodoc license.txt
docinto examples
dodoc clawktest.lisp emp.data
}
pkg_preinst() {
- rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+ rm -rf ${ROOT}/usr/lib/common-lisp/*/${CLPACKAGE} || true
}
pkg_postrm() {
- rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+ rm -rf ${ROOT}/usr/lib/common-lisp/*/${CLPACKAGE} || true
}