summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-25 12:58:06 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-25 12:58:06 +0000
commitadd9c9e9e83fc9d682326ae2b0923ec44392792c (patch)
treed20419c8f408c4441e02745ed0481550b0a16976 /dev-libs
parent*** empty log message *** (diff)
downloadgentoo-2-add9c9e9e83fc9d682326ae2b0923ec44392792c.tar.gz
gentoo-2-add9c9e9e83fc9d682326ae2b0923ec44392792c.tar.bz2
gentoo-2-add9c9e9e83fc9d682326ae2b0923ec44392792c.zip
*** empty log message ***
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libunicode/files/digest-libunicode-0.41
-rw-r--r--dev-libs/libunicode/libunicode-0.4.ebuild35
-rw-r--r--dev-libs/libxml/files/digest-libxml-1.8.10-r11
-rw-r--r--dev-libs/libxml/libxml-1.8.10-r1.ebuild33
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-libs/libunicode/files/digest-libunicode-0.4 b/dev-libs/libunicode/files/digest-libunicode-0.4
new file mode 100644
index 000000000000..dd54d95a09f0
--- /dev/null
+++ b/dev-libs/libunicode/files/digest-libunicode-0.4
@@ -0,0 +1 @@
+MD5 d788ed7595a0250931f421068f4a0083 libunicode-0.4.tar.gz
diff --git a/dev-libs/libunicode/libunicode-0.4.ebuild b/dev-libs/libunicode/libunicode-0.4.ebuild
new file mode 100644
index 000000000000..bbf177aaed1a
--- /dev/null
+++ b/dev-libs/libunicode/libunicode-0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="The Gnome Application Libraries"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND=">=sys-libs/glibc-2.1.3"
+RDEPEND="$DEPEND
+ >=sys-apps/bash-2.04"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ try ./configure --host=${CHOST} --prefix=/opt/gnome
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/opt/gnome install
+
+ dodoc AUTHORS COPYING.* ChangeLog NEWS README THANKS TODO
+}
+
+
+
+
diff --git a/dev-libs/libxml/files/digest-libxml-1.8.10-r1 b/dev-libs/libxml/files/digest-libxml-1.8.10-r1
new file mode 100644
index 000000000000..f9b98c8fb800
--- /dev/null
+++ b/dev-libs/libxml/files/digest-libxml-1.8.10-r1
@@ -0,0 +1 @@
+MD5 4773efd97515916b9b4a7d6a303997d4 libxml-1.8.10.tar.gz
diff --git a/dev-libs/libxml/libxml-1.8.10-r1.ebuild b/dev-libs/libxml/libxml-1.8.10-r1.ebuild
new file mode 100644
index 000000000000..1f920c045919
--- /dev/null
+++ b/dev-libs/libxml/libxml-1.8.10-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml/libxml-1.8.10-r1.ebuild,v 1.1 2000/11/25 12:57:02 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="libxml"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/"${A}
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND=">=sys-libs/gpm-1.19.3"
+RDEPEND="$DEPEND
+ >=sys-apps/bash-2.04"
+
+src_compile() {
+ cd ${S}
+ LDFLAGS="-lncurses" try ./configure --host=${CHOST} --prefix=/opt/gnome
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make install prefix=${D}/opt/gnome
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}
+
+
+
+
+
+
+