summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-03 21:49:04 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-03 21:49:04 +0000
commit203f2e5d686e74e581e8e836581429b54d170306 (patch)
treebe11b69188e784291b9b1aafdd0fddbd8da34408 /dev-libs
parentd comes before e in alphabetical order... (diff)
downloadgentoo-2-203f2e5d686e74e581e8e836581429b54d170306.tar.gz
gentoo-2-203f2e5d686e74e581e8e836581429b54d170306.tar.bz2
gentoo-2-203f2e5d686e74e581e8e836581429b54d170306.zip
Version bump.
(Portage version: 13767-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/icu/ChangeLog8
-rw-r--r--dev-libs/icu/icu-4.2.1.ebuild71
2 files changed, 78 insertions, 1 deletions
diff --git a/dev-libs/icu/ChangeLog b/dev-libs/icu/ChangeLog
index 07379339fc2b..b3b714d5c088 100644
--- a/dev-libs/icu/ChangeLog
+++ b/dev-libs/icu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/icu
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.88 2009/06/28 16:57:03 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.89 2009/07/03 21:49:04 arfrever Exp $
+
+*icu-4.2.1 (03 Jul 2009)
+
+ 03 Jul 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +icu-4.2.1.ebuild:
+ Version bump.
28 Jun 2009; Tobias Klausmann <klausman@gentoo.org> icu-4.2.ebuild:
Stable on alpha, bug #275593
diff --git a/dev-libs/icu/icu-4.2.1.ebuild b/dev-libs/icu/icu-4.2.1.ebuild
new file mode 100644
index 000000000000..88683eb153b1
--- /dev/null
+++ b/dev-libs/icu/icu-4.2.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-4.2.1.ebuild,v 1.1 2009/07/03 21:49:04 arfrever Exp $
+
+EAPI="2"
+
+inherit eutils versionator
+
+DESCRIPTION="International Components for Unicode"
+HOMEPAGE="http://www.icu-project.org/ http://ibm.com/software/globalization/icu/"
+
+BASEURI="http://download.icu-project.org/files/${PN}4c/${PV}"
+DOCS_PV="$(get_version_component_range 1-2)"
+DOCS_BASEURI="http://download.icu-project.org/files/${PN}4c/${DOCS_PV}"
+DOCS_PV="${DOCS_PV/./_}"
+SRCPKG="${PN}4c-${PV//./_}-src.tgz"
+APIDOCS="${PN}4c-${DOCS_PV}-docs.zip"
+
+SRC_URI="${BASEURI}/${SRCPKG}
+ doc? ( ${DOCS_BASEURI}/${APIDOCS} )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples"
+
+DEPEND="doc? ( app-arch/unzip )"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}/source"
+
+src_unpack() {
+ unpack ${SRCPKG}
+ if use doc; then
+ mkdir apidocs
+ pushd apidocs > /dev/null
+ unpack ${APIDOCS}
+ popd > /dev/null
+ fi
+}
+
+src_prepare() {
+ # Do not hardcode used CFLAGS, LDFLAGS etc. into icu-config
+ # Bug 202059
+ # http://bugs.icu-project.org/trac/ticket/6102
+ for x in ARFLAGS CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
+ sed -i -e "/^${x} =.*/s:@${x}@::" "config/Makefile.inc.in" || die "sed failed"
+ done
+}
+
+src_configure() {
+ econf \
+ --enable-static \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_test() {
+ emake check || die "emake check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dohtml ../readme.html
+ dodoc ../unicode-license.txt
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html/apidocs
+ doins -r "${WORKDIR}"/apidocs/*
+ fi
+}