summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-09-24 12:34:41 +0000
committerPeter Volkov <pva@gentoo.org>2008-09-24 12:34:41 +0000
commit10e5146936cd3c82a2a358e1af62b316acb47077 (patch)
tree40d10dd5550942f3994b2679d3b060c7713a4b8a /dev-libs
parentLicense for a free GeoLite Country database (part of geoip). (diff)
downloadgentoo-2-10e5146936cd3c82a2a358e1af62b316acb47077.tar.gz
gentoo-2-10e5146936cd3c82a2a358e1af62b316acb47077.tar.bz2
gentoo-2-10e5146936cd3c82a2a358e1af62b316acb47077.zip
Version bump. Fixed parallel make failure #180988, thank Mike Doty for report. Do not build test programs, bug #226207, thank Diego Pettenò for report. Remove old.
(Portage version: 2.2_rc9/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/geoip/ChangeLog12
-rw-r--r--dev-libs/geoip/files/geoip-1.4.4-no-noinst_PROGRAMS.patch69
-rw-r--r--dev-libs/geoip/files/geoip-1.4.4-parallel-build.patch59
-rw-r--r--dev-libs/geoip/geoip-1.4.2.ebuild38
-rw-r--r--dev-libs/geoip/geoip-1.4.3.ebuild39
-rw-r--r--dev-libs/geoip/geoip-1.4.5.ebuild41
6 files changed, 180 insertions, 78 deletions
diff --git a/dev-libs/geoip/ChangeLog b/dev-libs/geoip/ChangeLog
index bb2548965182..097cc6a484c5 100644
--- a/dev-libs/geoip/ChangeLog
+++ b/dev-libs/geoip/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-libs/geoip
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/geoip/ChangeLog,v 1.90 2008/03/15 12:11:14 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/geoip/ChangeLog,v 1.91 2008/09/24 12:34:40 pva Exp $
+
+*geoip-1.4.5 (24 Sep 2008)
+
+ 24 Sep 2008; Peter Volkov <pva@gentoo.org>
+ +files/geoip-1.4.4-no-noinst_PROGRAMS.patch,
+ +files/geoip-1.4.4-parallel-build.patch, -geoip-1.4.2.ebuild,
+ -geoip-1.4.3.ebuild, +geoip-1.4.5.ebuild:
+ Version bump. Fixed parallel make failure #180988, thank Mike Doty for
+ report. Do not build test programs, bug #226207, thank Diego Pettenò for
+ report. Remove old.
15 Mar 2008; Markus Rothe <corsair@gentoo.org> geoip-1.4.4.ebuild:
Stable on ppc64; bug #212359
diff --git a/dev-libs/geoip/files/geoip-1.4.4-no-noinst_PROGRAMS.patch b/dev-libs/geoip/files/geoip-1.4.4-no-noinst_PROGRAMS.patch
new file mode 100644
index 000000000000..334147cb62e3
--- /dev/null
+++ b/dev-libs/geoip/files/geoip-1.4.4-no-noinst_PROGRAMS.patch
@@ -0,0 +1,69 @@
+=== modified file 'test/Makefile.am'
+--- test/Makefile.am 2008-09-08 09:44:05 +0000
++++ test/Makefile.am 2008-09-08 09:44:14 +0000
+@@ -4,56 +4,25 @@
+
+ check_PROGRAMS = test-geoip
+
+-#if WITH_CITY
+-noinst_PROGRAMS = benchmark test-geoip-region test-geoip-city test-geoip-org test-geoip-asnum test-geoip-isp test-geoip-netspeed
+-#else
+-#noinst_PROGRAMS = benchmark test-geoip-region
+-#endif
++EXTRA_PROGRAMS = benchmark \
++ test-geoip-region \
++ test-geoip-city \
++ test-geoip-org \
++ test-geoip-asnum \
++ test-geoip-isp \
++ test-geoip-netspeed
+
+-DEPS = $(top_builddir)/libGeoIP/libGeoIP.la
+-LDADDS = $(top_builddir)/libGeoIP/libGeoIP.la
++LDADD = $(top_builddir)/libGeoIP/libGeoIP.la
+
+ test_geoip_SOURCES = test-geoip.c
+-test_geoip_LDFLAGS =
+-test_geoip_DEPENDENCIES = $(DEPS)
+-test_geoip_LDADD = $(LDADDS)
+
+ test_geoip_region_SOURCES = test-geoip-region.c
+-test_geoip_region_LDFLAGS =
+-test_geoip_region_DEPENDENCIES = $(DEPS)
+-test_geoip_region_LDADD = $(LDADDS)
+-
+ test_geoip_org_SOURCES = test-geoip-org.c
+-test_geoip_org_LDFLAGS =
+-test_geoip_org_DEPENDENCIES = $(DEPS)
+-test_geoip_org_LDADD = $(LDADDS)
+-
+ test_geoip_isp_SOURCES = test-geoip-isp.c
+-test_geoip_isp_LDFLAGS =
+-test_geoip_isp_DEPENDENCIES = $(DEPS)
+-test_geoip_isp_LDADD = $(LDADDS)
+-
+ test_geoip_asnum_SOURCES = test-geoip-asnum.c
+-test_geoip_asnum_LDFLAGS =
+-test_geoip_asnum_DEPENDENCIES = $(DEPS)
+-test_geoip_asnum_LDADD = $(LDADDS)
+-
+ test_geoip_netspeed_SOURCES = test-geoip-netspeed.c
+-test_geoip_netspeed_LDFLAGS =
+-test_geoip_netspeed_DEPENDENCIES = $(DEPS)
+-test_geoip_netspeed_LDADD = $(LDADDS)
+-
+-if WITH_CITY
+ test_geoip_city_SOURCES = test-geoip-city.c
+-test_geoip_city_LDFLAGS =
+-test_geoip_city_DEPENDENCIES = $(DEPS)
+-test_geoip_city_LDADD = $(LDADDS)
+-endif
+-
+ benchmark_SOURCES = benchmark.c
+-benchmark_LDFLAGS =
+-benchmark_DEPENDENCIES = $(DEPS)
+-benchmark_LDADD = $(LDADDS)
+
+ EXTRA_DIST = country_test.txt country_test2.txt country_test_name.txt region_test.txt
+ TESTS = test-geoip
+
diff --git a/dev-libs/geoip/files/geoip-1.4.4-parallel-build.patch b/dev-libs/geoip/files/geoip-1.4.4-parallel-build.patch
new file mode 100644
index 000000000000..8672bf7f8cfe
--- /dev/null
+++ b/dev-libs/geoip/files/geoip-1.4.4-parallel-build.patch
@@ -0,0 +1,59 @@
+Source: Peter Volkov <pva@gentoo.org>
+Upstream: Notified
+Reason: parallel make failed.
+
+From automake info page:
+
+ When writing `install-exec-hook' or `install-data-hook', please bear in mind
+ that the exec/data distinction is based on the installation directory, not
+ on the primary used (*note Install::). So a `foo_SCRIPTS' will be installed
+ by `install-data', and a `barexec_SCRIPTS' will be installed by
+ `install-exec'. You should define your hooks consequently.
+
+ Variables using the standard directory prefixes `bin', `sbin', `libexec',
+ `sysconf', `localstate', `lib', or `pkglib' are installed by `install-exec'.
+
+thus change from install-data-hook to install-exec-hook.
+
+ Automake also supports two install hooks, `install-exec-hook' and
+ `install-data-hook'. These hooks are run after all other install rules of
+ the appropriate type, exec or data, have completed. So, for instance, it is
+ possible to perform post-installation modifications using an install hook.
+
+thus no need for dependencies.
+
+--- conf/Makefile.am 2008-09-02 14:26:04 +0000
++++ conf/Makefile.am 2008-09-02 17:18:02 +0000
+@@ -4,7 +4,7 @@
+
+ DEFAULT_CONFIG_FILE = $(sysconfdir)/GeoIP.conf
+
+-install-data-hook: install-sysconfDATA
++install-exec-hook:
+ @if test -f $(DESTDIR)$(DEFAULT_CONFIG_FILE) ; then \
+ echo "$@ will not overwrite existing $(DESTDIR)$(DEFAULT_CONFIG_FILE)" ; \
+ else \
+
+--- data/Makefile.am 2008-09-02 14:26:04 +0000
++++ data/Makefile.am 2008-09-02 17:19:00 +0000
+@@ -4,7 +4,7 @@
+
+ DEFAULT_DB_FILE = $(pkgdatadir)/GeoIP.dat
+
+-install-data-hook: install-pkgdataDATA
++install-data-hook:
+ @if test -f $(DESTDIR)$(DEFAULT_DB_FILE) ; then \
+ echo "$@ will not overwrite existing $(DESTDIR)$(DEFAULT_DB_FILE)" ; \
+ else \
+
+--- man/Makefile.am 2008-09-02 14:26:04 +0000
++++ man/Makefile.am 2008-09-02 17:19:06 +0000
+@@ -5,6 +5,6 @@
+ UPDATE_MAN = $(mandir)/man1/geoipupdate.1
+ LOOKUP_MAN = $(mandir)/man1/geoiplookup.1
+
+-install-data-hook: install-man
++install-data-hook:
+ cat geoipupdate.1 | sed s,DATADIR,$(pkgdatadir), | sed s,CONF_DIR,$(sysconfdir), > $(DESTDIR)$(UPDATE_MAN)
+ cat geoiplookup.1 | sed s,DATADIR,$(pkgdatadir), > $(DESTDIR)$(LOOKUP_MAN)
+
diff --git a/dev-libs/geoip/geoip-1.4.2.ebuild b/dev-libs/geoip/geoip-1.4.2.ebuild
deleted file mode 100644
index 4253199ad8d7..000000000000
--- a/dev-libs/geoip/geoip-1.4.2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/geoip/geoip-1.4.2.ebuild,v 1.9 2007/12/10 02:03:21 jer Exp $
-
-inherit autotools eutils libtool
-
-MY_P="${P/geoip/GeoIP}"
-DESCRIPTION="easily lookup countries by IP addresses, even when Reverse DNS entries don't exist"
-HOMEPAGE="http://www.maxmind.com/geoip/api/c.shtml"
-SRC_URI="http://www.maxmind.com/download/geoip/api/c/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # FreeBSD requires this
- elibtoolize
-}
-
-src_compile() {
- econf --enable-shared || die "econf failed"
- # both parallel make and parallel make install explodes atm
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
-}
diff --git a/dev-libs/geoip/geoip-1.4.3.ebuild b/dev-libs/geoip/geoip-1.4.3.ebuild
deleted file mode 100644
index 85076cb3fa8c..000000000000
--- a/dev-libs/geoip/geoip-1.4.3.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/geoip/geoip-1.4.3.ebuild,v 1.7 2008/02/08 19:16:15 coldwind Exp $
-
-inherit autotools eutils libtool
-
-MY_P="${P/geoip/GeoIP}"
-DESCRIPTION="easily lookup countries by IP addresses, even when Reverse DNS entries don't exist"
-HOMEPAGE="http://www.maxmind.com/geoip/api/c.shtml"
-SRC_URI="http://www.maxmind.com/download/geoip/api/c/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # FreeBSD requires this
- elibtoolize
-}
-
-src_compile() {
- econf --enable-shared || die "econf failed"
- # both parallel make and parallel make install explodes atm
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- emake -j1 DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog README TODO
-}
diff --git a/dev-libs/geoip/geoip-1.4.5.ebuild b/dev-libs/geoip/geoip-1.4.5.ebuild
new file mode 100644
index 000000000000..4e7c566afa56
--- /dev/null
+++ b/dev-libs/geoip/geoip-1.4.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/geoip/geoip-1.4.5.ebuild,v 1.1 2008/09/24 12:34:40 pva Exp $
+
+inherit autotools eutils libtool
+
+MY_P="${P/geoip/GeoIP}"
+DESCRIPTION="easily lookup countries by IP addresses, even when Reverse DNS entries don't exist"
+HOMEPAGE="http://www.maxmind.com/geoip/api/c.shtml"
+SRC_URI="http://www.maxmind.com/download/geoip/api/c/${MY_P}.tar.gz"
+
+# GPL-2 for md5.c - part of libGeoIPUpdate, MaxMind for GeoLite Country db
+LICENSE="LGPL-2.1 GPL-2 MaxMind"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.4.4-parallel-build.patch
+ epatch "${FILESDIR}"/${PN}-1.4.4-no-noinst_PROGRAMS.patch
+ eautoreconf
+ # FreeBSD requires this
+ #elibtoolize
+}
+
+src_compile() {
+ econf --enable-shared
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dobin apps/geoipupdate-pureperl.pl
+ dodoc AUTHORS ChangeLog README TODO
+ newdoc data/README README.data
+}