summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-05-23 04:51:54 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-05-23 04:51:54 +0000
commit516fd1660ecd29f26ba52e1cab3f8d776e5e8dab (patch)
tree53b25718668d3fdf3358ac638fe7cac7275c1d7f /dev-libs/zziplib
parentStable for HPPA (bug #266986). (diff)
downloadgentoo-2-516fd1660ecd29f26ba52e1cab3f8d776e5e8dab.tar.gz
gentoo-2-516fd1660ecd29f26ba52e1cab3f8d776e5e8dab.tar.bz2
gentoo-2-516fd1660ecd29f26ba52e1cab3f8d776e5e8dab.zip
version bump; clean old
(Portage version: 2.1.6.11/cvs/Linux i686)
Diffstat (limited to 'dev-libs/zziplib')
-rw-r--r--dev-libs/zziplib/ChangeLog11
-rw-r--r--dev-libs/zziplib/files/zziplib-0.13.52-SDL-test.patch14
-rw-r--r--dev-libs/zziplib/files/zziplib-0.13.52-python.patch15
-rw-r--r--dev-libs/zziplib/files/zziplib-0.13.52-sparc-aligned-access.patch33
-rw-r--r--dev-libs/zziplib/zziplib-0.13.52.ebuild (renamed from dev-libs/zziplib/zziplib-0.13.49.ebuild)31
5 files changed, 89 insertions, 15 deletions
diff --git a/dev-libs/zziplib/ChangeLog b/dev-libs/zziplib/ChangeLog
index 358cf6efda60..9f18778fe43b 100644
--- a/dev-libs/zziplib/ChangeLog
+++ b/dev-libs/zziplib/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/zziplib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/zziplib/ChangeLog,v 1.61 2009/01/07 17:48:46 ken69267 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/zziplib/ChangeLog,v 1.62 2009/05/23 04:51:54 mr_bones_ Exp $
+
+*zziplib-0.13.52 (23 May 2009)
+
+ 23 May 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/zziplib-0.13.52-SDL-test.patch,
+ +files/zziplib-0.13.52-python.patch,
+ +files/zziplib-0.13.52-sparc-aligned-access.patch,
+ -zziplib-0.13.49.ebuild, +zziplib-0.13.52.ebuild:
+ version bump; clean old
07 Jan 2009; Kenneth Prugh <ken69267@gentoo.org>
zziplib-0.13.49-r1.ebuild:
diff --git a/dev-libs/zziplib/files/zziplib-0.13.52-SDL-test.patch b/dev-libs/zziplib/files/zziplib-0.13.52-SDL-test.patch
new file mode 100644
index 000000000000..410a2c746c95
--- /dev/null
+++ b/dev-libs/zziplib/files/zziplib-0.13.52-SDL-test.patch
@@ -0,0 +1,14 @@
+this test isnt even run automatically and the dependencies are all broken,
+so just disable it and be done
+
+--- SDL/Makefile.in
++++ SDL/Makefile.in
+@@ -38,7 +38,7 @@
+ build_triplet = @build@
+ host_triplet = @host@
+ target_triplet = @target@
+-check_PROGRAMS = zzcatsdl$(EXEEXT)
++check_PROGRAMS =
+ subdir = SDL
+ DIST_COMMON = $(pkgconfig_HEADERS) $(srcdir)/Makefile.am \
+ $(srcdir)/Makefile.in
diff --git a/dev-libs/zziplib/files/zziplib-0.13.52-python.patch b/dev-libs/zziplib/files/zziplib-0.13.52-python.patch
new file mode 100644
index 000000000000..f1cfae16a195
--- /dev/null
+++ b/dev-libs/zziplib/files/zziplib-0.13.52-python.patch
@@ -0,0 +1,15 @@
+Make it find correct Python version bug
+
+http://bugs.gentoo.org/174189
+
+--- configure
++++ configure
+@@ -21037,7 +21037,7 @@
+ done
+ test -n "$PERL" || PERL="echo no perl found for"
+
+-for ac_prog in python2.2 python2.3 python
++for ac_prog in python
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
+ set dummy $ac_prog; ac_word=$2
diff --git a/dev-libs/zziplib/files/zziplib-0.13.52-sparc-aligned-access.patch b/dev-libs/zziplib/files/zziplib-0.13.52-sparc-aligned-access.patch
new file mode 100644
index 000000000000..87ee790465a4
--- /dev/null
+++ b/dev-libs/zziplib/files/zziplib-0.13.52-sparc-aligned-access.patch
@@ -0,0 +1,33 @@
+This patch for zziplib (0.13.50) fixes a bus error on Linux/SPARC.
+
+Since SPARC machines are big endian and zip files are stored in little endian,
+zziplib needs to do byte swapping. On GNU/Linux this is usually done using
+glibc's bswap_{16,32,64} functions but in this case calling one of these
+functions triggers a bus error. This patch completes upstreams work to
+implement ZZIP_HAVE_ALIGNED_ACCESS_REQUIRED for machines which required aligned
+access.
+After applying the patch zziplib needs to be compiled with
+-DZZIP_HAVE_ALIGNED_ACCESS_REQUIRED
+
+To reproduce it run (in the src dir):
+ cd Linux_*_sparc64.d && ./bins/zzcat test/test/README
+or
+ make check
+
+Problem found by: Ferris McCormick <fmccor@gentoo.org>
+Patch written by: Friedrich Oslage <bluebird@gentoo.org>
+ with advice from: Mike Frysinger <vapier@gentoo.org>
+
+http://bugs.gentoo.org/239472
+
+--- zzip/fetch.c
++++ zzip/fetch.c
+@@ -17,7 +17,7 @@
+ #include <zzip/fetch.h>
+
+ #if defined ZZIP_WORDS_BIGENDIAN && \
+- defined bswap_16 && defined bswap_32 && defined bswap_64
++ defined bswap_16 && defined bswap_32 && defined bswap_64 && !defined(ZZIP_HAVE_ALIGNED_ACCESS_REQUIRED)
+ # define __ZZIP_GET16(__p) bswap_16(*(uint16_t*)(__p))
+ # define __ZZIP_GET32(__p) bswap_32(*(uint32_t*)(__p))
+ # define __ZZIP_SET16(__p,__x) (*(uint16_t*)(__p) = bswap_16((uint16_t)(__x)))
diff --git a/dev-libs/zziplib/zziplib-0.13.49.ebuild b/dev-libs/zziplib/zziplib-0.13.52.ebuild
index 4a75433f58fc..0dc59cdea860 100644
--- a/dev-libs/zziplib/zziplib-0.13.49.ebuild
+++ b/dev-libs/zziplib/zziplib-0.13.52.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/zziplib/zziplib-0.13.49.ebuild,v 1.11 2007/07/07 15:23:09 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/zziplib/zziplib-0.13.52.ebuild,v 1.1 2009/05/23 04:51:54 mr_bones_ Exp $
-inherit libtool fixheadtails eutils
+EAPI=2
+inherit libtool fixheadtails eutils flag-o-matic
DESCRIPTION="Lightweight library used to easily extract data from files archived in a single zip file"
HOMEPAGE="http://zziplib.sourceforge.net/"
@@ -10,33 +11,35 @@ SRC_URI="mirror://sourceforge/zziplib/${P}.tar.bz2"
LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh -sparc x86 ~x86-fbsd"
-IUSE="sdl"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="sdl test"
RDEPEND=">=dev-lang/python-2.3
sys-libs/zlib
sdl? ( >=media-libs/libsdl-1.2.6 )"
DEPEND="${RDEPEND}
- dev-util/pkgconfig"
+ dev-util/pkgconfig
+ test? ( app-arch/zip )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- #Make it find correct Python version bug #174189
+src_prepare() {
epatch "${FILESDIR}"/${P}-python.patch
epatch "${FILESDIR}"/${P}-SDL-test.patch
+ epatch "${FILESDIR}"/${P}-sparc-aligned-access.patch #239472
+ sed -i -e '/^Libs:/s:@LDFLAGS@::' configure || die #235511
+ sed -i -e '/^zzip-postinstall:/s:^:disabled-:' Makefile.in || die
ht_fix_file configure docs/Makefile.in uses/depcomp
elibtoolize
}
-src_compile() {
- econf $(use_enable sdl) || die
- emake || die "emake failed"
+src_configure() {
+ use sparc && append-flags -DZZIP_HAVE_ALIGNED_ACCESS_REQUIRED
+ econf $(use_enable sdl)
}
src_test() {
# need this because `make test` will always return true
- make check || die "make check failed"
+ # tests fail with -j > 1 (bug #241186)
+ emake -j1 check || die "make check failed"
}
src_install() {