summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-12-25 13:30:35 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-12-25 13:30:35 +0000
commit80d4025bcc68c355f4d0015ba2eb1569b8181abb (patch)
treea69d2a1062cb8fcb9659a92352847abf3d377d0a /dev-libs/yajl
parentDrop ruby19 to create a new stable candidate. (diff)
downloadgentoo-2-80d4025bcc68c355f4d0015ba2eb1569b8181abb.tar.gz
gentoo-2-80d4025bcc68c355f4d0015ba2eb1569b8181abb.tar.bz2
gentoo-2-80d4025bcc68c355f4d0015ba2eb1569b8181abb.zip
Version bump, thanks to Johan Bergström in bug #394985. Also shorten src_test and avoid setting S which is supposedly read-only in phases in EAPI=4 and later.
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/yajl')
-rw-r--r--dev-libs/yajl/ChangeLog9
-rw-r--r--dev-libs/yajl/yajl-2.0.3.ebuild35
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-libs/yajl/ChangeLog b/dev-libs/yajl/ChangeLog
index 84151f4fdaa1..a7d29d7ee178 100644
--- a/dev-libs/yajl/ChangeLog
+++ b/dev-libs/yajl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/yajl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/yajl/ChangeLog,v 1.16 2011/10/23 12:03:00 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yajl/ChangeLog,v 1.17 2011/12/25 13:30:35 flameeyes Exp $
+
+*yajl-2.0.3 (25 Dec 2011)
+
+ 25 Dec 2011; Diego E. Pettenò <flameeyes@gentoo.org> +yajl-2.0.3.ebuild:
+ Version bump, thanks to Johan Bergström in bug #394985. Also shorten src_test
+ and avoid setting S which is supposedly read-only in phases in EAPI=4 and
+ later.
23 Oct 2011; Tomáš Chvátal <scarabeus@gentoo.org> yajl-2.0.2.ebuild:
Make static libs optional
diff --git a/dev-libs/yajl/yajl-2.0.3.ebuild b/dev-libs/yajl/yajl-2.0.3.ebuild
new file mode 100644
index 000000000000..c402181f19fd
--- /dev/null
+++ b/dev-libs/yajl/yajl-2.0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/yajl/yajl-2.0.3.ebuild,v 1.1 2011/12/25 13:30:35 flameeyes Exp $
+
+EAPI=4
+
+inherit base cmake-utils
+
+DESCRIPTION="Small event-driven (SAX-style) JSON parser"
+HOMEPAGE="http://lloyd.github.com/yajl/"
+SRC_URI="http://github.com/lloyd/yajl/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+
+IUSE="static-libs"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-fix_static_linking.patch
+)
+
+src_unpack() {
+ unpack ${A}
+ mv "${WORKDIR}"/lloyd-${PN}-* "${S}"
+}
+
+src_test() {
+ emake -C "${CMAKE_BUILD_DIR}" test
+}
+
+src_install() {
+ cmake-utils_src_install
+ use static-libs || find "${ED}" -name '*.a' -exec rm -f {} +
+}