summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-11-26 16:32:08 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-11-26 16:32:08 +0000
commit0fcbeed5299c2038926c4ad9729d98984125b4ff (patch)
tree02e5164edcb358f78f5f7c01d00c5c20a6e24caf /dev-libs/uthash
parentPull in correct slot of dev-libs/libindicator. (diff)
downloadgentoo-2-0fcbeed5299c2038926c4ad9729d98984125b4ff.tar.gz
gentoo-2-0fcbeed5299c2038926c4ad9729d98984125b4ff.tar.bz2
gentoo-2-0fcbeed5299c2038926c4ad9729d98984125b4ff.zip
version bump. Thanks to Johan Bergström
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/uthash')
-rw-r--r--dev-libs/uthash/ChangeLog7
-rw-r--r--dev-libs/uthash/uthash-1.9.5.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-libs/uthash/ChangeLog b/dev-libs/uthash/ChangeLog
index 1038454bfcda..4d8c54b2547b 100644
--- a/dev-libs/uthash/ChangeLog
+++ b/dev-libs/uthash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/uthash
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/uthash/ChangeLog,v 1.1 2011/11/14 18:54:00 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/uthash/ChangeLog,v 1.2 2011/11/26 16:32:08 hwoarang Exp $
+
+*uthash-1.9.5 (26 Nov 2011)
+
+ 26 Nov 2011; Markos Chandras <hwoarang@gentoo.org> +uthash-1.9.5.ebuild:
+ version bump. Thanks to Johan Bergström
*uthash-1.9.4 (14 Nov 2011)
diff --git a/dev-libs/uthash/uthash-1.9.5.ebuild b/dev-libs/uthash/uthash-1.9.5.ebuild
new file mode 100644
index 000000000000..9af9482a914a
--- /dev/null
+++ b/dev-libs/uthash/uthash-1.9.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/uthash/uthash-1.9.5.ebuild,v 1.1 2011/11/26 16:32:08 hwoarang Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="An easy-to-use hash implementation for C programmers"
+HOMEPAGE="http://uthash.sourceforge.net"
+SRC_URI="mirror://sourceforge/uthash/${P}.tar.bz2"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-lang/perl )"
+RDEPEND=""
+
+src_test() {
+ cd tests
+ sed -i "/CFLAGS/s/-O3/${CFLAGS}/" Makefile || die "sed cflags failed"
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ insinto /usr/include
+ doins src/*.h || die "doins failed"
+
+ dodoc doc/txt/{ChangeLog,userguide,ut*}.txt || die "dodoc failed"
+}