summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-10-22 19:46:22 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-10-22 19:46:22 +0000
commitdfd49715317f51a2ebffc523b20522bb1028b974 (patch)
tree83597e65b55b8abafeac3a39f3252287eb2bd9fc /dev-libs/ptypes
parentReplace deprecated tcltk USE flag with tcl (#152399). (diff)
downloadgentoo-2-dfd49715317f51a2ebffc523b20522bb1028b974.tar.gz
gentoo-2-dfd49715317f51a2ebffc523b20522bb1028b974.tar.bz2
gentoo-2-dfd49715317f51a2ebffc523b20522bb1028b974.zip
Added patch for gcc-4*, thanks to James Hutton, fixes bug #148599. Added 'debug' USE-flag. Patched to respect our CXXFLAGS and CXX.
(Portage version: 2.1.2_pre3-r3)
Diffstat (limited to 'dev-libs/ptypes')
-rw-r--r--dev-libs/ptypes/ChangeLog6
-rw-r--r--dev-libs/ptypes/files/2.0.2-gcc41.patch48
-rw-r--r--dev-libs/ptypes/files/digest-ptypes-2.0.2-r13
-rw-r--r--dev-libs/ptypes/ptypes-2.0.2-r1.ebuild44
4 files changed, 100 insertions, 1 deletions
diff --git a/dev-libs/ptypes/ChangeLog b/dev-libs/ptypes/ChangeLog
index f45bd155ca52..e612d46ea397 100644
--- a/dev-libs/ptypes/ChangeLog
+++ b/dev-libs/ptypes/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/ptypes
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ptypes/ChangeLog,v 1.11 2006/02/08 05:22:17 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ptypes/ChangeLog,v 1.12 2006/10/22 19:46:22 dev-zero Exp $
+
+ 22 Oct 2006; Tiziano Müller <dev-zero@gentoo.org> ChangeLog:
+ Added patch for gcc-4*, thanks to James Hutton, fixes bug #148599. Added
+ 'debug' USE-flag. Patched to respect our CXXFLAGS and CXX.
08 Feb 2006; Mark Loeser <halcy0n@gentoo.org> ptypes-2.0.2.ebuild:
Fix ebuild to install things properly, thanks to Richard Whitty <rlw26 AT
diff --git a/dev-libs/ptypes/files/2.0.2-gcc41.patch b/dev-libs/ptypes/files/2.0.2-gcc41.patch
new file mode 100644
index 000000000000..e36d4a3f3153
--- /dev/null
+++ b/dev-libs/ptypes/files/2.0.2-gcc41.patch
@@ -0,0 +1,48 @@
+diff -Naur ptypes-2.0.2-orig/include/pstreams.h ptypes-2.0.2/include/pstreams.h
+--- ptypes-2.0.2-orig/include/pstreams.h 2006-06-09 09:41:51.000000000 -0400
++++ ptypes-2.0.2/include/pstreams.h 2006-06-09 09:42:30.000000000 -0400
+@@ -266,6 +266,9 @@
+ // internal class used in fdxstm
+ //
+
++class ptpublic fdxstm;
++class unit_thread;
++
+ class ptpublic fdxoutstm: public outstm
+ {
+ friend class fdxstm;
+diff -Naur ptypes-2.0.2-orig/include/ptypes.h ptypes-2.0.2/include/ptypes.h
+--- ptypes-2.0.2-orig/include/ptypes.h 2006-06-09 09:41:51.000000000 -0400
++++ ptypes-2.0.2/include/ptypes.h 2006-06-09 09:42:30.000000000 -0400
+@@ -46,6 +46,10 @@
+ # define VARIANT_TYPECAST_HACK
+ #endif
+
++#if (__GNUC__ == 4)
++# define VARIANT_TYPECAST_HACK
++#endif
++
+
+ // -------------------------------------------------------------------- //
+ // --- string class --------------------------------------------------- //
+@@ -71,6 +75,8 @@
+
+ ptpublic extern char* emptystr;
+
++class ptpublic variant;
++class ptpublic _varray;
+
+ class ptpublic string
+ {
+diff -Naur ptypes-2.0.2-orig/src/pvariant.cxx ptypes-2.0.2/src/pvariant.cxx
+--- ptypes-2.0.2-orig/src/pvariant.cxx 2006-06-09 09:41:51.000000000 -0400
++++ ptypes-2.0.2/src/pvariant.cxx 2006-06-09 09:42:55.000000000 -0400
+@@ -38,7 +38,7 @@
+ protected:
+ int refcount;
+
+- virtual int _varray::compare(const void* key, const void* item) const;
++ virtual int compare(const void* key, const void* item) const;
+
+ friend class variant;
+
diff --git a/dev-libs/ptypes/files/digest-ptypes-2.0.2-r1 b/dev-libs/ptypes/files/digest-ptypes-2.0.2-r1
new file mode 100644
index 000000000000..ee0a7fc64769
--- /dev/null
+++ b/dev-libs/ptypes/files/digest-ptypes-2.0.2-r1
@@ -0,0 +1,3 @@
+MD5 f5a6c90a3f9e89f90f4ea81f71c4ec7d ptypes-2.0.2.tar.gz 225135
+RMD160 60e8ff261c4a968072e6ae0e395ffde77ee1fccc ptypes-2.0.2.tar.gz 225135
+SHA256 7562b62143ca446fff73dfe8ab7c480ff731448b566d1c7841a404c79e20f584 ptypes-2.0.2.tar.gz 225135
diff --git a/dev-libs/ptypes/ptypes-2.0.2-r1.ebuild b/dev-libs/ptypes/ptypes-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..b5f8b0979161
--- /dev/null
+++ b/dev-libs/ptypes/ptypes-2.0.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ptypes/ptypes-2.0.2-r1.ebuild,v 1.1 2006/10/22 19:46:22 dev-zero Exp $
+
+inherit eutils toolchain-funcs
+
+KEYWORDS="~x86 ~amd64"
+
+DESCRIPTION="PTypes (C++ Portable Types Library) is a simple alternative to the STL that includes multithreading and networking."
+HOMEPAGE="http://www.melikyan.com/ptypes/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-gcc41.patch"
+ sed -i \
+ -e 's/-O2/$(CXXFLAGS)/' \
+ src/Makefile.common wshare/Makefile.common \
+ || die "sed failed"
+}
+
+src_compile() {
+ if ! use debug ; then
+ sed -i \
+ -e 's/^\(DDEBUG\).*/\1=/' \
+ src/Makefile.common wshare/Makefile.common \
+ || die "sed failed"
+ fi
+ emake CXX=$(tc-getCXX) CXXFLAGS="${CXXFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dolib lib/* || die "Installing libraries"
+ insinto /usr/include
+ doins include/* || die "Installing headers"
+ dohtml -r doc/* || die "Installing documentation"
+}