summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2012-05-24 20:07:50 +0000
committerTiziano Müller <dev-zero@gentoo.org>2012-05-24 20:07:50 +0000
commit636264a0eb68e99bda10d91852dd33fe346fae4f (patch)
tree0fc8a1878c70bf944c306c41171b355f6b736454 /dev-libs/ossp-uuid
parentVersion bump. Cleanup. (diff)
downloadgentoo-2-636264a0eb68e99bda10d91852dd33fe346fae4f.tar.gz
gentoo-2-636264a0eb68e99bda10d91852dd33fe346fae4f.tar.bz2
gentoo-2-636264a0eb68e99bda10d91852dd33fe346fae4f.zip
Add support for perl bindings (bug #350558, thanks to Scott Thomson). Added static-libs USE flag. Support for building with php-5.4.
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/ossp-uuid')
-rw-r--r--dev-libs/ossp-uuid/ChangeLog10
-rw-r--r--dev-libs/ossp-uuid/files/ossp-uuid-1.6.1-gentoo.patch94
-rw-r--r--dev-libs/ossp-uuid/files/ossp-uuid-1.6.2-gentoo-perl.patch24
-rw-r--r--dev-libs/ossp-uuid/files/ossp-uuid-1.6.2-php.patch13
-rw-r--r--dev-libs/ossp-uuid/ossp-uuid-1.6.2-r2.ebuild97
5 files changed, 143 insertions, 95 deletions
diff --git a/dev-libs/ossp-uuid/ChangeLog b/dev-libs/ossp-uuid/ChangeLog
index 6eecd4e2f336..e3d07b13db93 100644
--- a/dev-libs/ossp-uuid/ChangeLog
+++ b/dev-libs/ossp-uuid/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/ossp-uuid
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ossp-uuid/ChangeLog,v 1.29 2012/05/12 18:30:44 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ossp-uuid/ChangeLog,v 1.30 2012/05/24 20:07:50 dev-zero Exp $
+
+*ossp-uuid-1.6.2-r2 (24 May 2012)
+
+ 24 May 2012; Tiziano Müller <dev-zero@gentoo.org>
+ -files/ossp-uuid-1.6.1-gentoo.patch, +ossp-uuid-1.6.2-r2.ebuild,
+ +files/ossp-uuid-1.6.2-gentoo-perl.patch, +files/ossp-uuid-1.6.2-php.patch:
+ Add support for perl bindings (bug #350558, thanks to Scott Thomson). Added
+ static-libs USE flag. Support for building with php-5.4.
12 May 2012; Alexis Ballier <aballier@gentoo.org> ossp-uuid-1.6.2-r1.ebuild:
keyword ~amd64-fbsd
diff --git a/dev-libs/ossp-uuid/files/ossp-uuid-1.6.1-gentoo.patch b/dev-libs/ossp-uuid/files/ossp-uuid-1.6.1-gentoo.patch
deleted file mode 100644
index 7da4049f3800..000000000000
--- a/dev-libs/ossp-uuid/files/ossp-uuid-1.6.1-gentoo.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-diff -Naur uuid-1.6.1.orig/Makefile.in uuid-1.6.1/Makefile.in
---- uuid-1.6.1.orig/Makefile.in 2008-03-28 22:02:53.000000000 +0100
-+++ uuid-1.6.1/Makefile.in 2008-03-28 22:03:16.000000000 +0100
-@@ -62,13 +62,13 @@
- PHP = @PHP@
- PG_CONFIG = @PG_CONFIG@
-
--LIB_NAME = libuuid.la
-+LIB_NAME = libossp-uuid.la
- LIB_OBJS = uuid.lo uuid_md5.lo uuid_sha1.lo uuid_prng.lo uuid_mac.lo uuid_time.lo uuid_ui64.lo uuid_ui128.lo uuid_str.lo
-
--DCE_NAME = libuuid_dce.la
-+DCE_NAME = libossp-uuid_dce.la
- DCE_OBJS = uuid_dce.lo $(LIB_OBJS)
-
--CXX_NAME = libuuid++.la
-+CXX_NAME = libossp-uuid++.la
- CXX_OBJS = uuid++.lo $(LIB_OBJS)
-
- PRG_NAME = uuid
-@@ -253,7 +253,7 @@
- -@if [ ".$(WITH_CXX)" = .yes ]; then \
- $(LIBTOOL) --mode=install $(SHTOOL) install -c -m 644 $(CXX_NAME) $(DESTDIR)$(libdir)/; \
- fi
-- @$(LIBTOOL) --mode=install $(SHTOOL) install -c -s -m 755 uuid $(DESTDIR)$(bindir)/
-+ @$(LIBTOOL) --mode=install $(SHTOOL) install -c -m 755 uuid $(DESTDIR)$(bindir)/
- $(SHTOOL) install -c -m 644 $(S)/uuid.1 $(DESTDIR)$(mandir)/man1/
- -@if [ ".$(WITH_PERL)" = .yes ]; then \
- (cd $(S)/perl && $(MAKE) $(MFLAGS) install DESTDIR=$(DESTDIR)); \
-diff -Naur uuid-1.6.1.orig/php/config.m4 uuid-1.6.1/php/config.m4
---- uuid-1.6.1.orig/php/config.m4 2008-03-28 22:02:53.000000000 +0100
-+++ uuid-1.6.1/php/config.m4 2008-03-28 23:22:54.000000000 +0100
-@@ -33,10 +33,10 @@
- if test "$PHP_UUID" != "no"; then
- PHP_NEW_EXTENSION(uuid, uuid.c, $ext_shared)
- AC_DEFINE(HAVE_UUID, 1, [Have OSSP uuid library])
-- PHP_ADD_LIBPATH([..], )
-- PHP_ADD_LIBRARY([uuid],, UUID_SHARED_LIBADD)
-+ PHP_ADD_LIBRARY([ossp-uuid],, UUID_SHARED_LIBADD)
- PHP_ADD_INCLUDE([..])
- PHP_SUBST(UUID_SHARED_LIBADD)
-+ LDFLAGS="$LDFLAGS -L../.libs"
-
- dnl avoid linking conflict with a potentially existing uuid_create(3) in libc
- AC_CHECK_FUNC(uuid_create,[
-diff -Naur uuid-1.6.1.orig/php/Makefile.local uuid-1.6.1/php/Makefile.local
---- uuid-1.6.1.orig/php/Makefile.local 2008-03-28 22:02:53.000000000 +0100
-+++ uuid-1.6.1/php/Makefile.local 2008-03-28 22:10:17.000000000 +0100
-@@ -42,7 +42,7 @@
-
- test: build
- @version=`$(PHP)-config --version | sed -e 's;^\([0-9]\).*$$;\1;'`; \
-- $(PHP) -q -d "safe_mode=0" -d "extension_dir=./" uuid.ts $$version
-+ $(PHP) -q -d "safe_mode=0" -d "extension_dir=./modules/" uuid.ts $$version
-
- install: build
- @version=`$(PHP)-config --version | sed -e 's;^\([0-9]\).*$$;\1;'`; extdir="$(EXTDIR)"; \
-diff -Naur uuid-1.6.1.orig/php/uuid.ts uuid-1.6.1/php/uuid.ts
---- uuid-1.6.1.orig/php/uuid.ts 2008-03-28 22:02:53.000000000 +0100
-+++ uuid-1.6.1/php/uuid.ts 2008-03-28 22:10:37.000000000 +0100
-@@ -36,7 +36,7 @@
-
- print "++ loading DSO uuid.so (low-level API)\n";
- if (!extension_loaded('uuid')) {
-- dl('modules/uuid.so');
-+ dl('uuid.so');
- }
-
- print "++ loading PHP uuid.php${php_version} (high-level API)\n";
-diff -Naur uuid-1.6.1.orig/uuid-config.in uuid-1.6.1/uuid-config.in
---- uuid-1.6.1.orig/uuid-config.in 2008-03-28 22:02:53.000000000 +0100
-+++ uuid-1.6.1/uuid-config.in 2008-03-28 22:03:06.000000000 +0100
-@@ -121,7 +121,7 @@
- output_extra="$output_extra $uuid_ldflags"
- ;;
- --libs)
-- output="$output -luuid"
-+ output="$output -lossp-uuid"
- output_extra="$output_extra $uuid_libs"
- ;;
- * )
-diff -Naur uuid-1.6.1.orig/uuid.pc.in uuid-1.6.1/uuid.pc.in
---- uuid-1.6.1.orig/uuid.pc.in 2008-03-28 22:02:53.000000000 +0100
-+++ uuid-1.6.1/uuid.pc.in 2008-03-28 22:03:06.000000000 +0100
-@@ -36,7 +36,7 @@
- Description: Universally Unique Identifier (UUID) Library
- Version: @UUID_VERSION_RAW@
- URL: http://www.ossp.org/pkg/lib/uuid/
--Cflags: -I${includedir}
--Libs: -L${libdir} -luuid
-+Cflags: -I${includedir}/ossp
-+Libs: -L${libdir} -lossp-uuid
- Libs.private: @LIBS@
-
diff --git a/dev-libs/ossp-uuid/files/ossp-uuid-1.6.2-gentoo-perl.patch b/dev-libs/ossp-uuid/files/ossp-uuid-1.6.2-gentoo-perl.patch
new file mode 100644
index 000000000000..a4fade8b088b
--- /dev/null
+++ b/dev-libs/ossp-uuid/files/ossp-uuid-1.6.2-gentoo-perl.patch
@@ -0,0 +1,24 @@
+--- tmp/uuid-1.6.2/perl/Makefile.PL 2007-01-01 18:13:18.000000000 +0000
++++ uuid-1.6.2/perl/Makefile.PL 2011-01-07 11:54:23.521585547 +0000
+@@ -33,9 +33,9 @@
+ use ExtUtils::MakeMaker;
+
+ # determine source directory
+-my ($srcdir) = map { my $d = $_; $d =~ s/\/libuuid\.la$//; $d }
+- grep { -f $_ } ("../libuuid.la", glob("../*/libuuid.la"))
+- or die "no source directory found (where libuuid.la is located)";
++my ($srcdir) = map { my $d = $_; $d =~ s/\/libossp-uuid\.la$//; $d }
++ grep { -f $_ } ("../libossp-uuid.la", glob("../*/libossp-uuid.la"))
++ or die "no source directory found (where libossp-uuid.la is located)";
+
+ # determine extra build options
+ my $compat = 0;
+@@ -47,7 +47,7 @@
+ VERSION_FROM => 'uuid.pm',
+ ABSTRACT_FROM => 'uuid.pod',
+ PREREQ_PM => {},
+- LIBS => [ "-L$srcdir/.libs -L$srcdir -luuid" ],
++ LIBS => [ "-L$srcdir/.libs -L$srcdir -lossp-uuid" ],
+ DEFINE => '',
+ INC => "-I. -I$srcdir",
+ PM => { 'uuid.pm' => '$(INST_LIBDIR)/uuid.pm',
diff --git a/dev-libs/ossp-uuid/files/ossp-uuid-1.6.2-php.patch b/dev-libs/ossp-uuid/files/ossp-uuid-1.6.2-php.patch
new file mode 100644
index 000000000000..d57e8939f154
--- /dev/null
+++ b/dev-libs/ossp-uuid/files/ossp-uuid-1.6.2-php.patch
@@ -0,0 +1,13 @@
+diff --git a/php/uuid.c b/php/uuid.c
+index b76b718..455611a 100644
+--- a/php/uuid.c
++++ b/php/uuid.c
+@@ -496,7 +496,7 @@ PHP_FUNCTION(uuid_version)
+ }
+
+ /* module function table */
+-static function_entry uuid_functions[] = {
++static zend_function_entry uuid_functions[] = {
+ PHP_FE(uuid_create, NULL)
+ PHP_FE(uuid_destroy, NULL)
+ PHP_FE(uuid_clone, NULL)
diff --git a/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r2.ebuild b/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r2.ebuild
new file mode 100644
index 000000000000..734d85065c8c
--- /dev/null
+++ b/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r2.ebuild,v 1.1 2012/05/24 20:07:50 dev-zero Exp $
+
+EAPI="4"
+
+PHP_EXT_NAME="uuid"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+USE_PHP="php5-3 php5-4"
+
+MY_P="uuid-${PV}"
+PHP_EXT_S="${WORKDIR}/${MY_P}/php"
+PHP_EXT_OPTIONAL_USE="php"
+
+inherit eutils multilib php-ext-source-r2
+
+DESCRIPTION="An ISO-C:1999 API and corresponding CLI for the generation of DCE 1.1, ISO/IEC 11578:1996 and RFC 4122 compliant UUID."
+HOMEPAGE="http://www.ossp.org/pkg/lib/uuid/"
+SRC_URI="ftp://ftp.ossp.org/pkg/lib/uuid/${MY_P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="+cxx perl php static-libs"
+
+DEPEND="perl? ( dev-lang/perl )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+
+ epatch \
+ "${FILESDIR}/${P}-gentoo-r1.patch" \
+ "${FILESDIR}/${P}-gentoo-perl.patch"
+
+ if use php; then
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ epatch \
+ "${FILESDIR}/${P}-gentoo-php.patch" \
+ "${FILESDIR}/${P}-php.patch"
+ done
+
+ php-ext-source-r2_src_prepare
+ fi
+}
+
+src_configure() {
+ # Notes:
+ # * collides with e2fstools libs and includes if not moved around
+ # * pgsql-bindings need PostgreSQL-sources and are included since PostgreSQL 8.3
+ econf \
+ --includedir=/usr/include/ossp \
+ --with-dce \
+ --without-pgsql \
+ --without-php \
+ $(use_with cxx) \
+ $(use_with perl) \
+ $(use_enable static-libs static)
+
+ if use php; then
+ php-ext-source-r2_src_configure
+ fi
+}
+
+src_compile() {
+ default
+
+ if use php; then
+ php-ext-source-r2_src_compile
+ fi
+}
+
+src_install() {
+ DOCS="AUTHORS BINDINGS ChangeLog HISTORY NEWS OVERVIEW PORTING README SEEALSO THANKS TODO USERS"
+ default
+
+ if use php ; then
+ php-ext-source-r2_src_install
+ cd "${S}/php"
+ insinto /usr/share/php
+ newins uuid.php5 uuid.php
+ fi
+
+ use static-libs || rm -rf "${D}"/usr/lib*/*.la
+
+ mv "${D}/usr/$(get_libdir)/pkgconfig"/{,ossp-}uuid.pc
+ mv "${D}/usr/share/man/man3"/uuid.3{,ossp}
+ mv "${D}/usr/share/man/man3"/uuid++.3{,ossp}
+}
+
+src_test() {
+ export LD_LIBRARY_PATH="${S}/.libs" # required for the perl-bindings to load the (correct) library
+ default
+}