summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2015-01-30 08:38:10 +0000
committerSergey Popov <pinkbyte@gentoo.org>2015-01-30 08:38:10 +0000
commit21bc87622f8c973378878c6c36a6302a56f0b589 (patch)
treec0482a67615d4726c4d28914f778ee48e939e047 /dev-libs/nanomsg
parentAdd missing dependency on app-portage/gentoolkit as porticron calls glsa-chec... (diff)
downloadgentoo-2-21bc87622f8c973378878c6c36a6302a56f0b589.tar.gz
gentoo-2-21bc87622f8c973378878c6c36a6302a56f0b589.tar.bz2
gentoo-2-21bc87622f8c973378878c6c36a6302a56f0b589.zip
Revision bump: use multilib-aware eclasses, wrt bug #537038. Build and install manpages, wrt bug #526258
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'dev-libs/nanomsg')
-rw-r--r--dev-libs/nanomsg/ChangeLog8
-rw-r--r--dev-libs/nanomsg/nanomsg-0.5-r1.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-libs/nanomsg/ChangeLog b/dev-libs/nanomsg/ChangeLog
index e35c37639ac2..b448d0880e0a 100644
--- a/dev-libs/nanomsg/ChangeLog
+++ b/dev-libs/nanomsg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/nanomsg
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nanomsg/ChangeLog,v 1.12 2015/01/19 11:22:22 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nanomsg/ChangeLog,v 1.13 2015/01/30 08:38:10 pinkbyte Exp $
+
+*nanomsg-0.5-r1 (30 Jan 2015)
+
+ 30 Jan 2015; Sergey Popov <pinkbyte@gentoo.org> +nanomsg-0.5-r1.ebuild:
+ Revision bump: use multilib-aware eclasses, wrt bug #537038. Build and
+ install manpages, wrt bug #526258
19 Jan 2015; Sergey Popov <pinkbyte@gentoo.org> nanomsg-0.5.ebuild:
Add ~mips/~ppc/~ppc64/~s390 keywords, wrt bug #536804
diff --git a/dev-libs/nanomsg/nanomsg-0.5-r1.ebuild b/dev-libs/nanomsg/nanomsg-0.5-r1.ebuild
new file mode 100644
index 000000000000..524454d74feb
--- /dev/null
+++ b/dev-libs/nanomsg/nanomsg-0.5-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nanomsg/nanomsg-0.5-r1.ebuild,v 1.1 2015/01/30 08:38:10 pinkbyte Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-multilib
+
+DESCRIPTION="High-performance messaging interface for distributed applications"
+HOMEPAGE="http://nanomsg.org/"
+SRC_URI="http://download.nanomsg.org/${P}-beta.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/0.2.1"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~s390 ~x86"
+IUSE="doc static-libs"
+
+DEPEND="doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ )"
+RDEPEND=""
+
+S="${WORKDIR}/${P}-beta"
+
+src_prepare() {
+ sed -i -e 's/doc_DATA/html_DATA/' Makefile.am || die
+
+ autotools-multilib_src_prepare
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --htmldir "/usr/share/doc/${PF}/html"
+ )
+ if multilib_is_native_abi; then
+ myeconfargs+=(
+ $(use_enable doc)
+ )
+ else
+ myeconfargs+=(
+ --disable-doc
+ --disable-nanocat
+ --disable-symlinks
+ )
+ fi
+ autotools-utils_src_configure
+}