summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-06-10 00:57:31 +0000
committerTim Harder <radhermit@gentoo.org>2011-06-10 00:57:31 +0000
commitfa0c175437c24780f07e807c282158341fcda968 (patch)
tree6e801ad699e91bd5b53cc3422563a09d998fcc0a /dev-libs/libtommath
parentFixed URL (diff)
downloadgentoo-2-fa0c175437c24780f07e807c282158341fcda968.tar.gz
gentoo-2-fa0c175437c24780f07e807c282158341fcda968.tar.bz2
gentoo-2-fa0c175437c24780f07e807c282158341fcda968.zip
Version bump. Update LICENSE and add doc, examples, and static-libs USE flags.
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libtommath')
-rw-r--r--dev-libs/libtommath/ChangeLog10
-rw-r--r--dev-libs/libtommath/files/libtommath-0.42.0-makefile.patch44
-rw-r--r--dev-libs/libtommath/libtommath-0.36-r1.ebuild6
-rw-r--r--dev-libs/libtommath/libtommath-0.41.ebuild4
-rw-r--r--dev-libs/libtommath/libtommath-0.42.0.ebuild44
5 files changed, 102 insertions, 6 deletions
diff --git a/dev-libs/libtommath/ChangeLog b/dev-libs/libtommath/ChangeLog
index 220871c42c81..4cf82acca693 100644
--- a/dev-libs/libtommath/ChangeLog
+++ b/dev-libs/libtommath/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/libtommath
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/ChangeLog,v 1.33 2011/03/07 21:07:49 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/ChangeLog,v 1.34 2011/06/10 00:57:30 radhermit Exp $
+
+*libtommath-0.42.0 (10 Jun 2011)
+
+ 10 Jun 2011; Tim Harder <radhermit@gentoo.org> libtommath-0.36-r1.ebuild,
+ libtommath-0.41.ebuild, +libtommath-0.42.0.ebuild,
+ +files/libtommath-0.42.0-makefile.patch:
+ Version bump. Update LICENSE and add doc, examples, and static-libs USE
+ flags.
07 Mar 2011; Jeroen Roovers <jer@gentoo.org> libtommath-0.41.ebuild:
Stable for HPPA (bug #355133).
diff --git a/dev-libs/libtommath/files/libtommath-0.42.0-makefile.patch b/dev-libs/libtommath/files/libtommath-0.42.0-makefile.patch
new file mode 100644
index 000000000000..03dd5a25fda5
--- /dev/null
+++ b/dev-libs/libtommath/files/libtommath-0.42.0-makefile.patch
@@ -0,0 +1,44 @@
+--- libtommath-0.42.0/makefile.shared.orig
++++ libtommath-0.42.0/makefile.shared
+@@ -3,7 +3,7 @@
+ #Tom St Denis
+ VERSION=0:41
+
+-CC = libtool --mode=compile --tag=CC gcc
++LTCOMPILE = libtool --mode=compile --tag=CC $(CC)
+
+ CFLAGS += -I./ -Wall -W -Wshadow -Wsign-compare
+
+@@ -82,21 +82,24 @@
+
+ objs: $(OBJECTS)
+
++.c.o:
++ $(LTCOMPILE) $(CFLAGS) $(LDFLAGS) -o $@ -c $<
++
+ $(LIBNAME): $(OBJECTS)
+- libtool --mode=link gcc *.lo -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION)
++ libtool --mode=link --tag=CC $(CC) $(LDFLAGS) *.lo -o $(LIBNAME) -rpath $(LIBPATH) -version-info $(VERSION)
+
+ install: $(LIBNAME)
+- install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(LIBPATH)
++ install -d $(DESTDIR)$(LIBPATH)
+ libtool --mode=install install -c $(LIBNAME) $(DESTDIR)$(LIBPATH)/$(LIBNAME)
+- install -d -g $(GROUP) -o $(USER) $(DESTDIR)$(INCPATH)
+- install -g $(GROUP) -o $(USER) $(HEADERS) $(DESTDIR)$(INCPATH)
++ install -d $(DESTDIR)$(INCPATH)
++ install -m 644 $(HEADERS) $(DESTDIR)$(INCPATH)
+
+ test: $(LIBNAME) demo/demo.o
+- gcc $(CFLAGS) -c demo/demo.c -o demo/demo.o
+- libtool --mode=link gcc -o test demo/demo.o $(LIBNAME_S)
++ $(CC) $(CFLAGS) -c demo/demo.c -o demo/demo.o
++ libtool --mode=link $(CC) $(LDFLAGS) -o test demo/demo.o $(LIBNAME_S)
+
+ mtest: test
+- cd mtest ; gcc $(CFLAGS) mtest.c -o mtest
++ cd mtest ; $(CC) $(CFLAGS) $(LDFLAGS) mtest.c -o mtest
+
+ timing: $(LIBNAME)
+- gcc $(CFLAGS) -DTIMER demo/timing.c $(LIBNAME_S) -o ltmtest
++ libtool --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -DTIMER demo/timing.c $(LIBNAME_S) -o ltmtest
diff --git a/dev-libs/libtommath/libtommath-0.36-r1.ebuild b/dev-libs/libtommath/libtommath-0.36-r1.ebuild
index a12a6505cfb6..5665d4553902 100644
--- a/dev-libs/libtommath/libtommath-0.36-r1.ebuild
+++ b/dev-libs/libtommath/libtommath-0.36-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/libtommath-0.36-r1.ebuild,v 1.14 2009/07/30 17:24:01 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/libtommath-0.36-r1.ebuild,v 1.15 2011/06/10 00:57:30 radhermit Exp $
inherit eutils multilib
@@ -8,7 +8,7 @@ DESCRIPTION="highly optimized and portable routines for integer based number the
HOMEPAGE="http://www.libtom.org/"
SRC_URI="http://www.libtom.org/files/ltm-${PV}.tar.bz2"
-LICENSE="public-domain"
+LICENSE="WTFPL-2"
SLOT="0"
KEYWORDS="amd64 arm ppc ppc64 x86 ~x86-fbsd"
IUSE=""
diff --git a/dev-libs/libtommath/libtommath-0.41.ebuild b/dev-libs/libtommath/libtommath-0.41.ebuild
index 86356437aa51..4133a2a96b5c 100644
--- a/dev-libs/libtommath/libtommath-0.41.ebuild
+++ b/dev-libs/libtommath/libtommath-0.41.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/libtommath-0.41.ebuild,v 1.7 2011/03/07 21:07:49 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/libtommath-0.41.ebuild,v 1.8 2011/06/10 00:57:30 radhermit Exp $
EAPI=3
@@ -10,7 +10,7 @@ DESCRIPTION="highly optimized and portable routines for integer based number the
HOMEPAGE="http://www.libtom.org/"
SRC_URI="http://www.libtom.org/files/ltm-${PV}.tar.bz2"
-LICENSE="public-domain"
+LICENSE="WTFPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
IUSE=""
diff --git a/dev-libs/libtommath/libtommath-0.42.0.ebuild b/dev-libs/libtommath/libtommath-0.42.0.ebuild
new file mode 100644
index 000000000000..1c95d4e2023a
--- /dev/null
+++ b/dev-libs/libtommath/libtommath-0.42.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/libtommath-0.42.0.ebuild,v 1.1 2011/06/10 00:57:31 radhermit Exp $
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="highly optimized and portable routines for integer based number theoretic applications"
+HOMEPAGE="http://www.libtom.org/"
+SRC_URI="http://www.libtom.org/files/ltm-${PV}.tar.bz2"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc examples static-libs"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+
+ [[ ${CHOST} == *-darwin* ]] && \
+ sed -i -e 's/libtool/glibtool/g' makefile.shared
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) -f makefile.shared IGNORE_SPEED=1 LIBPATH="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_install() {
+ emake -f makefile.shared install DESTDIR="${ED}" LIBPATH="${EPREFIX}/usr/$(get_libdir)" INCPATH="${EPREFIX}/usr/include"
+ dodoc changes.txt
+
+ use doc && dodoc *.pdf
+
+ if use examples ; then
+ docinto demo
+ dodoc demo/*.c
+ fi
+
+ use static-libs || find "${ED}" \( -name '*.a' -or -name '*.la' \) -delete
+}