summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-01-13 02:45:19 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-01-13 02:45:19 +0000
commit4bf9a86d558902f33a9ad995226d6c2b180e490d (patch)
tree045f79b0a3238ef7b4b16d743d97a024d618d6e3 /dev-libs/libmacaroons
parentInitial import, ebuild by me. Dependency of dev-db/hyperdex (diff)
downloadgentoo-2-4bf9a86d558902f33a9ad995226d6c2b180e490d.tar.gz
gentoo-2-4bf9a86d558902f33a9ad995226d6c2b180e490d.tar.bz2
gentoo-2-4bf9a86d558902f33a9ad995226d6c2b180e490d.zip
Fix parallel test failure
(Portage version: 2.2.15/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/libmacaroons')
-rw-r--r--dev-libs/libmacaroons/ChangeLog7
-rw-r--r--dev-libs/libmacaroons/libmacaroons-0.2.0.ebuild8
2 files changed, 11 insertions, 4 deletions
diff --git a/dev-libs/libmacaroons/ChangeLog b/dev-libs/libmacaroons/ChangeLog
index 203694cc33e2..0f18e0d535cf 100644
--- a/dev-libs/libmacaroons/ChangeLog
+++ b/dev-libs/libmacaroons/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/libmacaroons
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmacaroons/ChangeLog,v 1.2 2014/11/23 13:30:44 patrick Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmacaroons/ChangeLog,v 1.3 2015/01/13 02:45:19 patrick Exp $
+
+ 13 Jan 2015; Patrick Lauer <patrick@gentoo.org> libmacaroons-0.2.0.ebuild:
+ Fix parallel test failure
23 Nov 2014; Patrick Lauer <patrick@gentoo.org> libmacaroons-0.2.0.ebuild:
Add python bindings and test phase
diff --git a/dev-libs/libmacaroons/libmacaroons-0.2.0.ebuild b/dev-libs/libmacaroons/libmacaroons-0.2.0.ebuild
index 0e0783dea2e7..3656cc911353 100644
--- a/dev-libs/libmacaroons/libmacaroons-0.2.0.ebuild
+++ b/dev-libs/libmacaroons/libmacaroons-0.2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmacaroons/libmacaroons-0.2.0.ebuild,v 1.2 2014/11/23 13:30:44 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmacaroons/libmacaroons-0.2.0.ebuild,v 1.3 2015/01/13 02:45:19 patrick Exp $
EAPI=5
@@ -28,3 +28,7 @@ REQUIRED_USE="test? ( python )"
src_configure() {
econf $(use_enable python python-bindings)
}
+
+src_test() {
+ emake -j1 test || die
+}