summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-01-15 05:47:45 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-01-15 05:47:45 +0000
commit3275fa2889e0c15687e1de450a50b1505fece82e (patch)
tree363d6201fe4cad176f59792cfa1df2722fb7cad8 /dev-libs/libmacaroons
parentVersion bump. (diff)
downloadgentoo-2-3275fa2889e0c15687e1de450a50b1505fece82e.tar.gz
gentoo-2-3275fa2889e0c15687e1de450a50b1505fece82e.tar.bz2
gentoo-2-3275fa2889e0c15687e1de450a50b1505fece82e.zip
Disable broken tests, fix python handling #536552
(Portage version: 2.2.15/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/libmacaroons')
-rw-r--r--dev-libs/libmacaroons/ChangeLog8
-rw-r--r--dev-libs/libmacaroons/libmacaroons-0.2.0-r1.ebuild (renamed from dev-libs/libmacaroons/libmacaroons-0.2.0.ebuild)15
2 files changed, 18 insertions, 5 deletions
diff --git a/dev-libs/libmacaroons/ChangeLog b/dev-libs/libmacaroons/ChangeLog
index 0f18e0d535cf..e71077c52643 100644
--- a/dev-libs/libmacaroons/ChangeLog
+++ b/dev-libs/libmacaroons/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libmacaroons
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmacaroons/ChangeLog,v 1.3 2015/01/13 02:45:19 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmacaroons/ChangeLog,v 1.4 2015/01/15 05:47:45 patrick Exp $
+
+*libmacaroons-0.2.0-r1 (15 Jan 2015)
+
+ 15 Jan 2015; Patrick Lauer <patrick@gentoo.org> +libmacaroons-0.2.0-r1.ebuild,
+ -libmacaroons-0.2.0.ebuild:
+ Disable broken tests, fix python handling #536552
13 Jan 2015; Patrick Lauer <patrick@gentoo.org> libmacaroons-0.2.0.ebuild:
Fix parallel test failure
diff --git a/dev-libs/libmacaroons/libmacaroons-0.2.0.ebuild b/dev-libs/libmacaroons/libmacaroons-0.2.0-r1.ebuild
index 3656cc911353..3bab7485d460 100644
--- a/dev-libs/libmacaroons/libmacaroons-0.2.0.ebuild
+++ b/dev-libs/libmacaroons/libmacaroons-0.2.0-r1.ebuild
@@ -1,12 +1,15 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmacaroons/libmacaroons-0.2.0.ebuild,v 1.3 2015/01/13 02:45:19 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmacaroons/libmacaroons-0.2.0-r1.ebuild,v 1.1 2015/01/15 05:47:45 patrick Exp $
EAPI=5
-PYTHON_COMPAT="python2_7"
+PYTHON_COMPAT=( python2_7 )
-inherit eutils python-r1
+inherit eutils python-single-r1
+
+# Tests can't function after 2014-12-31 ...
+RESTRICT="test"
DESCRIPTION="Hyperdex macaroons support library"
@@ -25,10 +28,14 @@ DEPEND="${RDEPEND}
REQUIRED_USE="test? ( python )"
+src_prepare() {
+ use python && python-single-r1_pkg_setup
+}
+
src_configure() {
econf $(use_enable python python-bindings)
}
src_test() {
- emake -j1 test || die
+ emake -j1 check || die
}