summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-11-02 11:09:34 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-11-02 11:09:34 +0000
commit35c1915d9f42a0dd2daafa31ca050c93d0de8b0f (patch)
tree45b1bf8641a2fc680eb8fcf5d868ddf8d90b7c66 /dev-libs/libhtmlparse
parentFix description and other minor QA issues (diff)
downloadgentoo-2-35c1915d9f42a0dd2daafa31ca050c93d0de8b0f.tar.gz
gentoo-2-35c1915d9f42a0dd2daafa31ca050c93d0de8b0f.tar.bz2
gentoo-2-35c1915d9f42a0dd2daafa31ca050c93d0de8b0f.zip
Revision bump: EAPI 4, add missing 'die' statements, add 'static-libs' USE flag, keyword ~amd64 wrt bug #440734. Thanks to Vicente Olivert Riera
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/libhtmlparse')
-rw-r--r--dev-libs/libhtmlparse/ChangeLog9
-rw-r--r--dev-libs/libhtmlparse/libhtmlparse-0.1.13-r1.ebuild32
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-libs/libhtmlparse/ChangeLog b/dev-libs/libhtmlparse/ChangeLog
index 970d9d1cb6f9..f20ea24ccc55 100644
--- a/dev-libs/libhtmlparse/ChangeLog
+++ b/dev-libs/libhtmlparse/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libhtmlparse
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhtmlparse/ChangeLog,v 1.11 2012/11/02 10:58:06 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhtmlparse/ChangeLog,v 1.12 2012/11/02 11:09:34 pinkbyte Exp $
+
+*libhtmlparse-0.1.13-r1 (02 Nov 2012)
+
+ 02 Nov 2012; Sergey Popov <pinkbyte@gentoo.org>
+ +libhtmlparse-0.1.13-r1.ebuild:
+ Revision bump: EAPI 4, add missing 'die' statements, add 'static-libs' USE
+ flag, keyword ~amd64 wrt bug #440734. Thanks to Vicente Olivert Riera
02 Nov 2012; Sergey Popov <pinkbyte@gentoo.org> libhtmlparse-0.1.13.ebuild:
Fix description and other minor QA issues
diff --git a/dev-libs/libhtmlparse/libhtmlparse-0.1.13-r1.ebuild b/dev-libs/libhtmlparse/libhtmlparse-0.1.13-r1.ebuild
new file mode 100644
index 000000000000..32101d21b85e
--- /dev/null
+++ b/dev-libs/libhtmlparse/libhtmlparse-0.1.13-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhtmlparse/libhtmlparse-0.1.13-r1.ebuild,v 1.1 2012/11/02 11:09:34 pinkbyte Exp $
+
+EAPI=4
+
+DESCRIPTION="HTML parsing library. It takes HTML tags, text, and calls callbacks for each type of token"
+HOMEPAGE="http://msalem.translator.cx/libhtmlparse.html"
+SRC_URI="http://msalem.translator.cx/dist/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS BUGS INSTALL ChangeLog NEWS README TODO )
+
+src_unpack() {
+ # for some reason, we get a "this does not look like a tar archive" error
+ # but the following works... go figure.
+ gunzip -c "${DISTDIR}"/${P}.tar.gz > ${P}.tar || die 'gunzip failed'
+ tar xf ${P}.tar || die "failed to unpack ${P}.tar"
+ rm ${P}.tar || die "rm failed"
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}