summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-10 19:50:30 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-01-10 19:50:30 +0000
commita2ae9dc12bd6905731d4eacc853de6ec15a638f0 (patch)
treeb979d01e81731deb7ca6671d44010f0c5eb1eae7 /dev-libs/libhome
parentstable ppc, bug 345747 (diff)
downloadgentoo-2-a2ae9dc12bd6905731d4eacc853de6ec15a638f0.tar.gz
gentoo-2-a2ae9dc12bd6905731d4eacc853de6ec15a638f0.tar.bz2
gentoo-2-a2ae9dc12bd6905731d4eacc853de6ec15a638f0.zip
Allow libhome to build against berkdb 5.0 as well as any 4.x version, by letting db-use provide the library name instead. Closes bug #340669.
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libhome')
-rw-r--r--dev-libs/libhome/ChangeLog9
-rw-r--r--dev-libs/libhome/files/libhome-0.10.2-Makefile.patch52
-rw-r--r--dev-libs/libhome/libhome-0.10.2.ebuild14
3 files changed, 68 insertions, 7 deletions
diff --git a/dev-libs/libhome/ChangeLog b/dev-libs/libhome/ChangeLog
index 97f5b8c2d9d2..c2075f3af408 100644
--- a/dev-libs/libhome/ChangeLog
+++ b/dev-libs/libhome/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libhome
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhome/ChangeLog,v 1.11 2010/06/17 21:32:16 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhome/ChangeLog,v 1.12 2011/01/10 19:50:30 flameeyes Exp $
+
+ 10 Jan 2011; Diego E. Pettenò <flameeyes@gentoo.org> libhome-0.10.2.ebuild,
+ +files/libhome-0.10.2-Makefile.patch:
+ Allow libhome to build against berkdb 5.0 as well as any 4.x version, by
+ letting db-use provide the library name instead. Closes bug #340669.
17 Jun 2010; Patrick Lauer <patrick@gentoo.org> libhome-0.10.1.ebuild,
libhome-0.10.2.ebuild:
diff --git a/dev-libs/libhome/files/libhome-0.10.2-Makefile.patch b/dev-libs/libhome/files/libhome-0.10.2-Makefile.patch
new file mode 100644
index 000000000000..c60917ce652e
--- /dev/null
+++ b/dev-libs/libhome/files/libhome-0.10.2-Makefile.patch
@@ -0,0 +1,52 @@
+Index: libhome-0.10.1/Makefile.in
+===================================================================
+--- libhome-0.10.1.orig/Makefile.in
++++ libhome-0.10.1/Makefile.in
+@@ -114,27 +114,32 @@ home_expire_cache: home_expire_cache.o l
+ install:: install-man install-lib
+
+ install-man:: home.conf.5
+- ${INSTALL_DATA} home.conf.5 ${mandir}/man5/
+-@DO_PROXY@ ${INSTALL_DATA} home_proxy.8 ${mandir}/man8/
++ ${INSTALL} -d $(DESTDIR)${mandir}/man5
++@DO_PROXY@ ${INSTALL} -d $(DESTDIR)${mandir}/man8
++ ${INSTALL_DATA} home.conf.5 $(DESTDIR)${mandir}/man5/
++@DO_PROXY@ ${INSTALL_DATA} home_proxy.8 $(DESTDIR)${mandir}/man8/
+
+ install-lib:: all
+- ${LIBTOOL} --mode=install ${INSTALL_DATA} libhome.la ${libdir}/
++ ${INSTALL} -d $(DESTDIR)${libdir}
++ ${INSTALL} -d $(DESTDIR)${bindir}
++@DO_PROXY@ ${INSTALL} -d $(DESTDIR)${sbindir}
++ ${INSTALL} -d $(DESTDIR)${includedir}/home
++ ${LIBTOOL} --mode=install ${INSTALL_DATA} libhome.la $(DESTDIR)${libdir}/
+ test "@PRELOAD_LIB@" = "" || \
+- ${LIBTOOL} --mode=install ${INSTALL_DATA} @PRELOAD_LIB@ ${libdir}/
+- ${LIBTOOL} --mode=install ${INSTALL_PROGRAM} home_finger ${bindir}/
+- ${LIBTOOL} --mode=install ${INSTALL_PROGRAM} home_su ${bindir}/
+- -mkdir -p ${includedir}/home
+- ${INSTALL_DATA} hpwd.h ${includedir}/home/pwd.h
+- ${INSTALL_DATA} hpwd.h ${includedir}/home/
+- ${INSTALL_DATA} hparam.h ${includedir}/home/
+- ${INSTALL_DATA} home_version.h ${includedir}/home/
++ ${LIBTOOL} --mode=install ${INSTALL_DATA} @PRELOAD_LIB@ $(DESTDIR)${libdir}/
++ ${LIBTOOL} --mode=install ${INSTALL_PROGRAM} home_finger $(DESTDIR)${bindir}/
++ ${LIBTOOL} --mode=install ${INSTALL_PROGRAM} home_su $(DESTDIR)${bindir}/
++ ${INSTALL_DATA} -D hpwd.h $(DESTDIR)${includedir}/home/pwd.h
++ ${INSTALL_DATA} -D hpwd.h $(DESTDIR)${includedir}/home/
++ ${INSTALL_DATA} -D hparam.h $(DESTDIR)${includedir}/home/
++ ${INSTALL_DATA} -D home_version.h $(DESTDIR)${includedir}/home/
+ chmod +x libhome.sh
+- ${INSTALL_SCRIPT} libhome.sh ${bindir}/
+-@DO_PROXY@ ${LIBTOOL} --mode=install ${INSTALL_PROGRAM} home_proxy ${sbindir}/
+-@DO_NSS@ ${LIBTOOL} --mode=install ${INSTALL_DATA} ${NSS_LIB} ${libdir}/
++ ${INSTALL_SCRIPT} -D libhome.sh $(DESTDIR)${bindir}/
++@DO_PROXY@ ${LIBTOOL} --mode=install ${INSTALL_PROGRAM} home_proxy $(DESTDIR)${sbindir}/
++@DO_NSS@ ${LIBTOOL} --mode=install ${INSTALL_DATA} ${NSS_LIB} $(DESTDIR)${libdir}/
+
+ install-nss:: nss
+-@DO_NSS@ ${LIBTOOL} --mode=install ${INSTALL_DATA} ${NSS_LIB} ${libdir}/
++@DO_NSS@ ${LIBTOOL} --mode=install ${INSTALL_DATA} ${NSS_LIB} $(DESTDIR)${libdir}/
+
+ compat:
+ -mkdir compat
diff --git a/dev-libs/libhome/libhome-0.10.2.ebuild b/dev-libs/libhome/libhome-0.10.2.ebuild
index b9607b1e5076..5aa84290cd3f 100644
--- a/dev-libs/libhome/libhome-0.10.2.ebuild
+++ b/dev-libs/libhome/libhome-0.10.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhome/libhome-0.10.2.ebuild,v 1.2 2010/06/17 21:32:16 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libhome/libhome-0.10.2.ebuild,v 1.3 2011/01/10 19:50:30 flameeyes Exp $
inherit autotools db-use eutils
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="berkdb ldap mysql pam postgres"
-DEPEND="berkdb? ( =sys-libs/db-4* )
+DEPEND="berkdb? ( >=sys-libs/db-4 )
ldap? ( net-nds/openldap )
mysql? ( virtual/mysql )
pam? ( virtual/pam )
@@ -24,12 +24,16 @@ src_unpack() {
unpack ${A}
cd "${S}"
rm -f aclocal.m4
- epatch "${FILESDIR}"/${PN}-0.10.1-Makefile.patch
+
+ epatch "${FILESDIR}"/${PN}-0.10.2-Makefile.patch
epatch "${FILESDIR}"/${PN}-0.10.2-ldap_deprecated.patch
# bug 225579
sed -i -e 's:\<VERSION\>:__PKG_VERSION:' configure.in
+ sed -i -e '/AC_SEARCH_LIBS.*db4/s: db-4.* db4:'$(db_libname)':' \
+ configure.in
+
eautoreconf
}
@@ -45,5 +49,5 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "make install failed"
}