summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-11-13 20:19:56 +0000
committerMike Frysinger <vapier@gentoo.org>2003-11-13 20:19:56 +0000
commit7798c3c3f5eaac9bb2953f913ffc96f898eb9621 (patch)
treeb5a96a0335f9ae915339fd6daf3bd28145ffca56 /dev-libs/libf2c
parentadding metadata (diff)
downloadgentoo-2-7798c3c3f5eaac9bb2953f913ffc96f898eb9621.tar.gz
gentoo-2-7798c3c3f5eaac9bb2953f913ffc96f898eb9621.tar.bz2
gentoo-2-7798c3c3f5eaac9bb2953f913ffc96f898eb9621.zip
cleanup to help fix distcc bugs
Diffstat (limited to 'dev-libs/libf2c')
-rw-r--r--dev-libs/libf2c/libf2c-20021004.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/dev-libs/libf2c/libf2c-20021004.ebuild b/dev-libs/libf2c/libf2c-20021004.ebuild
index 5d601f4eeae5..6978c54495be 100644
--- a/dev-libs/libf2c/libf2c-20021004.ebuild
+++ b/dev-libs/libf2c/libf2c-20021004.ebuild
@@ -1,25 +1,29 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libf2c/libf2c-20021004.ebuild,v 1.5 2003/08/06 08:07:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libf2c/libf2c-20021004.ebuild,v 1.6 2003/11/13 20:19:56 vapier Exp $
+
+inherit gcc
-IUSE=""
-S="${WORKDIR}/${PN}"
DESCRIPTION="Library that converts FORTRAN to C source."
-SRC_URI="ftp://ftp.netlib.org/f2c/${PN}.zip"
HOMEPAGE="ftp://ftp.netlib.org/f2c/index.html"
+SRC_URI="ftp://ftp.netlib.org/f2c/${PN}.zip"
+
LICENSE="libf2c"
-KEYWORDS="x86"
SLOT="0"
+KEYWORDS="x86"
+
DEPEND="virtual/glibc"
+S=${WORKDIR}/${PN}
+
src_compile() {
- sed -e "s:CFLAGS = -O::" makefile.u > makefile || \
- die "sed makefile failed"
- emake || die
+ emake -f makefile.u \
+ CFLAGS="${CFLAGS}" \
+ CC="$(gcc-getCC)" \
+ || die
}
src_install () {
- into /usr
dolib.a libf2c.a
insinto /usr/include
doins f2c.h