summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-04-23 14:05:00 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-04-23 14:05:00 +0000
commitd142e566867784c3728120861f307831921aad61 (patch)
treee7583c401b1486b6e4f624b5e60a461324c2529c /dev-libs/libee/libee-0.4.1.ebuild
parentVersion bump: 7.3.502 is released (diff)
downloadgentoo-2-d142e566867784c3728120861f307831921aad61.tar.gz
gentoo-2-d142e566867784c3728120861f307831921aad61.tar.bz2
gentoo-2-d142e566867784c3728120861f307831921aad61.zip
Add 0.4.1 with fix for #409137 and 0.3.2-r2 with backported patch from 0.4.1 for the same bug. Thanks to slepnoga
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libee/libee-0.4.1.ebuild')
-rw-r--r--dev-libs/libee/libee-0.4.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/libee/libee-0.4.1.ebuild b/dev-libs/libee/libee-0.4.1.ebuild
new file mode 100644
index 000000000000..b44bf6600df7
--- /dev/null
+++ b/dev-libs/libee/libee-0.4.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libee/libee-0.4.1.ebuild,v 1.1 2012/04/23 14:05:00 maksbotan Exp $
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="An Event Expression Library inspired by CEE"
+HOMEPAGE="http://www.libee.org"
+SRC_URI="http://www.libee.org/files/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="debug static-libs"
+
+DEPEND="dev-libs/libxml2
+ dev-libs/libestr"
+RDEPEND="${DEPEND}"
+
+DOCS=(INSTALL ChangeLog)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ --enable-testbench
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile -j1
+}