summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-08-29 01:25:20 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-08-29 01:25:20 +0000
commit3d7d379f35ece071a5844047c76ebd0278e2a745 (patch)
tree7692c25ed21d2a241bed0596248d787390a1f939 /dev-libs/leveldb
parentVersion bump to 1.4, cleaned ebuild up a bit and removed restriction on tests... (diff)
downloadgentoo-2-3d7d379f35ece071a5844047c76ebd0278e2a745.tar.gz
gentoo-2-3d7d379f35ece071a5844047c76ebd0278e2a745.tar.bz2
gentoo-2-3d7d379f35ece071a5844047c76ebd0278e2a745.zip
Bump
(Portage version: 2.2.1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/leveldb')
-rw-r--r--dev-libs/leveldb/ChangeLog7
-rw-r--r--dev-libs/leveldb/leveldb-1.13.0.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-libs/leveldb/ChangeLog b/dev-libs/leveldb/ChangeLog
index 53c3fe83a544..b5e4bdae272c 100644
--- a/dev-libs/leveldb/ChangeLog
+++ b/dev-libs/leveldb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/leveldb
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/leveldb/ChangeLog,v 1.14 2013/06/20 03:30:25 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/leveldb/ChangeLog,v 1.15 2013/08/29 01:25:20 patrick Exp $
+
+*leveldb-1.13.0 (29 Aug 2013)
+
+ 29 Aug 2013; Patrick Lauer <patrick@gentoo.org> +leveldb-1.13.0.ebuild:
+ Bump
*leveldb-1.12.0 (20 Jun 2013)
diff --git a/dev-libs/leveldb/leveldb-1.13.0.ebuild b/dev-libs/leveldb/leveldb-1.13.0.ebuild
new file mode 100644
index 000000000000..549572cf8367
--- /dev/null
+++ b/dev-libs/leveldb/leveldb-1.13.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/leveldb/leveldb-1.13.0.ebuild,v 1.1 2013/08/29 01:25:20 patrick Exp $
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="a fast key-value storage library written at Google"
+HOMEPAGE="http://code.google.com/p/leveldb/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="+snappy static-libs +tcmalloc"
+
+DEPEND="tcmalloc? ( dev-util/google-perftools )
+ snappy? (
+ app-arch/snappy
+ static-libs? ( app-arch/snappy[static-libs] )
+ )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # These vars all get picked up by build_detect_platform
+ # which the Makefile runs for us automatically.
+ tc-export AR CC CXX
+ export OPT="-DNDEBUG ${CPPFLAGS}"
+ # Probably needs more filling out
+ export TARGET_OS
+ case ${CHOST} in
+ *) TARGET_OS="Linux";;
+ esac
+ export USE_SNAPPY=$(usex snappy)
+ export USE_TCMALLOC=no
+}
+
+src_compile() {
+ emake $(usex static-libs '' 'LIBRARY=') all libmemenv.a
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ insinto /usr/include
+ doins -r include/* helpers/memenv/memenv.h
+ dolib.so libleveldb*$(get_libname)*
+ use static-libs && dolib.a libleveldb.a
+ dolib.a libmemenv.a
+}