summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-02-06 14:45:53 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-02-06 14:45:53 +0000
commit20db53f04e2f0c18cae86368255b9872414ee01b (patch)
tree0e887b946dba9807b30bde07fa3998fb485c2370 /dev-libs/icu
parentrevbumped due to changes on disk (diff)
downloadgentoo-2-20db53f04e2f0c18cae86368255b9872414ee01b.tar.gz
gentoo-2-20db53f04e2f0c18cae86368255b9872414ee01b.tar.bz2
gentoo-2-20db53f04e2f0c18cae86368255b9872414ee01b.zip
Use patches from fedora to fix few more issues.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'dev-libs/icu')
-rw-r--r--dev-libs/icu/ChangeLog7
-rw-r--r--dev-libs/icu/files/icu-50.1-no-c++11.patch46
-rw-r--r--dev-libs/icu/files/icu.7601.Indic-ccmp.patch43
-rw-r--r--dev-libs/icu/files/icu.8198.revert.icu5431.patch129
-rw-r--r--dev-libs/icu/icu-50.1-r1.ebuild119
-rw-r--r--dev-libs/icu/icu-50.1.2.ebuild6
6 files changed, 182 insertions, 168 deletions
diff --git a/dev-libs/icu/ChangeLog b/dev-libs/icu/ChangeLog
index 58d8a3334eec..88cfd884bb7a 100644
--- a/dev-libs/icu/ChangeLog
+++ b/dev-libs/icu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/icu
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.226 2013/02/06 14:21:39 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.227 2013/02/06 14:45:53 scarabeus Exp $
+
+ 06 Feb 2013; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/icu.7601.Indic-ccmp.patch, +files/icu.8198.revert.icu5431.patch,
+ -files/icu-50.1-no-c++11.patch, -icu-50.1-r1.ebuild, icu-50.1.2.ebuild:
+ Use patches from fedora to fix few more issues.
*icu-50.1.2 (06 Feb 2013)
diff --git a/dev-libs/icu/files/icu-50.1-no-c++11.patch b/dev-libs/icu/files/icu-50.1-no-c++11.patch
deleted file mode 100644
index 87256bd9b4b8..000000000000
--- a/dev-libs/icu/files/icu-50.1-no-c++11.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff -Naur icu.orig/source/configure.in icu/source/configure.in
---- icu.orig/source/configure.in 2012-11-03 09:16:37.937159045 +0100
-+++ icu/source/configure.in 2012-11-03 09:20:30.019550761 +0100
-@@ -955,42 +955,6 @@
- ;;
- esac
-
--# GCC >= 4.4 supports UTF16 string literals. The CFLAGS and CXXFLAGS may change in the future.
--if test "$CHECK_UTF16_STRING_RESULT" = "unknown"; then
-- if test "$GCC" = yes; then
-- OLD_CFLAGS="${CFLAGS}"
-- CFLAGS="${CFLAGS} -std=gnu99"
-- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
--static const char16_t test[] = u"This is a UTF16 literal string.";
-- ]], [[]])],[CC_UTF16_STRING=1],[CC_UTF16_STRING=0])
-- if test "$CC_UTF16_STRING" = 1; then
-- CHECK_UTF16_STRING_RESULT="C only";
-- else
-- CFLAGS="${OLD_CFLAGS}"
-- fi
-- fi
-- if test "$GXX" = yes; then
-- OLD_CXXFLAGS="${CXXFLAGS}"
-- # -Wno-return-type-c-linkage is desired so that stable ICU API is not warned about.
-- CXXFLAGS="${CXXFLAGS} -std=c++11"
-- AC_LANG_PUSH([C++])
-- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
--static const char16_t test[] = u"This is a UTF16 literal string.";
-- ]], [[]])],[CXX_UTF16_STRING=1],[CXX_UTF16_STRING=0])
-- AC_LANG_POP([C++])
-- if test "$CXX_UTF16_STRING" = 1; then
-- if test "$CC_UTF16_STRING" = 1; then
-- CHECK_UTF16_STRING_RESULT="available";
-- else
-- CHECK_UTF16_STRING_RESULT="C++ only";
-- fi
-- else
-- CXXFLAGS="${OLD_CXXFLAGS}"
-- fi
-- fi
--fi
--AC_MSG_RESULT($CHECK_UTF16_STRING_RESULT)
--
- # Enable/disable extras
- AC_ARG_ENABLE(extras,
- [ --enable-extras build ICU extras [default=yes]],
diff --git a/dev-libs/icu/files/icu.7601.Indic-ccmp.patch b/dev-libs/icu/files/icu.7601.Indic-ccmp.patch
new file mode 100644
index 000000000000..328a2854aa5c
--- /dev/null
+++ b/dev-libs/icu/files/icu.7601.Indic-ccmp.patch
@@ -0,0 +1,43 @@
+--- icu/source/layout/IndicReordering.cpp 2009-07-01 20:51:26.000000000 +0200
++++ icu/source/layout/IndicReordering.cpp 2011-01-08 11:12:49.950566538 +0100
+@@ -13,6 +13,7 @@
+
+ U_NAMESPACE_BEGIN
+
++#define ccmpFeatureTag LE_CCMP_FEATURE_TAG
+ #define loclFeatureTag LE_LOCL_FEATURE_TAG
+ #define initFeatureTag LE_INIT_FEATURE_TAG
+ #define nuktFeatureTag LE_NUKT_FEATURE_TAG
+@@ -35,6 +36,7 @@
+ #define caltFeatureTag LE_CALT_FEATURE_TAG
+ #define kernFeatureTag LE_KERN_FEATURE_TAG
+
++#define ccmpFeatureMask 0x00000001UL
+ #define loclFeatureMask 0x80000000UL
+ #define rphfFeatureMask 0x40000000UL
+ #define blwfFeatureMask 0x20000000UL
+@@ -73,7 +75,7 @@
+
+ #define repositionedGlyphMask 0x00000002UL
+
+-#define basicShapingFormsMask ( loclFeatureMask | nuktFeatureMask | akhnFeatureMask | rkrfFeatureMask | blwfFeatureMask | halfFeatureMask | vatuFeatureMask | cjctFeatureMask )
++#define basicShapingFormsMask ( ccmpFeatureMask | loclFeatureMask | nuktFeatureMask | akhnFeatureMask | rkrfFeatureMask | blwfFeatureMask | halfFeatureMask | vatuFeatureMask | cjctFeatureMask )
+ #define positioningFormsMask ( kernFeatureMask | distFeatureMask | abvmFeatureMask | blwmFeatureMask )
+ #define presentationFormsMask ( presFeatureMask | abvsFeatureMask | blwsFeatureMask | pstsFeatureMask | halnFeatureMask | caltFeatureMask )
+
+@@ -480,6 +482,7 @@
+ #define tagArray0 (rphfFeatureMask | tagArray1)
+
+ static const FeatureMap featureMap[] = {
++ {ccmpFeatureTag, ccmpFeatureMask},
+ {loclFeatureTag, loclFeatureMask},
+ {initFeatureTag, initFeatureMask},
+ {nuktFeatureTag, nuktFeatureMask},
+@@ -502,6 +505,7 @@
+ static const le_int32 featureCount = LE_ARRAY_SIZE(featureMap);
+
+ static const FeatureMap v2FeatureMap[] = {
++ {ccmpFeatureTag, ccmpFeatureMask},
+ {loclFeatureTag, loclFeatureMask},
+ {nuktFeatureTag, nuktFeatureMask},
+ {akhnFeatureTag, akhnFeatureMask},
diff --git a/dev-libs/icu/files/icu.8198.revert.icu5431.patch b/dev-libs/icu/files/icu.8198.revert.icu5431.patch
new file mode 100644
index 000000000000..4c3e78b8ed5d
--- /dev/null
+++ b/dev-libs/icu/files/icu.8198.revert.icu5431.patch
@@ -0,0 +1,129 @@
+Index: icu/trunk/source/layout/IndicReordering.cpp
+===================================================================
+--- icu/trunk/source/layout/IndicReordering.cpp (revision 25772)
++++ icu/trunk/source/layout/IndicReordering.cpp (revision 26090)
+@@ -126,4 +126,8 @@
+ FeatureMask fSMFeatures;
+
++ LEUnicode fPreBaseConsonant;
++ LEUnicode fPreBaseVirama;
++ le_int32 fPBCIndex;
++ FeatureMask fPBCFeatures;
+
+ void saveMatra(LEUnicode matra, le_int32 matraIndex, IndicClassTable::CharClass matraClass)
+@@ -172,5 +176,6 @@
+ fMatraFeatures(0), fMPreOutIndex(-1), fMPreFixups(mpreFixups),
+ fVMabove(0), fVMpost(0), fVMIndex(0), fVMFeatures(0),
+- fSMabove(0), fSMbelow(0), fSMIndex(0), fSMFeatures(0)
++ fSMabove(0), fSMbelow(0), fSMIndex(0), fSMFeatures(0),
++ fPreBaseConsonant(0), fPreBaseVirama(0), fPBCIndex(0), fPBCFeatures(0)
+ {
+ // nothing else to do...
+@@ -191,4 +196,6 @@
+ fVMabove = fVMpost = 0;
+ fSMabove = fSMbelow = 0;
++
++ fPreBaseConsonant = fPreBaseVirama = 0;
+ }
+
+@@ -386,4 +393,12 @@
+ }
+
++ void notePreBaseConsonant(le_uint32 index,LEUnicode PBConsonant, LEUnicode PBVirama, FeatureMask features)
++ {
++ fPBCIndex = index;
++ fPreBaseConsonant = PBConsonant;
++ fPreBaseVirama = PBVirama;
++ fPBCFeatures = features;
++ }
++
+ void noteBaseConsonant()
+ {
+@@ -465,4 +480,20 @@
+ }
+
++ void writePreBaseConsonant()
++ {
++ // The TDIL spec says that consonant + virama + RRA should produce a rakar in Malayalam. However,
++ // it seems that almost none of the fonts for Malayalam are set up to handle this.
++ // So, we're going to force the issue here by using the rakar as defined with RA in most fonts.
++
++ if (fPreBaseConsonant == 0x0d31) { // RRA
++ fPreBaseConsonant = 0x0d30; // RA
++ }
++
++ if (fPreBaseConsonant != 0) {
++ writeChar(fPreBaseConsonant, fPBCIndex, fPBCFeatures);
++ writeChar(fPreBaseVirama,fPBCIndex-1,fPBCFeatures);
++ }
++ }
++
+ le_int32 getOutputIndex()
+ {
+@@ -723,4 +754,5 @@
+ }
+
++
+ IndicClassTable::CharClass charClass = CC_RESERVED;
+ IndicClassTable::CharClass nextClass = CC_RESERVED;
+@@ -730,7 +762,9 @@
+ le_bool seenVattu = FALSE;
+ le_bool seenBelowBaseForm = FALSE;
++ le_bool seenPreBaseForm = FALSE;
+ le_bool hasNukta = FALSE;
+ le_bool hasBelowBaseForm = FALSE;
+ le_bool hasPostBaseForm = FALSE;
++ le_bool hasPreBaseForm = FALSE;
+
+ if (postBase < markStart && classTable->isNukta(chars[postBase])) {
+@@ -746,12 +780,20 @@
+ hasBelowBaseForm = IndicClassTable::hasBelowBaseForm(charClass) && !hasNukta;
+ hasPostBaseForm = IndicClassTable::hasPostBaseForm(charClass) && !hasNukta;
++ hasPreBaseForm = IndicClassTable::hasPreBaseForm(charClass) && !hasNukta;
+
+ if (IndicClassTable::isConsonant(charClass)) {
+ if (postBaseLimit == 0 || seenVattu ||
+ (baseConsonant > baseLimit && !classTable->isVirama(chars[baseConsonant - 1])) ||
+- !(hasBelowBaseForm || hasPostBaseForm)) {
++ !(hasBelowBaseForm || hasPostBaseForm || hasPreBaseForm)) {
+ break;
+ }
+
++ // Note any pre-base consonants
++ if ( baseConsonant == lastConsonant && lastConsonant > 0 &&
++ hasPreBaseForm && classTable->isVirama(chars[baseConsonant - 1])) {
++ output.notePreBaseConsonant(lastConsonant,chars[lastConsonant],chars[lastConsonant-1],tagArray2);
++ seenPreBaseForm = TRUE;
++
++ }
+ // consonants with nuktas are never vattus
+ seenVattu = IndicClassTable::isVattu(charClass) && !hasNukta;
+@@ -786,10 +828,12 @@
+
+ // write any pre-base consonants
++ output.writePreBaseConsonant();
++
+ le_bool supressVattu = TRUE;
+
+ for (i = baseLimit; i < baseConsonant; i += 1) {
+ LEUnicode ch = chars[i];
+- // Don't put 'blwf' on first consonant.
+- FeatureMask features = (i == baseLimit? tagArray2 : tagArray1);
++ // Don't put 'pstf' or 'blwf' on anything before the base consonant.
++ FeatureMask features = tagArray1 & ~( pstfFeatureMask | blwfFeatureMask );
+
+ charClass = classTable->getCharClass(ch);
+@@ -842,5 +886,5 @@
+
+ // write below-base consonants
+- if (baseConsonant != lastConsonant) {
++ if (baseConsonant != lastConsonant && !seenPreBaseForm) {
+ for (i = bcSpan + 1; i < postBase; i += 1) {
+ output.writeChar(chars[i], i, tagArray1);
+@@ -872,5 +916,5 @@
+ // write post-base consonants
+ // FIXME: does this put the right tags on post-base consonants?
+- if (baseConsonant != lastConsonant) {
++ if (baseConsonant != lastConsonant && !seenPreBaseForm) {
+ if (postBase <= lastConsonant) {
+ for (i = postBase; i <= lastConsonant; i += 1) {
diff --git a/dev-libs/icu/icu-50.1-r1.ebuild b/dev-libs/icu/icu-50.1-r1.ebuild
deleted file mode 100644
index 53f85618ca6f..000000000000
--- a/dev-libs/icu/icu-50.1-r1.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-50.1-r1.ebuild,v 1.5 2013/02/02 10:53:04 aballier Exp $
-
-EAPI=5
-
-inherit eutils toolchain-funcs base autotools
-
-DESCRIPTION="International Components for Unicode"
-HOMEPAGE="http://www.icu-project.org/"
-SRC_URI="http://download.icu-project.org/files/icu4c/${PV/_/}/icu4c-${PV//./_}-src.tgz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 -amd64-fbsd -x86-fbsd"
-IUSE="debug doc examples static-libs"
-
-DEPEND="
- doc? (
- app-doc/doxygen[dot]
- )
-"
-
-S="${WORKDIR}/${PN}/source"
-
-PATCHES=(
- "${FILESDIR}/${PN}-4.8.1-fix_binformat_fonts.patch"
- "${FILESDIR}/${PN}-4.8.1.1-fix_ltr.patch"
- "${FILESDIR}/${PN}-50.1-no-c++11.patch"
-)
-
-src_prepare() {
- local variable
-
- base_src_prepare
-
- # Do not hardcode flags in icu-config and icu-*.pc files.
- # https://ssl.icu-project.org/trac/ticket/6102
- for variable in CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
- sed \
- -e "/^${variable} =.*/s: *@${variable}@\( *$\)\?::" \
- -i config/icu.pc.in \
- -i config/Makefile.inc.in \
- || die
- done
-
- # Disable renaming as it is stupind thing to do
- sed -i \
- -e "s/#define U_DISABLE_RENAMING 0/#define U_DISABLE_RENAMING 1/" \
- common/unicode/uconfig.h || die
-
- # Fix linking of icudata
- sed -i \
- -e "s:LDFLAGSICUDT=-nodefaultlibs -nostdlib:LDFLAGSICUDT=:" \
- config/mh-linux || die
-
- # Append doxygen configuration to configure
- sed -i \
- -e 's:icudefs.mk:icudefs.mk Doxyfile:' \
- configure.in || die
- eautoreconf
-}
-
-src_configure() {
- local cross_opts
-
- # bootstrap for cross compilation
- if tc-is-cross-compiler; then
- CFLAGS="" CXXFLAGS="" ASFLAGS="" LDFLAGS="" \
- CC="$(tc-getBUILD_CC)" CXX="$(tc-getBUILD_CXX)" AR="$(tc-getBUILD_AR)" \
- RANLIB="$(tc-getBUILD_RANLIB)" LD="$(tc-getBUILD_LD)" \
- ./configure --disable-renaming --disable-debug \
- --disable-samples --enable-static || die
- emake
- mkdir -p "${WORKDIR}/host/"
- cp -a {bin,lib,config,tools} "${WORKDIR}/host/"
- emake clean
-
- cross_opts="--with-cross-build=${WORKDIR}/host"
- fi
-
- econf \
- --disable-renaming \
- $(use_enable debug) \
- $(use_enable examples samples) \
- $(use_enable static-libs static) \
- ${cross_opts}
-}
-
-src_compile() {
- default
-
- if use doc; then
- doxygen -u Doxyfile || die
- doxygen Doxyfile || die
- fi
-}
-
-src_test() {
- # INTLTEST_OPTS: intltest options
- # -e: Exhaustive testing
- # -l: Reporting of memory leaks
- # -v: Increased verbosity
- # IOTEST_OPTS: iotest options
- # -e: Exhaustive testing
- # -v: Increased verbosity
- # CINTLTST_OPTS: cintltst options
- # -e: Exhaustive testing
- # -v: Increased verbosity
- emake -j1 VERBOSE="1" check
-}
-
-src_install() {
- default
-
- dohtml ../readme.html
-
- use doc && dohtml -p api -r doc/html/
-}
diff --git a/dev-libs/icu/icu-50.1.2.ebuild b/dev-libs/icu/icu-50.1.2.ebuild
index 0bdd5630bd59..69baabfd71cd 100644
--- a/dev-libs/icu/icu-50.1.2.ebuild
+++ b/dev-libs/icu/icu-50.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-50.1.2.ebuild,v 1.1 2013/02/06 14:21:39 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-50.1.2.ebuild,v 1.2 2013/02/06 14:45:53 scarabeus Exp $
EAPI=5
@@ -25,13 +25,15 @@ S="${WORKDIR}/${PN}/source"
PATCHES=(
"${FILESDIR}/${PN}-4.8.1-fix_binformat_fonts.patch"
- "${FILESDIR}/${PN}-4.8.1.1-fix_ltr.patch"
+ "${FILESDIR}/${PN}.7601.Indic-ccmp.patch"
)
src_prepare() {
local variable
base_src_prepare
+ epatch -R \
+ "${FILESDIR}/${PN}.8198.revert.icu5431.patch"
# Do not hardcode flags in icu-config and icu-*.pc files.
# https://ssl.icu-project.org/trac/ticket/6102