summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-10-29 15:00:44 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-10-29 15:00:44 +0000
commit3a0c4f9d5bbe298d6fb0af37d2710041cc362fa5 (patch)
tree433b11aba14546e8c011fc810c54e0f277f0dbb0 /dev-libs/fcgi
parentQA: binchecks should not be restricted. (diff)
downloadgentoo-2-3a0c4f9d5bbe298d6fb0af37d2710041cc362fa5.tar.gz
gentoo-2-3a0c4f9d5bbe298d6fb0af37d2710041cc362fa5.tar.bz2
gentoo-2-3a0c4f9d5bbe298d6fb0af37d2710041cc362fa5.zip
added prefix support (bug #440070)
(Portage version: 2.2.0_alpha142/cvs/Linux i686, signed Manifest commit with key C2000586)
Diffstat (limited to 'dev-libs/fcgi')
-rw-r--r--dev-libs/fcgi/ChangeLog9
-rw-r--r--dev-libs/fcgi/fcgi-2.4.1_pre0910052249-r1.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/dev-libs/fcgi/ChangeLog b/dev-libs/fcgi/ChangeLog
index b70713291942..c22b4dc0744d 100644
--- a/dev-libs/fcgi/ChangeLog
+++ b/dev-libs/fcgi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/fcgi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/fcgi/ChangeLog,v 1.56 2012/10/29 06:59:19 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/fcgi/ChangeLog,v 1.57 2012/10/29 15:00:44 ottxor Exp $
+
+*fcgi-2.4.1_pre0910052249-r1 (29 Oct 2012)
+
+ 29 Oct 2012; Christoph Junghans <ottxor@gentoo.org>
+ +fcgi-2.4.1_pre0910052249-r1.ebuild:
+ added prefix support (bug #440070)
29 Oct 2012; Hans de Graaff <graaff@gentoo.org>
-fcgi-2.4.1_pre0311112127.ebuild:
@@ -210,4 +216,3 @@
04 Sep 2003; Matthew Kennedy <mkennedy@gentoo.org> :
Initial import.
-
diff --git a/dev-libs/fcgi/fcgi-2.4.1_pre0910052249-r1.ebuild b/dev-libs/fcgi/fcgi-2.4.1_pre0910052249-r1.ebuild
new file mode 100644
index 000000000000..5f7b35478f32
--- /dev/null
+++ b/dev-libs/fcgi/fcgi-2.4.1_pre0910052249-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/fcgi/fcgi-2.4.1_pre0910052249-r1.ebuild,v 1.1 2012/10/29 15:00:44 ottxor Exp $
+
+EAPI="4"
+
+inherit eutils autotools multilib
+
+DESCRIPTION="FastCGI Developer's Kit"
+HOMEPAGE="http://www.fastcgi.com/"
+SRC_URI="http://www.fastcgi.com/dist/fcgi-2.4.1-SNAP-0910052249.tar.gz"
+
+LICENSE="FastCGI"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="html"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/fcgi-2.4.1-SNAP-0910052249"
+
+src_prepare() {
+ epatch "${FILESDIR}/fcgi-2.4.0-Makefile.patch"
+ epatch "${FILESDIR}/fcgi-2.4.0-clientdata-pointer.patch"
+ epatch "${FILESDIR}/fcgi-2.4.0-html-updates.patch"
+ epatch "${FILESDIR}"/fcgi-2.4.1_pre0311112127-gcc44.patch
+ epatch "${FILESDIR}"/${P}-link.patch
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install LIBRARY_PATH="${ED}/usr/$(get_libdir)"
+
+ dodoc README
+
+ # install the manpages into the right place
+ doman doc/*.[13]
+
+ # Only install the html documentation if USE=html
+ if use html ; then
+ dohtml "${S}"/doc/*/*
+ insinto /usr/share/doc/${PF}/html
+ doins -r "${S}/images"
+ fi
+
+ # install examples in the right place
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}/examples/"*.c
+}