summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-10-05 02:28:02 +0000
committerMike Frysinger <vapier@gentoo.org>2011-10-05 02:28:02 +0000
commit05da21c796fd2bbc772432dd2e3b08611302e968 (patch)
tree4e3e0953433a3f6e6795d70a7f325f9e8bd6d43f /dev-libs/elfutils
parentDrop forced gcc/binutils/glibc upgrade since these versions are long stable. (diff)
downloadgentoo-2-05da21c796fd2bbc772432dd2e3b08611302e968.tar.gz
gentoo-2-05da21c796fd2bbc772432dd2e3b08611302e968.tar.bz2
gentoo-2-05da21c796fd2bbc772432dd2e3b08611302e968.zip
Switch to patches published with upstream.
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/elfutils')
-rw-r--r--dev-libs/elfutils/ChangeLog7
-rw-r--r--dev-libs/elfutils/elfutils-0.152-r1.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-libs/elfutils/ChangeLog b/dev-libs/elfutils/ChangeLog
index 35d181c48e77..3a3b0593bd87 100644
--- a/dev-libs/elfutils/ChangeLog
+++ b/dev-libs/elfutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/elfutils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.153 2011/10/05 02:27:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.154 2011/10/05 02:28:02 vapier Exp $
+
+*elfutils-0.152-r1 (05 Oct 2011)
+
+ 05 Oct 2011; Mike Frysinger <vapier@gentoo.org> +elfutils-0.152-r1.ebuild:
+ Switch to patches published with upstream.
05 Oct 2011; Mike Frysinger <vapier@gentoo.org> elfutils-0.146.ebuild,
elfutils-0.148.ebuild, elfutils-0.149.ebuild, elfutils-0.150.ebuild,
diff --git a/dev-libs/elfutils/elfutils-0.152-r1.ebuild b/dev-libs/elfutils/elfutils-0.152-r1.ebuild
new file mode 100644
index 000000000000..8d50071ba168
--- /dev/null
+++ b/dev-libs/elfutils/elfutils-0.152-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/elfutils-0.152-r1.ebuild,v 1.1 2011/10/05 02:28:02 vapier Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="Libraries/utilities to handle ELF objects (drop in replacement for libelf)"
+HOMEPAGE="https://fedorahosted.org/elfutils/"
+SRC_URI="https://fedorahosted.org/releases/e/l/${PN}/${PV}/${P}.tar.bz2
+ https://fedorahosted.org/releases/e/l/${PN}/${PV}/${PN}-portability.patch -> ${P}-portability.patch
+ https://fedorahosted.org/releases/e/l/${PN}/${PV}/${PN}-robustify.patch -> ${P}-robustify.patch"
+
+LICENSE="GPL-2-with-exceptions"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 lzma nls zlib"
+
+# This pkg does not actually seem to compile currently in a uClibc
+# environment (xrealloc errs), but we need to ensure that glibc never
+# gets pulled in as a dep since this package does not respect virtual/libc
+RDEPEND="zlib? ( >=sys-libs/zlib-1.2.2.3 )
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ !dev-libs/libelf"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=sys-devel/flex-2.5.4a
+ sys-devel/m4"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.118-PaX-support.patch
+ epatch "${DISTDIR}"/${P}-{portability,robustify}.patch
+ sed -i -e 's:-Werror::g' $(find -name Makefile.in) || die
+ use test || sed -i -e 's: tests::' Makefile.in #226349
+ # some patches touch both configure and configure.ac
+ find -type f -exec touch -r configure {} +
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --program-prefix="eu-" \
+ $(use_with zlib) \
+ $(use_with bzip2 bzlib) \
+ $(use_with lzma)
+}
+
+src_test() {
+ env LD_LIBRARY_PATH="${S}/libelf:${S}/libebl:${S}/libdw:${S}/libasm" \
+ LC_ALL="C" \
+ emake -j1 check || die "test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS NOTES README THANKS TODO
+}