summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2012-02-08 21:24:37 +0000
committerThomas Sachau <tommy@gentoo.org>2012-02-08 21:24:37 +0000
commit5d34b41db46cee10a0a9596c142aeef4247bccc1 (patch)
tree7b9c763621652226f55549359a1ff15078248fbb /dev-libs/eeze
parentMove to new unpacker eclass for unpack_makeself. (diff)
downloadgentoo-2-5d34b41db46cee10a0a9596c142aeef4247bccc1.tar.gz
gentoo-2-5d34b41db46cee10a0a9596c142aeef4247bccc1.tar.bz2
gentoo-2-5d34b41db46cee10a0a9596c142aeef4247bccc1.zip
Version bump
(Portage version: 2.2.0_alpha85-r1/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/eeze')
-rw-r--r--dev-libs/eeze/ChangeLog9
-rw-r--r--dev-libs/eeze/eeze-1.1.0.ebuild26
-rw-r--r--dev-libs/eeze/metadata.xml3
3 files changed, 36 insertions, 2 deletions
diff --git a/dev-libs/eeze/ChangeLog b/dev-libs/eeze/ChangeLog
index 92d5e228e27e..bfa55e1ebf8f 100644
--- a/dev-libs/eeze/ChangeLog
+++ b/dev-libs/eeze/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/eeze
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/eeze/ChangeLog,v 1.5 2011/08/19 15:17:17 tommy Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/eeze/ChangeLog,v 1.6 2012/02/08 21:24:37 tommy Exp $
+
+*eeze-1.1.0 (08 Feb 2012)
+
+ 08 Feb 2012; Thomas Sachau (Tommy[D]) <tommy@gentoo.org> +eeze-1.1.0.ebuild:
+ Version bump
*eeze-1.0.2 (19 Aug 2011)
diff --git a/dev-libs/eeze/eeze-1.1.0.ebuild b/dev-libs/eeze/eeze-1.1.0.ebuild
new file mode 100644
index 000000000000..7f50d562d787
--- /dev/null
+++ b/dev-libs/eeze/eeze-1.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/eeze/eeze-1.1.0.ebuild,v 1.1 2012/02/08 21:24:37 tommy Exp $
+
+inherit enlightenment
+
+DESCRIPTION="library to simplify the use of devices"
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/Eeze"
+SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs utilities"
+
+DEPEND=">=dev-libs/ecore-1.0.0_beta"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ MY_ECONF="
+ $(use_enable utilities eeze-disk-ls)
+ $(use_enable utilities eeze-mount)
+ $(use_enable utilities eeze-umount)
+ $(use_enable utilities eeze-udev-test)
+ "
+
+ enlightenment_src_configure
+}
diff --git a/dev-libs/eeze/metadata.xml b/dev-libs/eeze/metadata.xml
index 99165add909f..a637b6c96b25 100644
--- a/dev-libs/eeze/metadata.xml
+++ b/dev-libs/eeze/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>enlightenment</herd>
+<use>
+ <flag name="utilities">Install some test utilities for mount/umount support in eeze</flag>
+</use>
</pkgmetadata>