summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-25 15:20:49 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-25 15:20:49 +0000
commit70f159824dcf2f42e1f4702a04223f0bdbda49f8 (patch)
tree504477d92c25bdc1fb0c05f088c01f6115c04380 /dev-libs/cryptlib
parentamd64/x86 stable, bug #288827 (diff)
downloadgentoo-2-70f159824dcf2f42e1f4702a04223f0bdbda49f8.tar.gz
gentoo-2-70f159824dcf2f42e1f4702a04223f0bdbda49f8.tar.bz2
gentoo-2-70f159824dcf2f42e1f4702a04223f0bdbda49f8.zip
Version bump. Optionally build Python bindings which were previously built in dev-python/cryptlib_py. Filter some flags for Python bindings (bug #268947).
(Portage version: 14724-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/cryptlib')
-rw-r--r--dev-libs/cryptlib/ChangeLog12
-rw-r--r--dev-libs/cryptlib/cryptlib-3.3.0-r1.ebuild74
-rw-r--r--dev-libs/cryptlib/cryptlib-3.3.1.ebuild75
-rw-r--r--dev-libs/cryptlib/cryptlib-3.3.3.ebuild108
-rw-r--r--dev-libs/cryptlib/files/cryptlib-3.3.0-ld.patch13
5 files changed, 118 insertions, 164 deletions
diff --git a/dev-libs/cryptlib/ChangeLog b/dev-libs/cryptlib/ChangeLog
index 066802274176..fc06c5018687 100644
--- a/dev-libs/cryptlib/ChangeLog
+++ b/dev-libs/cryptlib/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/cryptlib
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/ChangeLog,v 1.15 2009/01/31 00:20:57 dragonheart Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/ChangeLog,v 1.16 2009/10/25 15:20:48 arfrever Exp $
+
+*cryptlib-3.3.3 (25 Oct 2009)
+
+ 25 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -cryptlib-3.3.0-r1.ebuild, -files/cryptlib-3.3.0-ld.patch,
+ -cryptlib-3.3.1.ebuild, +cryptlib-3.3.3.ebuild:
+ Version bump. Optionally build Python bindings which were previously built
+ in dev-python/cryptlib_py. Filter some flags for Python bindings (bug #268947).
*cryptlib-3.3.2 (31 Jan 2009)
diff --git a/dev-libs/cryptlib/cryptlib-3.3.0-r1.ebuild b/dev-libs/cryptlib/cryptlib-3.3.0-r1.ebuild
deleted file mode 100644
index 54b6bb976c32..000000000000
--- a/dev-libs/cryptlib/cryptlib-3.3.0-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/cryptlib-3.3.0-r1.ebuild,v 1.2 2009/01/31 00:20:57 dragonheart Exp $
-
-inherit eutils multilib flag-o-matic
-
-MY_PV="${PV//.0}"
-MY_PV="${MY_PV//.}"
-
-DESCRIPTION="Powerful security toolkit for adding encryption to software"
-HOMEPAGE="http://www.cs.auckland.ac.nz/~pgut001/cryptlib/"
-SRC_URI="ftp://ftp.franken.de/pub/crypt/cryptlib/cl${MY_PV}.zip
- doc? ( mirror://gentoo/${P}-manual.pdf.bz2 )"
-
-LICENSE="Sleepycat"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="doc odbc"
-
-S="${WORKDIR}"
-
-RDEPEND="odbc? ( dev-db/unixODBC )"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4
- app-arch/unzip"
-
-src_unpack() {
- # we need the -a option, so we can not use 'unpack'
- unzip -qoa "${DISTDIR}/cl${MY_PV}.zip"
- use doc && unpack "${P}-manual.pdf.bz2"
-
- # we want our own CFLAGS) ;-)
- sed -i -e "s:-m.*=pentium::g" -e "s:-fomit-frame-pointer::g" -e "s:-O2::g" \
- -e "s:-O3::g" -e "s:-O4::g" makefile || die "sed makefile failed"
-
- # change 'make' to '$(MAKE)'
- sed -i -e "s:@\?make:\$(MAKE):g" makefile || die "sed makefile failed"
-
- # NOTICE:
- # Because of stack execution
- # assembly parts are disabled.
- sed -i -e 's:i\[3,4,5,6\]86:___:g' makefile || die "sed makefile failed"
-
- # fix soname and strip issues
- epatch "${FILESDIR}/${P}-ld.patch"
-}
-
-src_compile() {
- # we need at least -O2
- replace-flags -O -O2
- replace-flags -Os -O2
- replace-flags -O1 -O2
- append-flags -c -D__UNIX__ -DNDEBUG -I.
- # QA issue for pthread_yield
- append-flags -D_GNU_SOURCE
-
- emake -j1 CFLAGS="${CFLAGS}" SCFLAGS="${CFLAGS} -fPIC" || \
- die "emake static failed"
-
- emake -j1 shared CFLAGS="${CFLAGS}" SCFLAGS="${CFLAGS} -fPIC" || \
- die "emake shared failed"
-}
-
-src_install() {
- dolib.so "libcl.so.${PV}"
- dosym "libcl.so.${PV}" "/usr/$(get_libdir)/libcl.so"
- dolib.a "libcl.a"
-
- insinto /usr/include
- doins cryptlib.h
-
- dodoc README
- use doc && newdoc "${P}-manual.pdf" "manual.pdf"
-}
diff --git a/dev-libs/cryptlib/cryptlib-3.3.1.ebuild b/dev-libs/cryptlib/cryptlib-3.3.1.ebuild
deleted file mode 100644
index 0ab5a0ffb861..000000000000
--- a/dev-libs/cryptlib/cryptlib-3.3.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/cryptlib-3.3.1.ebuild,v 1.2 2009/01/31 00:20:57 dragonheart Exp $
-
-inherit eutils multilib flag-o-matic
-
-MY_PV="${PV//.0}"
-MY_PV="${MY_PV//.}"
-
-DESCRIPTION="Powerful security toolkit for adding encryption to software"
-HOMEPAGE="http://www.cs.auckland.ac.nz/~pgut001/cryptlib/"
-DOC_PREFIX="${PN}-3.3.0"
-SRC_URI="ftp://ftp.franken.de/pub/crypt/cryptlib/cl${MY_PV}.zip
- doc? ( mirror://gentoo/${DOC_PREFIX}-manual.pdf.bz2 )"
-
-LICENSE="Sleepycat"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="doc odbc"
-
-S="${WORKDIR}"
-
-RDEPEND="odbc? ( dev-db/unixODBC )"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4
- app-arch/unzip"
-
-src_unpack() {
- # we need the -a option, so we can not use 'unpack'
- unzip -qoa "${DISTDIR}/cl${MY_PV}.zip"
- use doc && unpack "${DOC_PREFIX}-manual.pdf.bz2"
-
- # we want our own CFLAGS) ;-)
- sed -i -e "s:-m.*=pentium::g" -e "s:-fomit-frame-pointer::g" -e "s:-O2::g" \
- -e "s:-O3::g" -e "s:-O4::g" makefile || die "sed makefile failed"
-
- # change 'make' to '$(MAKE)'
- sed -i -e "s:@\?make:\$(MAKE):g" makefile || die "sed makefile failed"
-
- # NOTICE:
- # Because of stack execution
- # assembly parts are disabled.
- sed -i -e 's:i\[3,4,5,6\]86:___:g' makefile || die "sed makefile failed"
-
- # fix soname and strip issues
- epatch "${FILESDIR}/${DOC_PREFIX}-ld.patch"
-}
-
-src_compile() {
- # we need at least -O2
- replace-flags -O -O2
- replace-flags -Os -O2
- replace-flags -O1 -O2
- append-flags -c -D__UNIX__ -DNDEBUG -I.
- # QA issue for pthread_yield
- append-flags -D_GNU_SOURCE
-
- emake -j1 CFLAGS="${CFLAGS}" SCFLAGS="${CFLAGS} -fPIC" || \
- die "emake static failed"
-
- emake -j1 shared CFLAGS="${CFLAGS}" SCFLAGS="${CFLAGS} -fPIC" || \
- die "emake shared failed"
-}
-
-src_install() {
- dolib.so "libcl.so.3.3.0"
- dosym "libcl.so.3.3.0" "/usr/$(get_libdir)/libcl.so"
- dolib.a "libcl.a"
-
- insinto /usr/include
- doins cryptlib.h
-
- dodoc README
- use doc && newdoc "${DOC_PREFIX}-manual.pdf" "manual.pdf"
-}
diff --git a/dev-libs/cryptlib/cryptlib-3.3.3.ebuild b/dev-libs/cryptlib/cryptlib-3.3.3.ebuild
new file mode 100644
index 000000000000..3f99d9ae876c
--- /dev/null
+++ b/dev-libs/cryptlib/cryptlib-3.3.3.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/cryptlib-3.3.3.ebuild,v 1.1 2009/10/25 15:20:48 arfrever Exp $
+
+EAPI="2"
+DISTUTILS_DISABLE_PYTHON_DEPENDENCY="1"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils flag-o-matic multilib toolchain-funcs
+
+MY_PV="${PV//.0}"
+MY_PV="${MY_PV//.}"
+
+DESCRIPTION="Powerful security toolkit for adding encryption to software"
+HOMEPAGE="http://www.cs.auckland.ac.nz/~pgut001/cryptlib/"
+DOC_PREFIX="${PN}-3.3.3"
+SRC_URI="ftp://ftp.franken.de/pub/crypt/cryptlib/cl${MY_PV}.zip
+ doc? ( mirror://gentoo/${DOC_PREFIX}-manual.pdf.bz2 )"
+
+LICENSE="Sleepycat"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="doc ldap odbc python"
+
+S="${WORKDIR}"
+
+RDEPEND="sys-libs/zlib
+ ldap? ( net-nds/openldap )
+ odbc? ( dev-db/unixODBC )
+ python? ( virtual/python )
+ !dev-python/cryptlib_py"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_unpack() {
+ # we need the -a option, so we can not use 'unpack'
+ unzip -qoa "${DISTDIR}/cl${MY_PV}.zip"
+ use doc && unpack "${DOC_PREFIX}-manual.pdf.bz2"
+}
+
+src_prepare() {
+ rm -fr zlib
+
+ # we want our own CFLAGS ;-)
+ sed -i -e "s:-m.*=pentium::g" -e "s:-fomit-frame-pointer::g" -e "s:-O2::g" \
+ -e "s:-O3::g" -e "s:-O4::g" makefile || die "sed makefile failed"
+ sed -i -e "s/-march=[[:alnum:]\.=-]*//g" -e "s/-mcpu=[[:alnum:]\.=-]*//g" \
+ -e "s:-O2::g" -e "s:-O3::g" tools/ccopts.sh || die "sed tools/ccopts.sh failed"
+
+ # change 'make' to '$(MAKE)'
+ sed -i -e "s:@\?make:\$(MAKE):g" makefile || die "sed makefile failed"
+
+ # NOTICE:
+ # Because of stack execution
+ # assembly parts are disabled.
+ sed -i -e 's:i\[3,4,5,6\]86:___:g' makefile || die "sed makefile failed"
+
+ # Fix version number of shared library.
+ sed -i -e 's/PLV="2"/PLV="3"/' tools/buildall.sh || die "sed tools/buildall.sh failed"
+
+ # Respect LDFLAGS and fix soname and strip issues.
+ epatch "${FILESDIR}/${PN}-3.3.2-ld.patch"
+
+ # Use external zlib.
+ epatch "${FILESDIR}/${PN}-3.3.2-external-zlib.patch"
+}
+
+src_compile() {
+ # At least -O2 is needed.
+ replace-flags -O -O2
+ replace-flags -O0 -O2
+ replace-flags -O1 -O2
+ replace-flags -Os -O2
+ is-flagq -O* || append-flags -O2
+
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -c -D__UNIX__ -DNDEBUG -I." || die "emake static failed"
+
+ emake shared CC="$(tc-getCC)" CFLAGS="${CFLAGS} -c -D__UNIX__ -DNDEBUG -I." || die "emake shared failed"
+
+ if use python; then
+ ln -s libcl.so.${PV} libcl.so || die
+
+ # Python bindings don't work with -O2 and higher.
+ replace-flags -O* -O1
+
+ cd bindings
+ distutils_src_compile
+ fi
+}
+
+src_install() {
+ dolib.so "libcl.so.${PV}" || die
+ dosym "libcl.so.${PV}" "/usr/$(get_libdir)/libcl.so" || die
+ dolib.a "libcl.a" || die
+
+ insinto /usr/include || die
+ doins cryptlib.h || die
+
+ if use python; then
+ pushd bindings > /dev/null
+ distutils_src_install
+ popd > /dev/null
+ fi
+
+ dodoc README
+ use doc && newdoc "${DOC_PREFIX}-manual.pdf" "manual.pdf"
+}
diff --git a/dev-libs/cryptlib/files/cryptlib-3.3.0-ld.patch b/dev-libs/cryptlib/files/cryptlib-3.3.0-ld.patch
deleted file mode 100644
index 18ed2962f5fa..000000000000
--- a/dev-libs/cryptlib/files/cryptlib-3.3.0-ld.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./tools/buildsharedlib.sh.old 2006-10-22 15:24:29.000000000 +0200
-+++ ./tools/buildsharedlib.sh 2006-10-22 15:25:49.000000000 +0200
-@@ -98,7 +98,8 @@ case $OSNAME in
- strip $LIBNAME ;;
-
- *)
-- $LD -shared -o $LIBNAME `cat $LINKFILE` `./tools/getlibs.sh autodetect` ;
-- strip $LIBNAME ;;
-+ $LD -shared -Wl,-soname,$LIBNAME -o $LIBNAME `cat $LINKFILE` `./tools/getlibs.sh autodetect` ;
-+# strip $LIBNAME
-+ ;;
- esac
- rm -f $LINKFILE