summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-12-05 12:25:36 +0000
committerPacho Ramos <pacho@gentoo.org>2014-12-05 12:25:36 +0000
commit75c5738c02975b619a908b00721ff253ff9ece17 (patch)
treeffcba86be66cdf59c7a673bab9c102a63a0fc8de /dev-libs/appstream-glib
parentEnsure obexd is launched when needed and add missing rdepend on bluez[obex] (... (diff)
downloadgentoo-2-75c5738c02975b619a908b00721ff253ff9ece17.tar.gz
gentoo-2-75c5738c02975b619a908b00721ff253ff9ece17.tar.bz2
gentoo-2-75c5738c02975b619a908b00721ff253ff9ece17.zip
Version bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs/appstream-glib')
-rw-r--r--dev-libs/appstream-glib/ChangeLog7
-rw-r--r--dev-libs/appstream-glib/appstream-glib-0.3.3.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-libs/appstream-glib/ChangeLog b/dev-libs/appstream-glib/ChangeLog
index b0f1cfc0db06..c4c4483fdb9d 100644
--- a/dev-libs/appstream-glib/ChangeLog
+++ b/dev-libs/appstream-glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/appstream-glib
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/appstream-glib/ChangeLog,v 1.8 2014/11/24 11:13:49 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/appstream-glib/ChangeLog,v 1.9 2014/12/05 12:25:36 pacho Exp $
+
+*appstream-glib-0.3.3 (05 Dec 2014)
+
+ 05 Dec 2014; Pacho Ramos <pacho@gentoo.org> +appstream-glib-0.3.3.ebuild:
+ Version bump
24 Nov 2014; Michał Górny <mgorny@gentoo.org> appstream-glib-0.3.2.ebuild:
[QA] Add missing blocker on colliding versions of dev-util/appdata-tools. Use
diff --git a/dev-libs/appstream-glib/appstream-glib-0.3.3.ebuild b/dev-libs/appstream-glib/appstream-glib-0.3.3.ebuild
new file mode 100644
index 000000000000..6b502d65ceca
--- /dev/null
+++ b/dev-libs/appstream-glib/appstream-glib-0.3.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/appstream-glib/appstream-glib-0.3.3.ebuild,v 1.1 2014/12/05 12:25:36 pacho Exp $
+
+EAPI=5
+
+inherit autotools eutils bash-completion-r1
+
+MY_P="${PN/-/_}_${PV//./_}"
+
+DESCRIPTION="Provides GObjects and helper methods to read and write AppStream metadata"
+HOMEPAGE="https://github.com/hughsie/appstream-glib"
+SRC_URI="https://github.com/hughsie/${PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/7"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64"
+IUSE="+introspection nls"
+
+# FIXME: yaml is optional but not properly handled in autofoo
+RDEPEND="
+ app-arch/libarchive
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.16.1:2
+ media-libs/fontconfig
+ >=media-libs/freetype-2.4:2
+ >=net-libs/libsoup-2.24:2.4
+ >=x11-libs/gdk-pixbuf-2.14:2
+ x11-libs/gtk+:3
+ x11-libs/pango
+ dev-libs/libyaml
+ introspection? ( >=dev-libs/gobject-introspection-0.9.8 )
+"
+# gtk-doc required until package is released properly
+# https://github.com/hughsie/appstream-glib/issues/26
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.3
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-1.21
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+"
+# ${PN} superseeds appdata-tools, require dummy package until all ebuilds
+# are migrated to appstream-glib
+RDEPEND="${RDEPEND}
+ !<dev-util/appdata-tools-0.1.8-r1"
+PDEPEND=">=dev-util/appdata-tools-0.1.8-r1"
+
+S="${WORKDIR}/${PN}-${MY_P}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-rpm \
+ --disable-static \
+ --enable-dep11 \
+ --enable-man \
+ $(use_enable nls) \
+ $(use_enable introspection) \
+ --with-bashcompletiondir="$(get_bashcompdir)"
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}