summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPreston A. Elder <prez@gentoo.org>2002-04-26 04:04:00 +0000
committerPreston A. Elder <prez@gentoo.org>2002-04-26 04:04:00 +0000
commit0b1ba8980cefd0c1c2c5f0ba9c87a36fccb7cc06 (patch)
treef1388cc75d2b840434f30ffe08800f7d70e27403 /dev-libs/ace
parentfix broken header, cleanup formatting. (diff)
downloadgentoo-2-0b1ba8980cefd0c1c2c5f0ba9c87a36fccb7cc06.tar.gz
gentoo-2-0b1ba8980cefd0c1c2c5f0ba9c87a36fccb7cc06.tar.bz2
gentoo-2-0b1ba8980cefd0c1c2c5f0ba9c87a36fccb7cc06.zip
Added ACE to the build system.
Diffstat (limited to 'dev-libs/ace')
-rw-r--r--dev-libs/ace/ChangeLog9
-rw-r--r--dev-libs/ace/ace-5.2.1.ebuild60
-rw-r--r--dev-libs/ace/ace-5.2.ebuild60
-rw-r--r--dev-libs/ace/files/digest-ace-5.21
-rw-r--r--dev-libs/ace/files/digest-ace-5.2.11
5 files changed, 131 insertions, 0 deletions
diff --git a/dev-libs/ace/ChangeLog b/dev-libs/ace/ChangeLog
new file mode 100644
index 000000000000..ef9955bb04b2
--- /dev/null
+++ b/dev-libs/ace/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-gfx/scrot
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ChangeLog,v 1.1 2002/04/26 04:04:00 prez Exp $
+
+*ace-5.2.1 (26 April 2002)
+
+ 26 April 2002; Preston A. Elder <prez@gentoo.org> ChangeLog :
+
+ Initial ebuild... Enjoy..
diff --git a/dev-libs/ace/ace-5.2.1.ebuild b/dev-libs/ace/ace-5.2.1.ebuild
new file mode 100644
index 000000000000..a514aa373deb
--- /dev/null
+++ b/dev-libs/ace/ace-5.2.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Preston A. Elder <prez@goth.net>
+
+S=${WORKDIR}/ACE_wrappers
+ACE_VER=5.2.1
+DESCRIPTION="The Adaptive Communications Environment"
+SRC_URI="http://deuce.doc.wustl.edu/ACE-${ACE_VER}.tar.gz
+ ftp://deuce.doc.wustl.edu/pub/ACE+TAO-distribution/ACE-${ACE_VER}.tar.gz"
+HOMEPAGE="http://www.cs.wustl.edu/~schmidt/ACE.html"
+#DEPEND=""
+
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}/ace
+ cp config-linux.h config.h
+ cd ${S}/include/makeinclude
+ sed -e "s:-O3:${CFLAGS}:" platform_linux.GNU >platform_macros.GNU
+}
+
+src_compile() {
+
+ export ACE_ROOT=${S}
+ cd ${S}
+ emake static_libs=1 || die
+}
+
+src_install() {
+
+ dodir /usr/include/ace /usr/lib /usr/share/man/man3
+
+ cd ${S}/ace
+ cp libACE.so ${D}/usr/lib/libACE.so.${ACE_VER}
+ cp libACE.a ${D}/usr/lib/libACE.a
+ cd ${D}/usr/lib
+ ln -s libACE.so.${ACE_VER} libACE.so.`echo ${ACE_VER} | cut -f1 -d.`
+ ln -s libACE.so.${ACE_VER} libACE.so
+
+ cd ${S}/ace
+ cp -r *.h *.cpp *.i *.inl ${D}/usr/include/ace
+ chmod 644 ${D}/usr/include/ace/*
+
+ cd ${S}/man/man3
+ cp *.3 ${D}/usr/share/man/man3
+ chmod 644 ${D}/usr/share/man/man3/*.3
+ gzip ${D}/usr/share/man/man3/*.3
+
+ cd ${S}
+ dodoc ACE-INSTALL* AUTHORS COPYING FAQ PROBLEM-REPORT-FORM README
+ dodoc THANKS TODO VERSION
+ cd ${S}/docs
+ dodoc *.html *.txt *gz
+ cd ${S}
+ docinto ChangeLogs
+ dodoc ChangeLog
+ cd ${S}/ChangeLogs
+ dodoc ChangeLog*
+}
diff --git a/dev-libs/ace/ace-5.2.ebuild b/dev-libs/ace/ace-5.2.ebuild
new file mode 100644
index 000000000000..804b0a11c7e1
--- /dev/null
+++ b/dev-libs/ace/ace-5.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Preston A. Elder <prez@goth.net>
+
+S=${WORKDIR}/ACE_wrappers
+ACE_VER=5.2
+DESCRIPTION="The Adaptive Communications Environment"
+SRC_URI="http://deuce.doc.wustl.edu/ACE-${ACE_VER}.tar.gz
+ ftp://deuce.doc.wustl.edu/pub/ACE+TAO-distribution/ACE-${ACE_VER}.tar.gz"
+HOMEPAGE="http://www.cs.wustl.edu/~schmidt/ACE.html"
+#DEPEND=""
+
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}/ace
+ cp config-linux.h config.h
+ cd ${S}/include/makeinclude
+ sed -e "s:-O3:${CFLAGS}:" platform_linux.GNU >platform_macros.GNU
+}
+
+src_compile() {
+
+ export ACE_ROOT=${S}
+ cd ${S}
+ emake static_libs=1 || die
+}
+
+src_install() {
+
+ dodir /usr/include/ace /usr/lib /usr/share/man/man3
+
+ cd ${S}/ace
+ cp libACE.so ${D}/usr/lib/libACE.so.${ACE_VER}
+ cp libACE.a ${D}/usr/lib/libACE.a
+ cd ${D}/usr/lib
+ ln -s libACE.so.${ACE_VER} libACE.so.`echo ${ACE_VER} | cut -f1 -d.`
+ ln -s libACE.so.${ACE_VER} libACE.so
+
+ cd ${S}/ace
+ cp -r *.h *.cpp *.i *.inl ${D}/usr/include/ace
+ chmod 644 ${D}/usr/include/ace/*
+
+ cd ${S}/man/man3
+ cp *.3 ${D}/usr/share/man/man3
+ chmod 644 ${D}/usr/share/man/man3/*.3
+ gzip ${D}/usr/share/man/man3/*.3
+
+ cd ${S}
+ dodoc ACE-INSTALL* AUTHORS COPYING FAQ PROBLEM-REPORT-FORM README
+ dodoc THANKS TODO VERSION
+ cd ${S}/docs
+ dodoc *.html *.txt *gz
+ cd ${S}
+ docinto ChangeLogs
+ dodoc ChangeLog
+ cd ${S}/ChangeLogs
+ dodoc ChangeLog*
+}
diff --git a/dev-libs/ace/files/digest-ace-5.2 b/dev-libs/ace/files/digest-ace-5.2
new file mode 100644
index 000000000000..267e132278d3
--- /dev/null
+++ b/dev-libs/ace/files/digest-ace-5.2
@@ -0,0 +1 @@
+md5 a0039784b7296359e1e2952bd6dd0214 ACE-5.2.tar.gz 6565224
diff --git a/dev-libs/ace/files/digest-ace-5.2.1 b/dev-libs/ace/files/digest-ace-5.2.1
new file mode 100644
index 000000000000..b6606eecb77d
--- /dev/null
+++ b/dev-libs/ace/files/digest-ace-5.2.1
@@ -0,0 +1 @@
+MD5 efc5b32aed8648eda151e0a7c95b1d9d ACE-5.2.1.tar.gz 6584394