summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-01-02 23:36:29 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-01-02 23:36:29 +0000
commitae5d7df201a1f90dbbd199241e56f21c0ed23f58 (patch)
tree6ed07e8d1a82f4e6471d6b9cf20da7580a61097a /dev-libs/OpenSRF/files
parentInitial commit. Dep for EverGreen ILS (via CQL-Parser). (diff)
downloadgentoo-2-ae5d7df201a1f90dbbd199241e56f21c0ed23f58.tar.gz
gentoo-2-ae5d7df201a1f90dbbd199241e56f21c0ed23f58.tar.bz2
gentoo-2-ae5d7df201a1f90dbbd199241e56f21c0ed23f58.zip
Disable the pkg_config routine for now as it needs functional jabber. Fix a braindead search in the ctl tool, and remember to install the docs and javascript, and everything with correct paths.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-03114-g3c92ec8 x86_64)
Diffstat (limited to 'dev-libs/OpenSRF/files')
-rw-r--r--dev-libs/OpenSRF/files/OpenSRF-1.0.1-buildfix.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-libs/OpenSRF/files/OpenSRF-1.0.1-buildfix.patch b/dev-libs/OpenSRF/files/OpenSRF-1.0.1-buildfix.patch
index 75a6f8ac2e2e..e93e6e6f824e 100644
--- a/dev-libs/OpenSRF/files/OpenSRF-1.0.1-buildfix.patch
+++ b/dev-libs/OpenSRF/files/OpenSRF-1.0.1-buildfix.patch
@@ -3,6 +3,7 @@
- split out install targets to build the apache modules
- disable perl and apache install targets, will use gentoo tools instead
- compile fix to osrf_chat.c
+- Hardcode location of osrf_config instead of using a long recursive find statement
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
@@ -162,3 +163,16 @@ diff -Nuar OpenSRF-1.0.1.orig/Makefile.am OpenSRF-1.0.1/Makefile.am
- cp @srcdir@/src/gateway/apachetools.h @includedir@/opensrf/apachetools.h
+ cp @srcdir@/src/gateway/apachetools.h $(DESTDIR)@includedir@/opensrf/apachetools.h
+diff -Nuar OpenSRF-1.0.1/bin/osrf_ctl.sh
+--- OpenSRF-1.0.1.orig/bin/osrf_ctl.sh 2008-09-24 20:27:44.000000000 -0700
++++ OpenSRF-1.0.1/bin/osrf_ctl.sh 2008-12-09 02:25:39.018456228 -0800
+@@ -87,7 +87,8 @@
+ esac;
+ done
+
+-OSRF_CONFIG=`find $BASEDIR -name osrf_config`
++#OSRF_CONFIG=`find $BASEDIR -name osrf_config`
++OSRF_CONFIG=/usr/bin/osrf_config
+
+ [ -z "$OPT_CONFIG" ] && OPT_CONFIG=`$OSRF_CONFIG --sysconfdir`/opensrf_core.xml;
+ if [ ! -r "$OPT_CONFIG" ]; then