summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-12-01 13:58:42 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-12-01 13:58:42 +0000
commitf60d54b79574b1f6bf4c8e6501d821ad84930ee6 (patch)
tree084e2970b41543db7b94368e802d6dd720361f59 /dev-lang
parentVersion bump. Libmowgli dependencies bled through into the external headers, ... (diff)
downloadgentoo-2-f60d54b79574b1f6bf4c8e6501d821ad84930ee6.tar.gz
gentoo-2-f60d54b79574b1f6bf4c8e6501d821ad84930ee6.tar.bz2
gentoo-2-f60d54b79574b1f6bf4c8e6501d821ad84930ee6.zip
Fix autogen problems (bug 355733).
(Portage version: 2.1.10.39/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog6
-rw-r--r--dev-lang/python/python-2.7.2-r3.ebuild5
-rw-r--r--dev-lang/python/python-3.1.4-r3.ebuild5
-rw-r--r--dev-lang/python/python-3.2.2.ebuild5
4 files changed, 14 insertions, 7 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 845e412a0926..e853cc0a25fb 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.559 2011/12/01 11:19:00 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.560 2011/12/01 13:58:42 djc Exp $
+
+ 01 Dec 2011; Dirkjan Ochtman <djc@gentoo.org> python-2.7.2-r3.ebuild,
+ python-3.1.4-r3.ebuild, python-3.2.2.ebuild:
+ Fix autogen problems (bug 355733).
01 Dec 2011; Dirkjan Ochtman <djc@gentoo.org> -python-2.7.2-r2.ebuild,
-python-3.1.4-r2.ebuild, -python-3.2-r2.ebuild:
diff --git a/dev-lang/python/python-2.7.2-r3.ebuild b/dev-lang/python/python-2.7.2-r3.ebuild
index dc52ee93767e..02153d41f5ec 100644
--- a/dev-lang/python/python-2.7.2-r3.ebuild
+++ b/dev-lang/python/python-2.7.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.2-r3.ebuild,v 1.8 2011/11/26 16:50:52 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.2-r3.ebuild,v 1.9 2011/12/01 13:58:42 djc Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -152,7 +152,8 @@ src_prepare() {
# Linux-3 compat. Bug #374579 (upstream issue12571)
cp -r "${S}/Lib/plat-linux2" "${S}/Lib/plat-linux3" || die
- eautoreconf
+ eautoconf
+ eautoheader
}
src_configure() {
diff --git a/dev-lang/python/python-3.1.4-r3.ebuild b/dev-lang/python/python-3.1.4-r3.ebuild
index 5e48be1ff4b4..6cd9e833c7a2 100644
--- a/dev-lang/python/python-3.1.4-r3.ebuild
+++ b/dev-lang/python/python-3.1.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.4-r3.ebuild,v 1.6 2011/11/26 16:50:52 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.4-r3.ebuild,v 1.7 2011/12/01 13:58:42 djc Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -127,7 +127,8 @@ src_prepare() {
Modules/getpath.c \
setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
- eautoreconf
+ eautoconf
+ eautoheader
}
src_configure() {
diff --git a/dev-lang/python/python-3.2.2.ebuild b/dev-lang/python/python-3.2.2.ebuild
index a18d84eb9f29..95f257112457 100644
--- a/dev-lang/python/python-3.2.2.ebuild
+++ b/dev-lang/python/python-3.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.2.ebuild,v 1.3 2011/10/31 04:02:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.2.ebuild,v 1.4 2011/12/01 13:58:42 djc Exp $
EAPI="3"
WANT_AUTOMAKE="none"
@@ -135,7 +135,8 @@ src_prepare() {
sed -e "s/\(-DSVNVERSION=\).*\( -o\)/\1\\\\\"${ESVN_REVISION}\\\\\"\2/" -i Makefile.pre.in || die "sed failed"
fi
- eautoreconf
+ eautoconf
+ eautoheader
}
src_configure() {