summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2004-01-11 21:26:11 +0000
committerAndres Loeh <kosmikus@gentoo.org>2004-01-11 21:26:11 +0000
commitdf0e8eb7d239987512614f75cad43de6bd6b6a44 (patch)
tree9eb6b5f349826297f7fdd64384c15a24f1a794fa /dev-lang
parentChanged the distcc-config related ewarn message. (diff)
downloadgentoo-2-df0e8eb7d239987512614f75cad43de6bd6b6a44.tar.gz
gentoo-2-df0e8eb7d239987512614f75cad43de6bd6b6a44.tar.bz2
gentoo-2-df0e8eb7d239987512614f75cad43de6bd6b6a44.zip
moved checks to pkg_setup, bug #33962
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ghc/ChangeLog7
-rw-r--r--dev-lang/ghc/files/digest-ghc-5.04.31
-rw-r--r--dev-lang/ghc/ghc-5.04.3-r1.ebuild51
-rw-r--r--dev-lang/ghc/ghc-5.04.3.ebuild153
4 files changed, 31 insertions, 181 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index da9a7ade84f2..70d0f1924565 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ghc
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.25 2003/12/22 09:15:50 kosmikus Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.26 2004/01/11 21:26:11 kosmikus Exp $
+
+ 11 Jan 2004; Andres Loeh <kosmikus@gentoo.org> ghc-5.04.3-r1.ebuild:
+ moved setup checks to pkg_setup (bug #33962).
22 Dec 2003; Andres Loeh <kosmikus@gentoo.org> ghc-6.2.ebuild:
Haddock got called even with USE=-doc.
diff --git a/dev-lang/ghc/files/digest-ghc-5.04.3 b/dev-lang/ghc/files/digest-ghc-5.04.3
deleted file mode 100644
index 4a11d128985b..000000000000
--- a/dev-lang/ghc/files/digest-ghc-5.04.3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 2d4d60f11e8f5909c4f28a02b2c69917 ghc-5.04.3-src.tar.bz2 4741512
diff --git a/dev-lang/ghc/ghc-5.04.3-r1.ebuild b/dev-lang/ghc/ghc-5.04.3-r1.ebuild
index 3e2995e458c2..5d9120b86b62 100644
--- a/dev-lang/ghc/ghc-5.04.3-r1.ebuild
+++ b/dev-lang/ghc/ghc-5.04.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-5.04.3-r1.ebuild,v 1.8 2003/11/11 19:42:36 pappy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-5.04.3-r1.ebuild,v 1.9 2004/01/11 21:26:11 kosmikus Exp $
#Some explanation of bootstrap logic:
#
@@ -64,34 +64,35 @@ RDEPEND="virtual/glibc
>=dev-libs/gmp-4.1
opengl? ( virtual/opengl virtual/glu virtual/glut )"
+# extend path to /opt/ghc/bin to guarantee that ghc-bin is found
+GHCPATH="${PATH}:/opt/ghc/bin"
-#determine what version of ghc we have around:
-if test -z "${GHC}"; then
- GHC=`which ghc`
-fi
-
-BASE_GHC_VERSION=`"$GHC" --version | sed 's/^.*version //'`
+pkg_setup() {
+ #determine what version of ghc we have around:
+ if test -z "${GHC}"; then
+ GHC=`which ghc`
+ fi
-# If the base GHC version matches wanted one we can skip stage1
-if test x${BASE_GHC_VERSION} = x${PV}; then
- need_stage1=no
-else
- need_stage1=yes
-fi
+ BASE_GHC_VERSION=`"$GHC" --version | sed 's/^.*version //'`
-# If we update from certain package combinations, we need to compile
-# twice to get a GHCi bug fixed ...
-has_version '>=sys-libs/glibc-2.3.2' \
- && has_version '<=virtual/ghc-5.04.3' \
- && need_stage1=yes
+ # If the base GHC version matches wanted one we can skip stage1
+ if test x${BASE_GHC_VERSION} = x${PV}; then
+ need_stage1=no
+ else
+ need_stage1=yes
+ fi
-# some vars
-STAGE1_B="${WORKDIR}/stage1-build"
-STAGE2_B="${WORKDIR}/stage2-build"
-STAGE1_D="${BUILDDIR}/stage1-image"
+ # If we update from certain package combinations, we need to compile
+ # twice to get a GHCi bug fixed ...
+ has_version '>=sys-libs/glibc-2.3.2' \
+ && has_version '<=virtual/ghc-5.04.3' \
+ && need_stage1=yes
-# extend path to /opt/ghc/bin to guarantee that ghc-bin is found
-GHCPATH="${PATH}:/opt/ghc/bin"
+ # some vars
+ STAGE1_B="${WORKDIR}/stage1-build"
+ STAGE2_B="${WORKDIR}/stage2-build"
+ STAGE1_D="${WORKDIR}/stage1-image"
+}
src_unpack() {
base_src_unpack
diff --git a/dev-lang/ghc/ghc-5.04.3.ebuild b/dev-lang/ghc/ghc-5.04.3.ebuild
deleted file mode 100644
index 701981d087bd..000000000000
--- a/dev-lang/ghc/ghc-5.04.3.ebuild
+++ /dev/null
@@ -1,153 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-5.04.3.ebuild,v 1.2 2003/04/06 06:42:25 george Exp $
-
-#Some explanation of bootstrap logic:
-#
-#After thinking through the best way to bootstrap ghc I decided to split it into
-#ghc and ghc-bin and make ghc depend on ghc-bin.
-# The ebuild has been revamped and greatly simplified. Bootstrap off old 4x hc files no longer works on x86.
-#Not sure what happens with old scheme on sparc, as I did not see any test reports.
-#
-#The considerations:
-#Making ghc unpack binary build first (under ${WORKDIR}) and bootstrapping from that will effectively force
-#ghc-bin reinstall every time ghc is rebuilt or upgraded. What is worse it will likely force download of binary image
-#at upgrade, which is not nice (in fact quite bad for modem users - 16+ MB).
-#
-#The best results are achieved if ghc-bin is left alone after ghc installation -
-#Both ebuilds install in the same place, thus space penalty is minimal. In fact only the docs exist in double
-#(considering that ghc is not installing much docs at present this looks more like an advantage).
-#When the upgrade time comes, if you still have ghc-bin around, portage will happily bootstrap off
-#your existing ghc (or ghc-bin, whichever was merged last), without attempting to ruin anything...
-#
-#There is only one issue: ghci will be successfully built only if ghc is bootstrapped from the same version.
-#Thus we need to detect presently installed one and bootstrap in one or two stages..
-
-inherit base
-
-IUSE="opengl"
-
-DESCRIPTION="The Glasgow Haskell Compiler"
-HOMEPAGE="http://www.haskell.org/ghc/"
-
-SRC_URI="http://www.haskell.org/ghc/dist/${PV}/ghc-${PV}-src.tar.bz2"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="x86 ~sparc -ppc -alpha"
-
-
-PROVIDE="virtual/ghc"
-# FIXME: Add USE support for parallel haskell (requires PVM)
-# Get PVM from ftp://ftp.netlib.org/pvm3/
-DEPEND="virtual/ghc
- >=dev-lang/perl-5.6.1
- >=sys-devel/gcc-2.95.3
- >=sys-devel/make-3.79.1
- >=sys-apps/sed-3.02.80
- >=sys-devel/flex-2.5.4a
- >=dev-libs/gmp-4.1
- opengl? ( virtual/opengl
- virtual/glu
- virtual/glut )"
-
-RDEPEND="virtual/glibc
- >=sys-devel/gcc-2.95.3
- >=dev-lang/perl-5.6.1
- opengl? ( virtual/opengl virtual/glu virtual/glut )"
-
-
-#determine what version of ghc we have around:
-if test -z "${GHC}"; then
- GHC=`which ghc`
-fi
-
-BASE_GHC_VERSION=`"$GHC" --version | sed 's/^.*version //'`
-
-# If the base GHC version matches wanted one we can skip stage1
-if test x${BASE_GHC_VERSION} = x${PV}; then
- need_stage1=no
-else
- need_stage1=yes
-fi
-
-#some vars
-STAGE1_B="${WORKDIR}/stage1-build"
-STAGE2_B="${WORKDIR}/stage2-build"
-STAGE1_D="${BUILDDIR}/stage1-image"
-
-src_unpack() {
- base_src_unpack
-
- # Create our own lndir if none installed.
- local LNDIR
- if which lndir; then
- LNDIR=lndir
- else
- # Current directory should be $WORKDIR.
- echo "You don\'t seem to have lndir available, building my own"
- echo "version..."
- cp ${FILESDIR}/lndir.c . || die
- make lndir || die
- LNDIR=./lndir
- fi
-
- # Create build directories.
- if test x$need_stage1 = xyes; then
- echo '>>> Creating stage 1 build dir'
- mkdir ${STAGE1_B} || die
- ${LNDIR} ${S} ${STAGE1_B} || die
- fi
- echo '>>> Creating stage 2 build dir'
- mkdir ${STAGE2_B} || die
- ${LNDIR} ${S} ${STAGE2_B} || die
-
-}
-
-src_compile() {
- local myconf
- use opengl && myconf="--enable-hopengl" || myconf="--disable-hopengl"
-
- if test x$need_stage1 = xyes; then
- echo ">>> Bootstrapping intermediate GHC ${PV} using GHC ${BASE_GHC_VERSION}"
-
- pushd "${STAGE1_B}" || die
- ./configure \
- -host="${CHOST}" \
- --prefix="${STAGE1_D}/usr" \
- --with-ghc="${GHC}" \
- --without-happy || die "intermediate stage configure failed"
- #parallel make causes trouble
- make || die "intermediate stage make failed"
- make install || die
- GHC=${STAGE1_D}/usr/bin/ghc
- popd
- fi
-
- pushd "${STAGE2_B}" || die
- econf --enable-threaded-rts --with-ghc="${GHC}" ${myconf}|| die "./configure failed"
- # the build does not seem to work all that
- # well with parallel make
- make || die
- popd
-}
-
-src_install () {
- pushd "${STAGE2_B}" || die
- make install \
- prefix="${D}/usr" \
- infodir="${D}/usr/share/info" \
- mandir="${D}/usr/share/man" || die
- popd
-
- #need to remove ${D} from ghcprof script
- cd ${D}/usr/bin
- mv ghcprof ghcprof-orig
- sed -e 's:$FPTOOLS_TOP_ABS:#$FPTOOLS_TOP_ABS:' ghcprof-orig > ghcprof
- chmod a+x ghcprof
- rm -f ghcprof-orig
-
- cd ${S}/ghc
- dodoc README ANNOUNCE LICENSE VERSION
-}
-