summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-02-24 11:30:28 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-02-24 11:30:28 +0000
commitc580a3d83ffdbff46670d31e3c2ff92c8146025b (patch)
treec7e003b8fa3ad44abe41d7f16d04c056b3e13cf3 /dev-lang
parentDon't bzip the patches inside the tarball (diff)
downloadgentoo-2-c580a3d83ffdbff46670d31e3c2ff92c8146025b.tar.gz
gentoo-2-c580a3d83ffdbff46670d31e3c2ff92c8146025b.tar.bz2
gentoo-2-c580a3d83ffdbff46670d31e3c2ff92c8146025b.zip
added smp and kpoll USE flags to enable/disable those features, adjusted some bits; thanks to Max Loparyev <max@city.veganet.ru>
(Portage version: 2.1.2-r9)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/erlang/ChangeLog9
-rw-r--r--dev-lang/erlang/erlang-11.2.3-r1.ebuild155
-rw-r--r--dev-lang/erlang/files/digest-erlang-11.2.3-r19
3 files changed, 172 insertions, 1 deletions
diff --git a/dev-lang/erlang/ChangeLog b/dev-lang/erlang/ChangeLog
index c3fe646f37fc..a3b56e2dfffb 100644
--- a/dev-lang/erlang/ChangeLog
+++ b/dev-lang/erlang/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/erlang
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.56 2007/02/22 10:28:42 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.57 2007/02/24 11:30:28 opfer Exp $
+
+*erlang-11.2.3-r1 (24 Feb 2007)
+
+ 24 Feb 2007; Christian Faulhammer <opfer@gentoo.org>
+ +erlang-11.2.3-r1.ebuild:
+ added smp and kpoll USE flags to enable/disable those features, adjusted
+ some bits; thanks to Max Loparyev <max@city.veganet.ru>
22 Feb 2007; Simon Stelling <blubb@gentoo.org> erlang-11.2.3.ebuild:
put back the export-TARGET patch; bug 167909
diff --git a/dev-lang/erlang/erlang-11.2.3-r1.ebuild b/dev-lang/erlang/erlang-11.2.3-r1.ebuild
new file mode 100644
index 000000000000..30f7e002598b
--- /dev/null
+++ b/dev-lang/erlang/erlang-11.2.3-r1.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-11.2.3-r1.ebuild,v 1.1 2007/02/24 11:30:28 opfer Exp $
+
+inherit elisp-common eutils flag-o-matic multilib versionator
+
+# NOTE: You need to adjust the version number
+# in the last comment.
+# If you need symlinks for binaries please tell maintainers or open up a bug
+# to let it be created.
+
+# erlang uses a really weird versioning scheme which caused quite a few problems
+# already. Thus we do a slight modification converting all letters to digits to
+# make it more sane (see e.g. #26420)
+
+# the next line selects the right source.
+MY_PV="R$(get_major_version)B-$(get_version_component_range 3)"
+
+# ATTN!! Take care when processing the C, etc version!
+MY_P=otp_src_${MY_PV}
+
+DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
+HOMEPAGE="http://www.erlang.org/"
+SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
+ doc? ( http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
+ http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
+
+LICENSE="EPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="doc emacs hipe java kpoll odbc smp ssl tk"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ emacs? ( virtual/emacs )
+ java? ( >=virtual/jdk-1.2 )
+ odbc? ( dev-db/unixODBC )"
+DEPEND="${RDEPEND}
+ tk? ( dev-lang/tk )"
+
+S="${WORKDIR}/${MY_P}"
+
+SITEFILE=50erlang-gentoo.el
+
+src_unpack() {
+ ## fix compilation on hardened systems, see bug #154338
+ filter-flags "-fstack-protector"
+ filter-flags "-fstack-protector-all"
+
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-10.2.6-export-TARGET.patch"
+ use odbc || sed -i 's: odbc : :' lib/Makefile
+# epatch "${DISTDIR}"/otp_src_${MY_PV}_epoll.patch
+ epatch "${FILESDIR}/erl_process_dump_R11B-3.patch"
+
+ if use hipe; then
+ ewarn
+ ewarn "You enabled High performance Erlang. Be aware that this extension"
+ ewarn "can break the compilation in many ways, especially on hardened systems."
+ ewarn "Don't cry, don't file bugs, just disable it!"
+ ewarn
+ fi
+}
+
+src_compile() {
+ use java || export JAVAC=false
+
+ econf \
+ --enable-threads \
+ $(use_enable hipe) \
+ $(use_with ssl) \
+ $(use_enable kpoll kernell-poll) \
+ $(use_enable smp smp-support) \
+ || die "econf failed"
+ emake -j1 || die "emake failed"
+
+ if use emacs ; then
+ pushd lib/tools/emacs
+ elisp-compile *.el
+ popd
+ fi
+}
+
+extract_version() {
+ sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
+}
+
+src_install() {
+ local ERL_LIBDIR=/usr/$(get_libdir)/erlang
+ local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
+ local ERL_ERTS_VER=$(extract_version erts VSN)
+
+ make INSTALL_PREFIX="${D}" install || die
+ dodoc AUTHORS EPLICENCE README
+
+ dosym ${ERL_LIBDIR}/bin/erl /usr/bin/erl
+ dosym ${ERL_LIBDIR}/bin/erlc /usr/bin/erlc
+ dosym ${ERL_LIBDIR}/bin/ecc /usr/bin/ecc
+ dosym ${ERL_LIBDIR}/bin/elink /usr/bin/elink
+ dosym ${ERL_LIBDIR}/bin/ear /usr/bin/ear
+ dosym ${ERL_LIBDIR}/bin/escript /usr/bin/escript
+ dosym \
+ ${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call \
+ /usr/bin/erl_call
+ dosym ${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam /usr/bin/beam
+
+ ## Remove ${D} from the following files
+ dosed ${ERL_LIBDIR}/bin/erl
+ dosed ${ERL_LIBDIR}/bin/start
+ cd ${ERL_LIBDIR}/erts-${ERL_ERTS_VER}
+ grep -rle "${D}" "${D}"/${ERL_LIBDIR}/erts-${ERL_ERTS_VER} | xargs sed -i -e "s:${D}::g"
+
+ ## Clean up the no longer needed files
+ rm "${D}"/${ERL_LIBDIR}/Install
+
+ if use doc ; then
+ for i in "${WORKDIR}"/man/man* ; do
+ dodir /usr/share/${i##${WORKDIR}}erl
+ done
+ for file in "${WORKDIR}"/man/man*/*.[1-9]; do
+ # Avoid namespace collisions
+ local newfile=${file}erl
+ cp ${file} ${newfile}
+ # Man page processing tools expect a capitalized "SEE ALSO" section
+ # header
+ sed -i -e 's,\.SH See Also,\.SH SEE ALSO,g' ${newfile}
+ # doman sucks so we can't use it
+ cp ${newfile} "${D}"/usr/share/man/man${newfile##*.}/
+ done
+ dohtml -A README,erl,hrl,c,h,kwc,info -r \
+ "${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
+ fi
+
+ if use emacs ; then
+ pushd "${S}"
+ elisp-install erlang lib/tools/emacs/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ popd
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ elog
+ elog "If you need a symlink to one of erlang's binaries,"
+ elog "please open a bug and tell the maintainers."
+ elog
+ elog "Gentoo's versioning scheme differs from the author's, so please refer to this version as R11B-3"
+ elog
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-lang/erlang/files/digest-erlang-11.2.3-r1 b/dev-lang/erlang/files/digest-erlang-11.2.3-r1
new file mode 100644
index 000000000000..ac72be2ef9bb
--- /dev/null
+++ b/dev-lang/erlang/files/digest-erlang-11.2.3-r1
@@ -0,0 +1,9 @@
+MD5 85bc43e52fa5066577ef412c80848dc0 otp_doc_html_R11B-3.tar.gz 4852262
+RMD160 ed61cb47f1632b5e627a213beaa17652da5ab99c otp_doc_html_R11B-3.tar.gz 4852262
+SHA256 01f1625b4d004b2b30c298d12e286ddbf512d316207fb8859ca598f98c553fb2 otp_doc_html_R11B-3.tar.gz 4852262
+MD5 645ef1ded84b470e9c05a4757dce88cf otp_doc_man_R11B-3.tar.gz 694238
+RMD160 d0f016d2388fad5721280b07634fd49c115b0153 otp_doc_man_R11B-3.tar.gz 694238
+SHA256 ec3ff0f2979ba91d485b37a232ad7d2186829f2948a9f7adcd6067890e55f928 otp_doc_man_R11B-3.tar.gz 694238
+MD5 2806e5a2f26cb1b20f3ea1a6f3ec0276 otp_src_R11B-3.tar.gz 11420612
+RMD160 1ba0cc072d6f33e5f12149ae36e24438a9d70199 otp_src_R11B-3.tar.gz 11420612
+SHA256 7024ca196a5e4a2d80363de1af78051b36de47833e848b812656d552baa5dde2 otp_src_R11B-3.tar.gz 11420612